TS 72 CNDRemoteDevelopment

(Difference between revisions)
Line 12: Line 12:
<br>
<br>
# {{testcase|Add Build host via Services}}
# {{testcase|Add Build host via Services}}
-
##Open Servises tab
+
##Open Services tab
# {{testcase|Add Build host via Tools/Options}}
# {{testcase|Add Build host via Tools/Options}}
##Open Tools->Options->C/C++
##Open Tools->Options->C/C++
Line 23: Line 23:
##*{{result|EXPECTED RESULT: If Password was chosen then Authentication dialog should appear}}
##*{{result|EXPECTED RESULT: If Password was chosen then Authentication dialog should appear}}
##*Enter the password
##*Enter the password
 +
##When host setting is done verify information on Summary step
 +
##*Display Name
 +
##*Platform
 +
##*Hostname
 +
##*User account
 +
##*Tool Collections details
 +
##*Default Tool Collection (OracleSolarisStudio if exists, GNU otherwise)
 +
##*Access ProjectFiles via (System Level File Sharing on Unix/Linux, Automatic copying on Windows)
 +
##Press Finish button to close New Remote Build Host dialog
 +
##Press OK button to close Build Host Manager dialog
 +
##Select the newly added host in Development Host combobox
 +
##Check available tool collections for the selected Build host
 +
##Close Options dialog
<br>
<br>
====Test suite: Create Remote Project====
====Test suite: Create Remote Project====

Revision as of 15:38, 4 April 2012

C/C++ Pack Test Specification for Remote Development

Author: Alexander Pepin
Version: 0.1
Lastupdate: 28.03.2012
Introduction: Test specification for Remote Development support in NetBeans 7.2 C/C++ Pack

Contents


Setup: Shared directories should be created on Unix systems. Samba should be used to allow shared project creation from Windows.

Test suite: Add Build Host

Comment:

  1. Add Build host via Services
    1. Open Services tab
  2. Add Build host via Tools/Options
    1. Open Tools->Options->C/C++
    2. Press Edit button next to Development Host combobox
      • EXPECTED RESULT: Build Host Manager dialog should appear
    3. Press Add button
      • EXPECTED RESULT: New Remote Build Host dialog should appear
    4. Enter host name into Hostname field and change Port if it's needed then press Next
    5. enter Login and choose Authentication type
      • EXPECTED RESULT: If Password was chosen then Authentication dialog should appear
      • Enter the password
    6. When host setting is done verify information on Summary step
      • Display Name
      • Platform
      • Hostname
      • User account
      • Tool Collections details
      • Default Tool Collection (OracleSolarisStudio if exists, GNU otherwise)
      • Access ProjectFiles via (System Level File Sharing on Unix/Linux, Automatic copying on Windows)
    7. Press Finish button to close New Remote Build Host dialog
    8. Press OK button to close Build Host Manager dialog
    9. Select the newly added host in Development Host combobox
    10. Check available tool collections for the selected Build host
    11. Close Options dialog


Test suite: Create Remote Project


  1. Create Remote Project using Automatic copying
  2. Create Remote Project using System level file sharing
  3. Create Sample Remote Project
  4. Create Makefile based Remote Project


Test suite: Build Remote Project


  1. Build Remote Project using Automatic copying
  2. Build Remote Project using System level file sharing


Test suite: Debug Remote Project


  1. Debug Remote Project using Automatic copying
  2. Debug Remote Project using System level file sharing


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo