TS 67 JPDAdbg Miscellaneous

Revision as of 17:34, 5 November 2009 by Admin (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)

Debugger Test Specification for NetBeans 6.7 Part V - Miscellaneous

Author: Emanuel Hucka, NB6.5 revision by Petr Cyhelsky, NB6.7 Beta revision by Filip Zamboj, NB6.7.1/6.8 revision by Vojtech Sigler
Version: 1.5
Lastupdate: 2009/07/22
Introduction: This document describes test specification for testing of debuggerjpda module in NetBeans ide. Debuggerjpda is implementation of most common Java debugger - JPDA. The tests also cover debuggercore module providing basic framework for implementations of all debuggers in IDE.
Comments: There are used test projects MemoryView and freeform and Derive (attached) in test cases.

Contents


Important!! Setup Before You Start Testing

Purpose: Set up your Netbeans before you start testing. Please set up your netbeans in this way before each test!

  1. Setup Debugger Sources (Since version 7.0 M2 there should JDK sources enabled by default. Uncheck them)
    1. Invoke from main panel Window -> Debugger -> Sources
    2. uncheck <JAVA_HOME>/src.zip

Test suite: Miscellaneous

Purpose: Verified a various debugger's functionality
Setup: Start NetBeans IDE with clear userdir Open project MemoryView and project Derive. Set Memory View as main project for now.

  1. Two top level classes in one file - step functionality
    1. Open ClazzOne.java in source editor
    2. Toggle line breakpoint on line 27
    3. Invoke Debug File action from context menu of file in Projects view
    4. Invoke Step Into until debugger finishes
    • EXPECTED RESULT: Debugger will step through constructor of class ClazzTwo and method doit()
    • Teardown: Delete breakpoint
  2. Two top level classes in one file - line breakpoint
    1. Open ClazzOne.java in source editor
    2. Toggle line breakpoint on line 39
    3. Invoke Debug File action form context menu of file in Projects view
    • EXPECTED RESULT: Breakpoint Line ClazzOne.java:39 will be created. Debugger will stop on the breakpoint.
    • Teardown: Finish debugging session and delete breakpoint
  3. Two top level classes in one file - class breakpoint
    1. Open ClazzOne.java in source editor
    2. Place caret on line 33
    3. Invoke New Breakpoint and create class breakpoint
    4. Invoke Debug File action form context menu of file in Projects view
    • EXPECTED RESULT: Breakpoint Class ClazzTwo load / unload will be created. Debugger will stop on line 27 when loading class.
    • Teardown: Finish debugging session and delete breakpoint
  4. Two top level classes in one file - method breakpoint
    1. Open ClazzOne.java in source editor
    2. Place caret on line 39
    3. Invoke New Breakpoint and create method breakpoint
    4. Invoke Debug File action form context menu of file in Projects view
    • EXPECTED RESULT: Breakpoint Method ClazzTwo.doit will be created. Debugger will stop on the breakpoint.
    • Teardown: Finish debugging session and delete breakpoint
  5. Code completion in condition field
    1. Toggle line breakpoint on line 101 of MemoryView.java
    2. Invoke Breakpoint|Properties from context menu of breakpoint annotation in guter
    • EXPECTED RESULT: Breakpoint Properties dialog will be opened. Code completion with context of MemoryView.java file will be possible in Condition field.
    • Teardown: Cancel the dialog and delete breakpoint
  6. Debugging multithreaded application
    1. Open file ThreadSuspending.java in editor
    2. Toggle breakpoints on lines 28 and 38
    3. Create watch i
    4. Invoke Debug|Debug "Thread Suspending.java" menu
    5. When debugger stops on breakpoint, invoke Step Into or Step Over action
    • EXPECTED RESULT: It will be possible to invoke the actions and debugger will not freeze. If the step actions will be dissabled, action Continue will start the debuged process and the breakpoints will be hit again.
    • Teardown: Finish debugging session, delete breakpoints and watch, close the file
  7. Abort debugging session
    1. Invoke Step Into menu
    2. Right click on progress bar in status bar and invoke Cancel Process from the context menu
    • EXPECTED RESULT: Debugged application will be killed and debugger finished.

Test suite: JPDA Debugger Options

Purpose: Verified a various debugger's functionality
Setup: Start NetBeans IDE with clear userdir Open project MemoryView and set it as main project.

  1. - Verify General Settings
    1. Open Tools -> Options -> Java Debugger -> General
    • {{result|EXPECTED RESULT: Verify that following checkboxes are checked:
    1. Open Debugger Console for Debugging Session
  2. Step Filters - Verify Initial Settings
    1. Open Tools -> Options -> Java Debugger -> Step Filters
    • {{{1}}}
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo