TS 60 JDA

Revision as of 17:12, 5 November 2009 by Admin (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)

"Java Desktop Project - Basic Shell" Test Specification for "NetBeans 6.0"

Author: "Jana Maleckova"
Version: "6.0"
Last update: "05/10/0001"
Introduction: "This Test Specification tests wizard for Java Desktop Project - Basic shell. It will generate a basic application skeleton containing everything needed to start with a general desktop application."
Comments: ""

Contents


Test suite: "Test step 1. in wizard for Java Desktop Project - Basic Shell"

Purpose: "This shows Swing Application Framework support in action and creating of Java Desktop Application (Basic shell) wizard. It will generate a basic application skeleton containing everything needed to start with a general desktop application."
Setup: "Start IDE with fresh userdir"

  1. "Invoke Project wizard from File menu"
    1. "Go to File -> New Project"
    2. "Select General node in Categories Tree"
    3. "Select Java Desktop Application in Project tree"
    4. "Press button Cancel on wizard"
    • EXPECTED RESULT: "Nothing was created and no exception was thrown. Description Area contains text "Creates a skeleton of a desktop application based on Swing Application Framework (JSR 296)." when Java Desktop Application node is selected in Project Tree"
  2. "Invoke Project wizard by shortcut"
    1. Press ctrl+shift+N
    2. Select General node in Categories Tree
    3. Select Java Desktop Application in Project tree
    4. Press Escape on keyboard
    • EXPECTED RESULT: Panel "New Project" is opened and user can select Java Desktop Application node in Project tree". When escape keyboard button is pushed, wizard should be closed without any changes and no project should not be created
  3. "Invoke Project wizard by pressing icon File:TS 60 JDA/createProject TS 60 JDA.png"
    1. Select General node in Categories Tree
    2. Select Java Desktop Application in Project tree
    3. Press Help Button
    4. Close Help
    5. Press button next
    • EXPECTED RESULT: Panel "New Project" is opened and user can select Java Desktop Application node in Project tree". Help button should invoke IDE help "New Project Wizard: Choose Project". Next button should open panel named "New Desktop Application" for defining Name and Location of such project. Now exception should be thrown and no project is still created


Test suite: "Test step 2 in wizard for Java Desktop Application"

Purpose: Test if all fields can be filled and all buttons are corretly working
Setup: Go to File -> New Project -> Select General node in Categories Tree -> Select Java Desktop Application in Project tree -> Press button Next

  1. Test Field "Project Name"
    1. Fill name with spaces
    2. Fill name with special characters
    3. Fill name of already existed Project in your directory
    • EXPECTED RESULT: 1. step -> Wizard should warm:"Application Class is not a valid class name", 2. step -> Wizard should warm as well:"Application Class is not a valid class name", 3. step -> Wizard should warm:"Project Folder already exist and is not empty". In all cases wizard should disable finish button, only buttons Back and Cancel are enabled
  2. Test field Project Location
    1. Write wanted project location by hand
    2. Past copied project location
    3. Invoke Project Location browser and select location and cancel it
    4. Invoke Project Location browser and select location and confirm it
    • EXPECTED RESULT: All steps except step no. 3 should pass without any problem and in every case, path should be set correctly. Step 3 should not fill any path. Field Project path is all the time disabled and display path filled in Project Location field
  3. "Test field Application Class"
    1. Fill class name with spaces
    2. Fill class name with special characters
    3. Fill class name but without dot
    4. Fill class name in correct format: e.g. DesktopAppl.DesktopAppl
    • EXPECTED RESULT: steps 1-3 -> wizard should warm, it's not correct name of Application Class. Step 4 should pass
  4. Test Application Shell options
    1. Select by mouse Basic Application
    2. Select by mouse Database Application
    • EXPECTED RESULT: Step 1 -> Basic Application node should be selected and in description win there should be appropriate text about basic skeleton. Buttons Back, Finish, Cancel and Help should by only enabled. Step 2 -> Database Application node should be selected and description win should contained appropriate info as well. Enabled buttons are: Back, Next, Cancel and Help


Test suite: Test - Create Basic Java Desktop Application

Purpose: "To test both steps together"
Setup: "Start IDE with fresh userdir"

  1. Test wizard with default settings
    1. Invoke wizard for New Project - File -> New Project...
    2. Select General node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press next
    5. Press Finish
    • EXPECTED RESULT: No exceptions are thrown and new project DesktoApplication1 is created in user home directory - NetBeansProjects. Project is displayed in Project Window and 3 class are generated in desktopapplication1 package: 1. DesktopApplication.class which is responsible for launch, startup, exit and shutdown of gui, 2. DesktopApplication1Frame.class - simple gui which should represent basic usual desktop application, 3. DesktopApplication1AboutBox.java - represents about window. In Project there are also generated resources with appropriate bundles and required icons: subpackages - resources (contains ResourceBundle of each Class) and resources.busyicons - contains icons designed for processes. Project is set as Main project.
  2. Test wizard with user settings
    1. Invoke wizard by pressing shortcut ctrl+shift+N
    2. Select General node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press next
    5. Fill correct name of Project but different from default (${projectName})
    6. Fill different project location from it's default
    7. Uncheck option - Set as Main Project
    8. Fill correct but different Application Class name
    9. Press Finish
    • EXPECTED RESULT: No exceptions are thrown and new project with name ${projectName} is created in required directory. Project is displayed in Project Window and 3 class are generated in ${projectName} package: 1. ${projectName}.class which is responsible for launch, startup, exit and shutdown of gui, 2. ${projectName}Frame.class - simple gui which should represent basic usual desktop application, 3. ${projectName}AboutBox.java - represents about window. In Project there are also generated resources with appropriate bundles and required icons: subpackages - resources (contains ResourceBundle of each Class) and resources.busyicons - contains icons designed for processes. Project is not set as Main project.
  3. Test cancellation of wizard
    1. Invoke wizard by pressing icon File:TS 60 JDA/createProject TS 60 JDA.png in toolbar
    2. Select General node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press next
    5. Fill correct name of Project but different from default (${projectName})
    6. Fill different project location from it's default
    7. Uncheck option - Set as Main Project
    8. Fill correct but different Application Class name
    9. Press Cancel button
    • EXPECTED RESULT: Wizard should be closed and no project is created
  4. Test buttons Back and Next
    1. Invoke wizard by pressing shortcut ctrl+shift+N
    2. Select General node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press next
    5. Fill correct name of Project but different from default (${projectName})
    6. Fill different project location from it's default
    7. Fill correct but different Application Class name
    8. Press Back button
    9. Press Next button
    10. Press Finish button
    • EXPECTED RESULT: Project should be created in chosen location and should have structure described in TestCase no. 2. If user push back button on the second step and then he returns back , all previous settings on this card should not be changed.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo