TFTCL10nUc

Revision as of 16:57, 5 November 2009 by Admin (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)

ML Update Center Test Specification for 6.0.1

Author: Masaki Katakai
Version: 1.1
Lastupdate: 2008/01/16
Introduction: 6.0.1 Update Center is providing IDE modules by default. It means IDE modules can be installed additionaly after IDE is installed. For example, if someone just installed only Java SE, but he can install Ruby from Update Center. These modules should be localized. Pure Update Center modules e.g. collab are not localized at 6.0.1, will be localized after 6.0.1 release.

Contents

Test suite: ML Update Center

Purpose: Verify the localized bits on Update Center.
Setup:

  1. Plugin dialog
    • Setup:
    1. Install just Java SE
    2. Tools | Plugin
    3. Check updates
    • EXPECTED RESULT: Other modules e.g. Ruby should be displayed on Update Center and can be installed
  2. Install IDE modules from Update Center
    • Setup:
    1. Install only Java SE
    2. Tools | Plugin
    3. Install Ruby from Updates
    • EXPECTED RESULT: Ruby modules will be installed and all UI messages should be localized.
  3. Uninstall then install from Update Center
    • Setup:
    1. Install All IDE
    2. Tools | Plugin
    3. Uninstall some modules e.g. Ruby
    4. Tools | Plugin and check updates
    5. Removed modules should be available
    6. Select them and install
    • EXPECTED RESULT: The modules are installed. Check All UIs are localized.

}}
}}

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo