NetBeans 81 Import Settings Test

(Difference between revisions)
Jkovalsky (Talk | contribs)
(Initial version of Import Settings Test page for NetBeans 8.1.)
Newer edit →

Revision as of 21:02, 7 October 2015


Vanilla Start Import Test

  1. Launch appropriate NetBeans 8.0, 8.0.1 or 8.0.2 version.
  2. Invoke File > Open Project... from main menu, select some of your existing projects and push Open Project button.
  3. Invoke Tools > Options from main menu.
  4. Switch to assigned options category(ies) and change some setting(s).
  5. Push OK button to save the options and File > Exit the IDE.
  6. Delete your $HOME/.netbeans/8.1rc directory.
  7. Launch NetBeans 8.1 RC, accept license agreement and push Yes in Confirm Import Settings dialog.
  8. Verify that project opened in step 2 was opened in the IDE.
  9. Repeat step 3 and verify that all settings changed in step 4 were imported correctly.

ZIP Export/Import Test

  1. Launch appropriate NetBeans 8.0, 8.0.1 or 8.0.2 version.
  2. Invoke Tools > Options from main menu.
  3. Switch to assigned options category(ies), change some setting(s) and push Apply button.
  4. Push Export... button, check some but not all changed option categories to export, remember what you checked and push OK button.
  5. Push Cancel button to close the Options window and File > Exit the IDE.
  6. Delete your $HOME/.netbeans/8.1rc directory.
  7. Launch NetBeans 8.1 RC, accept license agreement and push No in Confirm Import Settings dialog.
  8. Repeat step 2, push Import... button, select .netbeans.zip file in Select Options to Import dialog and push OK button.
  9. In Import Confirmation dialog push Yes button and wait until IDE is restarted.
  10. Verify that all exported settings changed in step 3 were imported correctly. Also verify that settings changed in step 3 which were not exported in step 4 are set to their default values.

Userdir Import Test

  1. Launch appropriate NetBeans 8.0, 8.0.1 or 8.0.2 version.
  2. Invoke File > Open Project... from main menu, select some of your existing projects and push Open Project button.
  3. Invoke Tools > Options from main menu.
  4. Switch to assigned options category(ies) and change some setting(s).
  5. Push OK button to save the options and File > Exit the IDE.
  6. Delete your $HOME/.netbeans/8.1rc directory.
  7. Launch NetBeans 8.1 RC, accept license agreement and push No in Confirm Import Settings dialog.
  8. Repeat step 3, push Import... button, push Browse... button, select either 8.0, 8.0.1 or 8.0.2 userdir and push OK button.
  9. Let all option categories checked in Select Options to Import dialog and push OK button.
  10. In Import Confirmation dialog push Yes button and wait until IDE is restarted.
  11. Verify that project opened in step 2 was opened in the IDE.
  12. Repeat step 3 and verify that all settings changed in step 4 were imported correctly.
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo