NetBeansRequiresAtLeastJDK7

(Difference between revisions)
(Launchers)
m
Line 1: Line 1:
-
= Increase of minimum version of Java for running NetBeans =
+
== Increase of minimum version of Java for running NetBeans ==
-
 
+
-
'''''Not final yet!!!'''''
+
Dropping JDK 6 as a version for installing and running NetBeans IDE allows to fully use  features of JDK 7 - see [[CorePlanNext#Features_of_Java_7_we_would_like_to_use]]
Dropping JDK 6 as a version for installing and running NetBeans IDE allows to fully use  features of JDK 7 - see [[CorePlanNext#Features_of_Java_7_we_would_like_to_use]]
Line 7: Line 5:
This change requires changes in several areas:
This change requires changes in several areas:
-
=== Building sources, Build jobs ===
+
=== Building sources, Hudson build jobs ===
 +
(PetrG)
* ant scripts for building IDE
* ant scripts for building IDE
** <code><root-netbeans-repository>/build.xml</code>
** <code><root-netbeans-repository>/build.xml</code>
-
* Hudson configuration
+
* Hudson jobs configuration
=== Installers ===
=== Installers ===
 +
(Jirka)
* Change of the minimum version
* Change of the minimum version
* Download page
* Download page
=== Launchers ===
=== Launchers ===
 +
(Jirka, Libor)
* Change of the minimum version
* Change of the minimum version
 +
** ''Mac:'' [[FaqMacJdkHome | How to use Java 6 on Retina Displays]]
=== Docs ===
=== Docs ===
-
* [[WorkingWithNetBeansSources]]
+
* wiki.netbeans.org
 +
** [[WorkingWithNetBeansSources]]
 +
** ...
* Installing instruction
* Installing instruction

Revision as of 08:33, 8 February 2013

Contents

Increase of minimum version of Java for running NetBeans

Dropping JDK 6 as a version for installing and running NetBeans IDE allows to fully use features of JDK 7 - see CorePlanNext#Features_of_Java_7_we_would_like_to_use

This change requires changes in several areas:

Building sources, Hudson build jobs

(PetrG)

  • ant scripts for building IDE
    • <root-netbeans-repository>/build.xml
  • Hudson jobs configuration

Installers

(Jirka)

  • Change of the minimum version
  • Download page

Launchers

(Jirka, Libor)

Docs

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo