MercurialVersionControl OlderReleases

Revision as of 13:22, 5 November 2009 by Admin (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)

Releases

Release 1.4.3 for Mercurial 0.9.4 and NetBeans 6.0 - 14th December 2007

The Mercurial Plugin rev 1.4.3 is available from the NetBeans 6.0 Stable Update Center.
Supported features

  • Respin to address two issues:
  • Clone Other, support optional username and password for HTTP #122133
  • Annotation issue, popup failing on multi line commit comments #123787

Release Notes

Release 1.4.2 for Mercurial 0.9.4 and NetBeans 6.0 - 11th December 2007

The Mercurial Plugin rev 1.4.2 is available from the NetBeans 6.0 Stable Update Center.
Supported features

  • Previous Releases
  • Status, Diff, Update, Commit, Clone local repository, Push/Pull local repository, Clone Other, Push/Pull Other, Export/Import patches, Show Annotations, Show History, View, Rollback, Revert Modifications, Ignore, Properties, Options, Merge and Resolve Conflicts, Help and i18n
  • New
  • Performance enhancements and better support for Merge on Mac OS. Refer to release notes.
  • Note: Mercurial Options moved to be consistent with CVS and SVN:
  • NetBeans 6.0: Tools > Options > Miscellaneous > Versioning: Mercurial

Release Notes

Prerequsites

Release

  • Available from NetBeans 6.0 Stable Update Center. Just go to Tools/Plugins -> Available Plugins, select Mercurial and click on Install.

Feeback

  • nb-mercurial - Please feel free to try it out, and send your feedback.

Issues

Release 1.4.1 for Mercurial 0.9.4 and NetBeans 6.0 RC 1 - 16th November 2007

The Mercurial Plugin rev 1.4.1 is available from the NetBeans 6.0 RC Stable Update Center.
Supported features

  • Previous Releases
  • Status, Diff, Update, Commit, Clone local repository, Push/Pull local repository, Clone Other, Push/Pull Other, Export/Import patches, Show Annotations, Show History, View, Rollback, Revert Modifications, Ignore, Properties, Options, Merge and Resolve Conflicts, Help and i18n
  • New
  • Better support for Merge on Windows OS. Refer to release notes.
  • This is primarily a bug fix release, addressing most of the issues listed in Release Notes 1.4

Release Notes

Prerequsites

Release

  • Available from NetBeans 6.0 RC 1 Update Center. Just go to Tools/Plugins -> Available Plugins, select Mercurial and click on Install.

Feeback

  • nb-mercurial - Please feel free to try it out, and send your feedback.

Issues

Release 1.4 for Mercurial 0.9.4 - 19th October 2007

The Mercurial Plugin rev 1.4 is available from the NetBeans 6.0 Beta 2 Stable Update Center. This new release has gone through more extensive QA and meets the criteria to be posted on the Stable Update Center, including i18n support.
Supported features

  • Previous Releases
  • Status, Diff, Update, Commit, Clone local repository, Push/Pull local repository, Export/Import patches, Show Annotations, Show History, Rollback, Revert Modifications, Ignore, Properties, Options
  • New
  • Clone Other, Push/Pull Other - supports cloning and push/pull to remote repository
  • Merge and Resolve Conflicts - supports merging of push/pull changes and resolution of conflicts using the resolve conflicts editor
  • View - limited support to launch Hgk dependency graph viewer for a repository, see release notes.
  • Help - some JavaHelp has been added, more to follow
  • i18n - this support has been added to allow support for future translations into different locales.

Release Notes

Prerequsites

Release

  • Available from NetBeans 6.0 Beta 2 Update Center. Just go to Tools/Plugins -> Available Plugins, select Mercurial and click on Install.

Feeback

  • nb-mercurial - Please feel free to try it out, and send your feedback.

Issues

Release 1.3 for Mercurial 0.9.4 - 19th September 2007

The Mercurial Plugin rev 1.3 is available from the NetBeans 6.0 Beta 1 Update Center. It is a development snapshot of the work in progress for the 2.0 release, so has not undergone the same level of QA as the 1.0 release, but we are using it on a daily basis and it is quite stable. As well as some important bug fixes, new features include, Merge support and optimization for large projects. Some Remote repository support has been added to allow you to Clone from a remote repository and Pull from a remote repository (Versioning/Clone Other... and Versioning/Pull Other...).
Prerequsites

Release

  • Available from NetBeans 6.0 Beta 1 Update Center. Just go to Tools/Plugins -> New Plugins, select Mercurial under Versioning and click on Install.

Known Issues

  • Problems committing deletion #117632 - due to refactoring of the refresh cache code if you delete a file and commit the deletion it persists in the cache and so continues to be visible in the Status Window. The workaround is:
  • Either to right click on the deleted file and press Commit, then the status of the deleted file is updated correctly or
  • If already committed is to right click on the file and run Status again, this forces a refresh of the cache. This issue is fixed in CVS head.

Release 1.1 for Mercurial 0.9.3 - 22nd June 2007

The Mercurial Plugin rev 1.1 is available from the NetBeans 6.0 m10 Preview Update Center. It is a development snapshot of the work in progress for the 2.0 release, so has not undergone the same level of QA as the 1.0 release, but we are using it on a daily basis and it is quite stable. As well as some important bug fixes, new features include, Project Properties (username, push/ pull default paths) and Global Options support (username, Hg exe location, status labels), Revert to specific revision support (both on Status panel and context menus), ignore support and Export/ Import of diff patches. We are also working on Remote Repository support and merge support, but they are not available in this build.
Prerequsites

Release
Available from NetBeans 6.0 m10 Development Update Center. Just go to Tools/Plugins -> New Plugins, select Mercurial under Versioning and click on Install. Note: make sure you have Mercurial 0.9.3 installed or you will just see an empty Mercurial menu when the plugin is installed.

Release 1.0 for Mercurial 0.9.3 - 7th May 2007

The Mercurial Plugin rev 1.0 is live on NetBeans 6.0 Dev Update Center, as well as to the NetBeans 6.0 m9 Preview Update Center. It focuses on the basic workflow of working with local repositories directly from the IDE. Refer to What's in Rev 1.0 below to see details of supported features and the Demo Script for some guidance on how to use it.
Mercurial Plugin
Prerequsites

Release
Available from NetBeans 6.0 m9 Development Update Center. Just go to Tools/Plugins -> New Plugins, select Mercurial under Versioning and click on Install. Note: make sure you have Mercurial 0.9.3 installed or you will just see an empty Mercurial menu.

Feeback

  • nb-mercurial - Please feel free to try it out, and send your feedback.

Release Notes

Issues


Events

Release 1.0 Key dates

Milestone Date Status Comment
Start Dev 07/03/07 Done Start development of Mercurial plugin, based on the skeleton created by Maros Sandor from the Subversion module - JR and POB
Feature Freeze 26/04/07 Done Create rc1 build against NetBeans 6.0 Preview m9 and post to wiki
Code Complete 02/05/07 Done NetBeans QA Team perform test cycle against OpenSolaris(nevada b61), Linux (Fedora) and Windows
Release to RE 04/05/07 Done Released to RE team for upload to Dev Update Center
Go Live Date 07/05/07 Done Available on Development and Milestone 9 Update Centers for NetBeans 6.0. Announce release at NetBeans day and on NetBeans.org


What's in Rev 1.0

The current version of the module focuses on the basic workflow of working with local repositories directly from the IDE. It integrates well with the latest NetBeans 6.0 versioning features such as editable diff / inline diff, versioning view, status annotations, etc.

Menu Support

Available from Top Level Versioning menu and from Project context menu. Only Create is available for Projects not under Hg control. Other menus items are displayed as appropriate for Hg controlled projects.

Menu Target Status Comment
Create 1.0 Done Puts NetBeans project under Hg control, adds all project files to repository, user needs to commit them.
Clone - <selected_project_dir> 1.0 Done Clones selected project to <project_dir>_cloneX and opens this project. Note: cloned project is not renamed and though you can do it it is not supported. Renaming a cloned project will cause issues when doing a push back to the source project, it will rename the source which is not desired. This issue will be addressed in Release 2.0.
Status 1.0 Done Opens a Status window and displays all local changes in the repository or selected files. Users can Update All, Diff All and Commit All from the Status Window. Right click menu support allows users to Open, Diff, Commit, Show Annotations
Diff 1.0 Done Diffs the selected locally modified file(s) against the repository tip revision. Show the Base revision and changeset ID you are diff'ing against.
Update 1.0 Done Updates Hg repository, this has the effect of reverting locally removed and deleted files in the working directory.
Commit 1.0 Done Brings up a Commit Dialog to allow a commit message to be entered for the selected locally changed files to be committed. Users can exclude a file from the commit if they wish in the dialog Action column.
Rollback 1.0 Done Rollback the last transaction in the repository. Will work for commit, push and pull (also works for import and unbundle, but these are not available in this release).
Push to - default 1.0 Done Push changes from the selected project to the default target repository that it was cloned from. Note: in this initial release we do not plan to handle merge, we will just report that a merge is required.
Pull from - default 1.0 Done Pull changes from the default target repository that the selected project cloned from. Will update the working directory if a merge is not required. If a merge is needed the user is warned and they need to do a hg merge from the command line.
Add 1.0 Done Mark the selected file(s) to be added to the Hg repository on next commit. This is only required for locally new files. When we create a project its project files are automatically made locally added as are renamed files.
Delete 1.0 Done Marks the selected file(s) for removal from the Hg repository on next commit. Not a Mercurial menu, overrides the standard Delete menu.
Show History 1.0 Done Show history for the repository or selected file(s). Lists all the changesets and their details in a labeled Output tab.
Show Annotations 1.0 Done Show annotations, changes made and by whom for a selected file.


Other 1.0 Features

Feature Target Status Comment
Logging 1.0 Done Use JDK Logger to output diagnostics, see logging in NetBeans
Project Status View 1.0 Done The project view reflects the status of mercurial controlled files and is automatically kept in sync with the status panel if visible. Black: Versioned & Uptodate; Yellow: Locally New; Green: Locally Added; Blue: Locally Modified; Red: Locally Removed; Gray: Ignored.
Inline Diff 1.0 Done Support inline diff between files in the working directory and the repository. In the edit window the diffs are indicated in the left hand side bar colored annotations, hovering over them shows the diff and available actions.


Release 1.5

We plan to release incremental 1.x updates over the next few months on the Dev Update center as we move to a 2.0 release. The goal is to support common use cases and working with remote repositories for the 2.0 release.

  • Use Cases
  • We want to work with the mercurial community to figure out common use cases and how we might best support them
  • UI Spec for the various use cases
  • Remote Support
  • Clone from remote repository
  • Push/Pull to/from remote repository
  • Sharing
  • Sharing changes through export of diffs.
  • Revision
  • Support working with revisions - give user simple way from Status Panel to Update working dir to specific revision
  • Hg view - support launching of Hg View if available on the platform to see revision dependency tree.
  • Merge
  • Provide Merge support, either with external tool and/or with the built in NB merge support.
  • Configuration
  • Support Global Hg options, such as username
  • Support Repository Properties such as Push/Pull Paths and overriding Global username
  • Nested Project Support
  • Many large NetBeans projects contain multiple sub projects, but only need one repository. We need to support these type of super Hg projects.
  • C++ Support
  • Work with the NetBeans C++ Plugin so we can support C/C++ code bases such as OpenSolaris onnv.

Additional Menu Support

Menu Target Status Comment
Clone other... 2.0 TBD Clones project from a specified Hg repository either local or remote and opens this project
Export Diff 2.0 TBD Exports the diffs from this repository tip.
Push other... 2.0 TBD Push changes from the selected project to the specified repository.
Pull other... 2.0 TBD Pull changes from the specified repository to the selected project.
Ignore 2.0 TBD Allow user to specify file(s) to be ignored by mercurial.
View 2.0 TBD Launch the Hg view if it is supported on the platform. This uses the Hgk binary, which is currently not available on OpenSolaris.
Properties 2.0 TBD Provide a Properties dialog to set Mercurial project specific settings such as default path for Push/Pull, files to ignore and so on.


Development Builds

  • Getting the Mercurial Plugin Rev 1.0 now:
  • Installing the Mercurial Plugin
  • If you have an earlier version of the plugin please uninstall and restart the IDE (upgrade will be supported in future releases).
  • Launch the NetBeans 6.0 m9 IDE:
  • Under Tools -> Plugins, select Downloaded tab, click on Add Plugins, browse to the Mercurial Plugin org-netbeans-modules-mercurial.nbm file you downloaded, select and click on Install. It is not signed so ignore the Validation warning. You must restart the IDE to use the plugin.
  • Note: If you are behind a firewall and haven't setup proxy settings for the IDE you get an Error which you can just cancel.
  • Testing the Mercurial Plugin
- queries for mercurial, New, Started, Reopened.
  • Uninstalling the Mercurial Plugin
  • Launch the NetBeans 6.0 m9 IDE:
  • Under Tools -> Plugins, select Installed tab, click on the Mercurial Plugin and click on Uninstall.
  • You should restart the IDE at this point. Mercurial menu items are still available after uninstall and before a restart #103214

Development Source

The latest Mercurial module is always available from the NetBeans cvs: cvs -d :pserver:anoncvs@cvs.netbeans.org:/shared/data/ccvs/repository co -r mercurial versioncontrol/mercurial

Building from Source

To try out the latest sources in NetBeans head you need to do the following:

Check Out:

  • Check out the latest NetBeans 6.0 milestone build, and use this for building the stable branch below.
  • Make sure to set your jdk_home to JDK 1.5.
  • Check out the latest stable NetBeans build:
  • cvs -d :pserver:anoncvs@cvs.netbeans.org:/shared/data/ccvs/repository co -P stable_nowww
  • Check out the latest Mercurial module:
  • cvs -d :pserver:anoncvs@cvs.netbeans.org:/shared/data/ccvs/repository co -r mercurial versioncontrol/mercurial

Build:

  • cd netbeans/nbbuild
  • ant build-nozip

Run:

  • Launch NetBeans 6.0 - Open Project versioncontrol/mercurial
  • Right click on Mercurial and Build with dependencies
  • Run - IDE launches and under Versioning see Mercurial submenu


Release Notes

  • Please increment the version (e.g. to 1.0.1.42.1) every time you publish a distinct NBM. AU does not recognize changes to NBMs unless the version is incremented. The workaround is to uninstall the old module and then install the new one, rather than to upgrade directly (jglick).
  • Tag the cvs branch for each published release. This was not done for earlier rc candidates.
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo