Fedora/How To/Parallel Installation of the NetBeans Platform versions

(Difference between revisions)
(Created page with '== How to install two (or more) versions of the NetBeans Platform? == === Prerequisites === === Limitations === === Actions === # Install a primary version '''N''' of the NetB…')
Line 1: Line 1:
-
== How to install two (or more) versions of the NetBeans Platform? ==
+
== How to install two (or more) versions of the NetBeans Platform on Fedora? ==
=== Prerequisites ===
=== Prerequisites ===
-
=== Limitations ===
+
=== Limitations and Warnings ===
 +
 
 +
{{warning|Please, be careful with updating of the packages that are installed according to these instructions. During update '''the old versions of the packages may be erased without any warning messages'''. <br /> To avoid this situation you can update a packages manually via the rpm tool by execution of erase and install procedures sequentially.}}
=== Actions ===
=== Actions ===
# Install a primary version '''N''' of the NetBeans Platform. [[Fedora/How_To/Install_NetBeans_Platform| How to install...]]
# Install a primary version '''N''' of the NetBeans Platform. [[Fedora/How_To/Install_NetBeans_Platform| How to install...]]
# A command for the next step depends on a secondary version.  
# A command for the next step depends on a secondary version.  
-
#* In a case, if a secondary version is lesser than the already installed primary version, e.g. the secondary version is 6.5, and  primary version is 6.7.1, i.e 6.5 < 6.7.1, then the following rpm command with the option --oldpackage should be used: <pre># rpm -ivh --oldpackage $NETBEANS_PLATFORM_PACKAGE_FILE</pre> where $NETBEANS_PLATFORM_PACKAGE_FILE is a desired NetBeans Platform binary RPM package file.
+
#* In a case, if a secondary version is lesser than the already installed primary version, e.g. the secondary version is 6.5, and  primary version is 6.7.1, <br /> i.e 6.5 < 6.7.1, then the following rpm command with the option --oldpackage should be used: <pre># rpm -ivh --oldpackage $NETBEANS_PLATFORM_PACKAGE_FILE</pre> where $NETBEANS_PLATFORM_PACKAGE_FILE is a desired NetBeans Platform binary RPM package file.
-
#* Otherwise, if a secondary version is greater than the already installed primary version, e.g. the secondary version is 6.8, and  primary version is 6.7.1, i.e 6.8 > 6.7.1, then the rpm command with the option --oldpackage should be used. [[Fedora/How_To/Install_NetBeans_Platform/RPM_Package_Manager|How to install...]]
+
#* Otherwise, if a secondary version is greater than the already installed primary version, e.g. the secondary version is 6.8, and  primary version is 6.7.1, <br /> i.e 6.8 > 6.7.1, then the rpm command with the option --oldpackage should be used. [[Fedora/How_To/Install_NetBeans_Platform/RPM_Package_Manager|How to install...]]

Revision as of 22:16, 13 February 2010

Contents

How to install two (or more) versions of the NetBeans Platform on Fedora?

Prerequisites

Limitations and Warnings

Please, be careful with updating of the packages that are installed according to these instructions. During update the old versions of the packages may be erased without any warning messages.
To avoid this situation you can update a packages manually via the rpm tool by execution of erase and install procedures sequentially.

Actions

  1. Install a primary version N of the NetBeans Platform. How to install...
  2. A command for the next step depends on a secondary version.
    • In a case, if a secondary version is lesser than the already installed primary version, e.g. the secondary version is 6.5, and primary version is 6.7.1,
      i.e 6.5 < 6.7.1, then the following rpm command with the option --oldpackage should be used:
      # rpm -ivh --oldpackage $NETBEANS_PLATFORM_PACKAGE_FILE
      where $NETBEANS_PLATFORM_PACKAGE_FILE is a desired NetBeans Platform binary RPM package file.
    • Otherwise, if a secondary version is greater than the already installed primary version, e.g. the secondary version is 6.8, and primary version is 6.7.1,
      i.e 6.8 > 6.7.1, then the rpm command with the option --oldpackage should be used. How to install...
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo