FaqJ2MEDevelopMIDP10With20EmulatorJa

(Difference between revisions)
(Created page with '__NOTOC__ ===どうしたらエミュレータが MIDP2.0 だけをサポートするときの MIDP 1.0 準拠のアプリケーションを開発することができますか?=…')
 
(One intermediate revision not shown)

Current revision as of 17:08, 6 November 2009

どうしたらエミュレータが MIDP2.0 だけをサポートするときの MIDP 1.0 準拠のアプリケーションを開発することができますか?

さて、SDKが、それが MIDP 2.0 であると言うなら、それは MIDP 2.0 のクラスを classpath に提供することを意味します。下位互換として、MIDP 2.0 SDK と共にMIDP 1.0 をコンパイルして、実行することができます。 NetBeansでは、SDK が MIDP 2.0 専用であるなら、まだアプリケーション記述子/マニフェストのプロパティーを変えることができます - プロジェクトのプロパティー > アプリケーション記述子 > 属性 > 追加 > MicroEdition-Profile を選んで、MIDP-1.0 を設定してください。 唯一の問題は、MIDP 2.0 のクラスを自身が使用していないかどうかチェックしなければならないことにあります。 なぜなら IDE がコード補完とコンパイルに SDK の classpath を使用しているので、残念ながらその classpath が MIDP 2.0 であるからです。


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo