VwpFaqNewbrowserJa

Visual Web Pack IDE で、すでに開いているブラウザを保持したまま、新しいブラウザウィンドウを開く方法を教えてください。

Visual Web Pack IDE がブラウザウィンドウに内容を表示する必要があるときに、すでにブラウザウィンドウが 1 つ開いている場合、デフォルトでは、IDE は開いているブラウザウィンドウを再利用します。 開いているブラウザウィンドウの URL は、IDE が開く URL に置き換わります。 IDE が新しいブラウザのタブまたは新しいブラウザウィンドウを使用するには、次のようにブラウザの設定を変更する必要があります。


Mozilla 1.x または Netscape 7.x の場合:

アプリケーションを配備する前に、次のように新しいタブを開く必要があります。

  • 「ファイル」>「新規作成」> 「Navigator タブ」を選択して、ブラウザウィンドウに新しいタブを開きます。

IDE によって新しいタブが使用され、すでに開いている URL は変更されません。

Firefox 1.x の場合:

  1. 「ツール」>「オプション」を選択し、「オプション」ダイアログを開きます。
  2. 「タブ」をクリックし、「他のアプリケーションからのリンク」区画で「新しいタブで開く」ラジオボタンを選択します。
  3. 「OK」をクリックしてダイアログを閉じます。

IDE によって新しいタブが使用され、すでに開いている URL は変更されません。

Firefox 2.x の場合:

  1. 「ツール」>「オプション」を選択して、「オプション」ダイアログを開きます。
  2. 「タブ」をクリックします。
  3. 「新しいページは次の場所に開く」区画で「新しいタブで開く」ラジオボタンを選択します。
  4. 「OK」をクリックしてダイアログを閉じます。

Firefox 1.x と同様に、IDE によって新しいタブが使用され、すでに開いている URL は変更されません。

Internet Explorer の場合:

  1. 「ツール」>「インターネットオプション」を選択し、「インターネットオプション」ダイアログを開きます。
  2. 「詳細設定」タブを開き、「ブラウズ」の下の「ショートカットを起動するためにウィンドウを再使用する」を選択解除します。
  3. 「OK」をクリックしてダイアログを閉じます。

これで IDE がブラウザウィンドウを使用するときは、新しいブラウザウィンドウが開きます。

Internet Explorer についての 2 つの補足:

  1. 同じプロジェクトの再配備で反復開発を実行するときに、Internet Explorer ではいつも新しいブラウザウィンドウが開くわけではありません。この場合、手動でブラウザの「更新」ボタンを押して、変更を確認してください。
  2. 複数のプロジェクトを (1 つずつ) 配備するとき、今配備しようとしているプロジェクトが IDE で主プロジェクトとして設定されていることを確認してください。たとえば、メニュー項目「ファイル」>「主プロジェクトとして設定」>「<プロジェクト名>」を選択します。こうすることで、プロジェクトごとに別のブラウザウィンドウが開きます。

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo