UpdatingWoodstockLibraryInNetBeans6

Contents

Updating Woodstock Component Library in NetBeans 6

NetBeans 6.0 bundles with Woodstock 4.1 FCS. By default, only a subset of the woodstock components (with red checks) are displayed in the palette. Notice that Grid Panel and Page Fragment Box components are not Woodstock components.

If you want the rest of the components (the ones in red circles) to also be added in the palette or if you need to pick up a fix made available after Woodstock 4.1 FCS, then proceed with the following few steps.

NOTE: 4.1.1 Woodstock components cannot be plugged into NB6 GA. Rather a 4.1.1 Woodstock component upgrade is available on NetBeans Update Center as of January 8, 2008. Once the update has been made, you can follow these instructions to update the Woodstock Component Library to get the rest of the components (again circled in red).


File:palette-comparison_UpdatingWoodstockLibraryInNetBeans6.JPG

Get The Plugins

There are two plugins for the Woodstock components:

  • org-netbeans-modules-visualweb-webui-jsf-defaulttheme.jar
  • org-netbeans-modules-visualweb-woodstock-webui-jsf.jar.

They can be either downloaded from java.net or built by yourself.

Download The Plugins

Go to the Woodstock Project on java.net. Download the NetBeans 6 Components and Theme plugins and save them to your favorite location. Important note: since there is a bug in the NetBeans plugins included in Woodstock 4.1 FCS, you have to download the ones from Woodstock release 4.1.1 or later. Now you're ready to install them.

Build The Plugins Yourself

The other way to get the plugins is to do the build yourself. First follow the instructions described on the Woodstock Project to checkout the source code. When you have all the source code ready, open the woodstock/ide-plugins/netbeans/woodstock-suite project in your NetBeans 6.0 IDE. Right-click on woodstock-suite project node and select Create NBMs. File:createnbms_UpdatingWoodstockLibraryInNetBeans6.JPG This will take a few minutes. You'll get some errors/warnings from the annotation process. Don't worry about them. After the build finishes, you'll see the two plugins are created under woodstock/ide-plugins/netbeans/woodstock-suite/build/updates. Now you're ready to install them.

Install The Plugins

Start your NetBeans 6.0 IDE. In the main menu, go to Tools > Plugins. It'll bring up the Plugin dialog. Go to the Downloaded tab and click on the Add Plugins... button. Browse to the location of your plugins and install them. Restart the IDE when finishing installing the plugins. File:pluginsdialog_UpdatingWoodstockLibraryInNetBeans6.JPG

Check Out The Palette

Create a new Visual Web JavaServer Faces project or open an existing one, all the Woodstock components should be shown in the palette. The newly added components are in the Composite category.

Roll Back To The Previous Version

Once you have installed the new version, you can not roll back to the previous version. This is not supported in NetBeans 6. However there is a way to get the original bundled version back.

  • In the main menu, go to Tools > Plugins
  • In the Plugins dialog, go to the Installed tab. Uninstall the Visual JSF plugin and restart the IDE.
  • Bring up the Plugins dialog again. Go to the Availble Plugins tab. Install the Visual JSF plugin and restart the IDE. Now you have the original Woodstock component library back.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo