TS 7 WindowSystem

Window System Test Specification for NetBeans 7

Author: Tomáš Tököly
Last update: 14.2.2012
Introduction: This is test specification for Netbeans 7 Window System and it covers the vast majority of Window System function. It is based on old TS for NetBeans 6.5.

Contents


Test suite: Main Window layout

Setup: Start IDE with clear userdir.

  1. Startup windows layout
    1. Run IDE. Check result.
    2. Close Start page. Check result.
  2. Main menu Window
    1. Activate installed plugins (main menu Tools | Plugins, card Installed, select all visible plugins, click on Activate, confirm Activate once again, wait, than click on Finish and Close)
    2. Check consistency of main menu Window.
  3. Main menu View
    1. Check consistency of main menu View.
    • EXPECTED RESULT: View menu and submenus should be defined in UI specification, but there could be obsolete information.
      Actual list of menu items you should be able find here:
      main menu View and submenus Editors, Code Folds and Toolbars. There should be list of All Windows. But submenus Editors and Code Folds may be unactive. You can activate Editors by opening of some form file and Code Fold e.g. by opening of some java file.


Test suite: Window

Setup: Start IDE with clear userdir.

  1. Menu Access by Shortcuts
    1. Try open some windows from main menu Window by shortcuts.
    2. Change some shortcuts to other then default and try them (main menu Tools | Options, card Keymap, change shortcut for e.g. Files and Favorites and push OK).
    3. Restart IDE and try them once more.
    • EXPECTED RESULT: Proper windows are opened. There is only one instance of each window. Each window has its own item in menu Window. No icon is displayed in the header of Window. Newly changed shortcuts works well, old (default) shortcuts stopped working. After the restart shortcuts works just as before the restart.
  2. Persistence of Window System - Files - close
    1. Open Files and expand some nodes.
    2. Remember selected node, expanded tree and scrollbar positions.
    3. Close Files (by pushing on close button from header of Files).
    4. Open Files (by pushing main menu Window | Files).
    • EXPECTED RESULT: Files is opened at the same position as it has been before close. The same node is selected and scrollbars have the same positions as before close.
  3. Base name vs. Descriptive name
    1. Open Properties window from main menu Window | IDE Tools | Properties.
    2. Select some node in Files (you must open or create some project first).
    • EXPECTED RESULT: Base name (menu item in the Window menu) is still the same "Properties", but Descriptive name (window's title bar) has changed "selected file - Properties".
  4. Close window - 4 ways how to do it
    1. Before each close open Services window from main menu Window | Services.
    2. By close button: push close button in the Services window header.
    3. By contextual menu: from contextual menu of Window push Close Window.
    4. By main menu: from main menu push Window | Close Window.
    5. By shortcut: press shortcut for Close Window action (Ctrl+W).
    • EXPECTED RESULT: Each time when you perform closing, the Services (and only Services) window is closed.
  5. Maximize and Restore window
    1. Open Services window from main menu Window | Services.
    2. Maximize it by double click on header of Services window. Restore the window by doubleclick on header once again. Check result.
    3. Maximize it once again by shortcut (Shift+Escape). Restore the window by pressing shortcut (Shift+Escape) one last time.
    • EXPECTED RESULT: Each time, when you perform maximizing, the Services window is maximized, selected and activated. Files and Projects tab are minimized on the left side of screen. Contextual menu and main menu Window | Configure Window contains checked Maximize. And each time, when you perform restoring, the Services window (whole window consists of Files and Services tab) is restored and Services Window is selected and activated. Contextual menu and main menu Window | Configure Window contains unchecked Maximize.
  6. Persistence of maximized window - restart
    1. Open Services window from main menu Window | Services.
    2. Doubleclick on header of Services window.
    3. Restart IDE.
    • EXPECTED RESULT: Services window is maximized, selected and activated. Contextual menu and main menu Window | Configure Window contains checked Maximize.
      Note: Persistence of maximized window isn't persistent when a StartPage is shown when IDE starts. In this case, StartPage is docked, selected and activated instead of Services.


Test suite: Window System Effects

Setup: Start IDE with clear userdir.

  1. Default Settings of WS Effects
    1. Open main menu Tools | Options > Miscellaneous > Windows panel.
    • EXPECTED RESULT: There are 3 parts separated by lines.
      In the first part (on the top), by default, there are all checkboxes switched on.
      In the second part (in the middle "Document Tabs"), there are all checkboxes unchecked except checkbox named 'Close activates most recent document'.
      In the third part ("Look and Feel"), there is 'Maximize use of native look and feel' checkbox, which is unchecked.
  2. Undock a window
    1. Select Float window action from Files window tab contextual menu to create a floating window.
    2. Give focus to editor window.
    • EXPECTED RESULT: The Files floating window becomes transparent in a few seconds.
  3. Undock a document window
    1. Open some file in editor.
    2. Select Float window action from editor window tab contextual menu to create a floating window.
    3. Give focus to IDE main window.
    • EXPECTED RESULT: The editor floating window remains opaque and does not become transparent.
  4. Change D'n'D effects and Floating windows settings
    • Comment: All settings used in this usecase you can find in main menu Tools | Options > Miscellaneous > Windows panel.
    1. D'n'D Files window and check if ghost image stays transparent during D'n'D.
    2. Turn off transparent drag window image.
    3. D'n'D Files window and check if it stays opaque during D'n'D.
    4. Turn off drag window image.
    5. D'n'D Files window and check, that there is no image with window content during D'n'D (instead it shows a small square).
    6. Turn off transparent floating window.
    7. Undock Files view, give focus on Editor and check if floating window stay opaque.
    • EXPECTED RESULT: The effects change correctly.
  5. Change Document settings
    • Comment: All settings used in this usecase you can find in main menu Tools | Options > Miscellaneous > Windows panel.
    1. Check 'New document opens next to active document tab' checkbox.
    2. Open three java files.
    3. Select and activate first tab.
    4. Open fourth java file.
    5. Newly opened document tab is second in the row.
    6. Select and activate last tab.
    7. Close last tab.
    8. Selected tab is second tab.
    9. Repeat steps 2 and 3.
    10. In Windows panel uncheck 'Close activates most recent document'.
    11. Select, activate and close the last (third) tab.
    12. Selected tab is second tab.
    • EXPECTED RESULT: The effects change correctly.
  6. Change Snapping settings
    • Comment: All settings used in this usecase you can find in main menu Tools | Options > Miscellaneous > Windows panel.
    1. Turn off snap to screen edges.
    2. Undock Favorites window and try to snap it to edges of the screen.
    3. Turn off snapping of floating windows.
    4. Undock Favorites window and Projects window and check if snapping works between them.
    • Comment: In Unix OS (Linux) you must turn off snapping of window directly in OS (e.g. in CompizConfig Settings Manager), otherwise the OS settings overrides the settings of IDE.
    • EXPECTED RESULT: The effects change correctly.


Test suite: Document Window

Setup: Start IDE with clear userdir.

  1. Tasks list
    1. Open main menu Window | Action Items.
    • EXPECTED RESULT: Action Items window is opened in bottom of document area.
  2. Read-only description
    1. Open some read-only java file (e.g. HelloWorld.java).
    • EXPECTED RESULT: Read-only file is displayed with gray background and font of title of selected Document Window is italic.
  3. Close document window - 4 ways how to do it
    1. Before each close open some java file (e.g. HelloWorld.java).
    2. By close button: push close button on the tab HelloWorld.
    3. By contextual menu: from contextual menu of document window tab push Close Window.
    4. By main menu: from main menu push Window | Close Window.
    5. By shortcut: press shortcut for Close Window action (Ctrl+W).
    • EXPECTED RESULT: Each time when you perform closing, the HelloWorld (and only HelloWorld) Document window is closed.
  4. Close All Documents - 3 ways
    1. Open 2 java files (e.g. HelloWorld_1.java, HelloWorld_2.java).
    2. Perform Close All function (from contextual menu) or Close All Documents (by main menu Window) or Ctrl+Shift+W (by shortcut).
    • EXPECTED RESULT: All (both HelloWorld_1 and HelloWorld_2) Document Windows are closed.
  5. Close All Documents - split - by contextual menu
    1. Open 2 java files (e.g. HelloWorld_1.java, HelloWorld_2.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From contextual menu of HelloWorld_1 Document Window push Close All.
    • EXPECTED RESULT: Only HelloWorld_1 Document Window is closed.
  6. Close All Documents - split - by main menu
    1. Open 2 java files (e.g. HelloWorld_1.java, HelloWorld_2.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From main menu push Window | Close All Documents.
    • EXPECTED RESULT: All (both HelloWorld_1 and HelloWorld_2) Document Windows are closed.
  7. Close Other Documents - by contextual menu
    1. Open 3 java files (e.g. HelloWorld_1.java, HelloWorld_2.java, HelloWorld_3.java).
    2. From contextual menu of HelloWorld_2 push Close Other Windows.
    • EXPECTED RESULT: HelloWorld_1 and HelloWorld_3 Document Windows are closed, HelloWorld_2 stay opened.
  8. Close Other Documents - split - by contextual menu
    1. Open 3 java files (e.g. HelloWorld_1.java, HelloWorld_2.java, HelloWorld_3.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From contextual menu of HelloWorld_2 push Close Other Windows.
    • EXPECTED RESULT: HelloWorld_3 Document Window is closed, HelloWorld_2 and HelloWorld_1 stay opened.
  9. Close Other Documents - split - by main menu
    1. Open 3 java files (e.g. HelloWorld_1.java, HelloWorld_2.java, HelloWorld_3.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From main menu push Close Other Windows.
    • EXPECTED RESULT: HelloWorld_2 and HelloWorld_3 Document Windows are closed only HelloWorld_1 stays opened.
  10. Reopening of recently closed documents
    1. Open two documents (e.g. java files) and close them.
    2. Click on main menu File | Open Recent File | "some file"
    3. Push shortcut Ctrl+Shift+T.
    • EXPECTED RESULT: Both documents are restored and opened.
  11. Save document - 2 ways how to do it
    1. Open java file (e.g. HelloWorld.java).
    2. Before each save modify HelloWorld source code.
    3. By main menu: from main menu push File | Save.
    4. By shortcut: press shortcut for Save action (Ctrl+S).
    • EXPECTED RESULT: Before saving HelloWorld tab fonts is bold as modified flag, after HelloWorld (and only HelloWorld) document is saved, fonts change to normal (no more bold), Documents dialog in Window menu contains disabled Save Document(s) item, Save item is disabled in File main menu and shortcut for Save action (Ctrl+S) did nothing.
  12. Clone document window
    1. Open java file (e.g. HelloWorld.java).
    2. From contextual menu of Window push Clone.
    • EXPECTED RESULT: HelloWorld as original and HelloWorld as clones (new tab in Editor Area) is opened.
  13. Clone document window - not cloneable
    1. Open Start Page (main menu Help | Start Page) and check result.
    2. Open Files view (main menu Window | Files) and check result.
    • EXPECTED RESULT: Menu item Clone Document is disabled in Window main menu.
  14. Maximize and Restore Document Window - 4 ways how to do it
    1. Open java file (e.g. HelloWorld.java).
    2. By contextual menu: from contextual menu of Window push twice Maximize. Check result.
    3. By main menu: push twice from main menu Window | Configure Window | Maximize. Check result.
    4. By shortcut: press twice shortcut for Maximize Window action (Shift+Escape). Check result.
    5. By doubleclick: Do doubleclick on header of HelloWorld, twice. Check result.
    • EXPECTED RESULT: Each time when you perform maximizing the Editor Window (whole window consists of all opened document windows) is maximized and HelloWorld source editor tab is selected and activated. Contextual menu and main menu Window | Configure Window contains checked Maximize. And each time, when you perform restoring, the Editor Window (whole window consists of all opened document windows) is restored and HelloWorld source editor tab is selected and activated. Contextual menu and main menu Window | Configure Window contains unchecked Maximize.
  15. Persistence of maximized Document Window - restart
    1. Open java file (e.g. HelloWorld.java).
    2. Maximize it (e.g. by doubleclick on header).
    3. Restart IDE.
    • EXPECTED RESULT: Editor Window (whole window consists of all opened document windows) is maximized and HelloWorld source editor tab is selected and activated. Contextual menu and main menu Window | Configure Window contains checked Maximize.
  16. Maximizing Form File
    1. Open some form file.
    2. Maximize it.
    • EXPECTED RESULT: Form file is maximized, but Palette window is visible on the right side of Document Area.
  17. Visible Windows with Maximized Document Window
    1. Open two java file (e.g. HelloWorld1.java and HelloWorld2.java) and Files from Window main menu and Navigator by shortcut (CTRL+7).
    2. Maximize HelloWorld1 document.
    3. Push Dock from contextual menu of Files and Navigator on left side of Window Area.
    4. Restore and close HelloWorld1 document.
    5. Maximize HelloWorld2 document.
    • EXPECTED RESULT: HelloWorld2 is maximized and Files and Navigator windows are visible on the left side of Document Area.
  18. Select next/previous document tab actions
    1. Open three or more files.
    2. Give focus to editor.
    3. Press CTRL+PGDOWN to select next document tab.
    4. Press CTRL+PGUP to select previous document tab.
    • EXPECTED RESULT: Both actions work as expected - next/previous document tab is selected when shortcut is pressed.
  19. List of actually opened documents
    1. Open three or more files.
    2. Give focus to editor.
    3. Press and hold CTRL and press TAB few times while still holding CTRL.
    4. Press and hold CTRL+SHIFT and press TAB few times while still holding CTRL+SHIFT.
    • EXPECTED RESULT: List of actually opened documents is shown in the middle of the screen. CTRL+TAB traverses downwards the list, CTRL+SHIFT+TAB traverses upwards. Items in the list are not sorted alphabetically, but actually active document is always first, previously active document is second etc.


Test suite: Window Area

Setup: Start IDE with clear userdir.

  1. Correct Placement of Windows
    1. Open all windows from Window main menu.
    2. Open some file.
    • EXPECTED RESULT: All Windows are open in Window Area (no one opened in Document Area). Document Window is opened in Document Area (no Window Area).
  2. D'n'D Tab Reordering
    1. Open Project, Files and Services from Window main menu.
    2. Drag Services tab and drop it between Projects and Files.
    3. Drag Projects tab and drop it right on Files to last position.
    • EXPECTED RESULT: Order of windows tabs is now Services, Files, Projects.
  3. Split Cell - resize
    1. Open Projects and Files from Window main menu.
    2. Drag Files view and drop it to the left side of Projects window.
    3. Move splitter between Projects view and Document Area.
    • EXPECTED RESULT: Chain of vertical split cells is visible. Files and Projects are resizing simultaneously so that the splitter between them was always in middle of them.
  4. Persistence of Split Cell
    1. Open Projects and Files from Window main menu.
    2. Drag Files view and drop it to the left side of Projects window.
    3. Move splitter between Files view and Projects window.
    4. Close and open Files view. Check result.
    5. Close Files again.
    6. Restart IDE.
    7. Open Files again.
    • EXPECTED RESULT: Files view is opened on the left side of Projects window and its size is the same as before closing.
  5. D'n'D Window Moving
    1. Open Projects and Services from Window main menu.
    2. D'n'D Services window next to Projects view (left, right, top or bottom).
    • EXPECTED RESULT: Services window is moved to the new location. Between both windows is splitter.
  6. Window Under the Document Window
    1. Open Projects from Window main menu and some java file.
    2. Drag Projects tab and drop it under the Document Area (you should see a red solid rectangle high around a quarter of the high of Document Area).
    • EXPECTED RESULT: Projects window is moved to the new position and its contextual menu remain the same as before moving.
  7. Window as Split Document Window
    1. Open Projects from Window main menu and some java file.
    2. Drag Projects tab and drop it to the bottom of Document Area (you should see a red dashed rectangle high around a half of the high of Document Area).
    • EXPECTED RESULT: Projects window is moved to the new position and its contextual menu change to document contextual menu: Close, Close All, Close Other, (splitter), Maximize, Float and Dock. You should see Projects item in list of documents when you click on main menu Window | Documents...".
  8. Maximized Split Cell - Switch to document
    1. Open Files and Projects from Window main menu and some java file.
    2. Doubleclick on a Projects header.
    3. Push from main menu Window | Documents... | Switch to Document.
    • EXPECTED RESULT: Split cell with Files View and Projects windows isn't maximized, Document Window with opened java file is visible and selected.
  9. Select next window tab and select previous window tab actions
    1. Open three or more windows in one split cells (one window content is visible, others are present only as tabs).
    2. Press CTRL+PGDOWN to select next window tab in split cell.
    3. Press CTRL+PGUP to select previous window tab in split cell.
    • EXPECTED RESULT: Both actions work as expected - next/previous window tab in split cell is selected when shortcut is pressed.


Test suite: Window Groups

Setup: Start IDE with clear userdir.
Note: There is two kinds of windows group, first is the groups of windows which are opened when IDE is in some mode (when form file is opened or when is in debugging mode). The second group is the group of window tabs in one window.

  1. GUI editing window group
    1. Open some form file. Check result.
    2. Close opened form file.
    • EXPECTED RESULT: One tab is added to Editor. Designer is visible. Designer toolbar contains three buttons: Source, Design and History, Design is selected by default. Form Editor consists of Palette, Properties and Form Designer. Check titles and position of views.
      When form file is closed, Palette, Properties, Form Designer and Source Editor are closed together with him.
  2. GUI editing window group - change layout - persistence
    1. Open some form file - HelloWorld.java.
    2. Drag Properties Window to the Files View as a new tab.
    3. Close opened form file.
    4. Open the another form file.
    • EXPECTED RESULT: Properties Window is opened on its new position as new tab in Files view. Check titles and position of views.
  3. Debugging window group
    1. Open some java file - HelloWorld.java.
    2. Run debugger to cursor on line with System.out.println("Hello World");.
    • EXPECTED RESULT: Debugging window group is opened. It consists of Debugging, Variables, Breakpoints and Output. If debugging is finished just Output window stays opened.
  4. Debugging window group - change layout - persistence
    1. Open some java file - HelloWorld.java.
    2. Run debugger to cursor on line with System.out.println("Hello World");.
    3. Drag Breakpoints window to the right side of Document Area.
    4. Drag Debugging to the same cell as Breakpoints window as a new tab.
    5. Drag Variables window to the Files View as a new tab.
    6. Push from main menu Debug | Finish Debugger Session.
    7. Run debugger to cursor on line with System.out.println("Hello World");.
    • EXPECTED RESULT: Debugging window group is opened. All windows are opened at the same positions as they were before finish debugging.
  5. Tab window groups
    1. Open Services and Projects.
    2. From Services tab contextual menu push Float Group. Check result.
    3. Restart IDE. Check result.
    4. Open Favorites window. Check result.
    5. From Favorites tab contextual menu push Dock Group. Check result.
    6. From Projects tab contextual menu push Minimize Group. Check result.
    7. Restart IDE. Check result.
    8. Open Files view. Check result.
    9. From the left side of screen push button Restore Window Group. Check result.
    10. From Projects tab contextual menu push Close Group. Check result.
    11. Open two java files.
    12. From tab contextual menu of first one select New Document Tab Group. Check Result.
    13. Open third file. Select second opened document and open fourth file. Check result.
    14. Open a form file. Select a tab from other group and open a second form file. Check result.
    15. From tab contextual menu of a opened file select Collapse Document Tab Group.
    • EXPECTED RESULT: Projects is floated together with Services tab. Favorites is opened in floated window. When group is docked/minimized/restored/closed, all of it's windows is docked/minimized/restored/closed at once. Floating/minimizing etc. of window group is persistent to IDE restart. When a group is in minimized mode, newly opened window belonging to that group is opened to default, docked position - no in minimized mode. After step 11. document area is divided into two half and in each half is one document tab. Third file is opened in group with first file and fourth in group with second file. Both form files is opened in the same group. At the end are all opened files back in one group.


Test suite: Documents dialog

Setup: Start IDE with clear userdir.
Note: When you see "Open files in defined order" it's allways "Class_A.java, Class_C.java and Class_B.java".

  1. Documents dialog - list of documents
    1. Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
    2. Modify file Class_B.
    3. Open Documents window (shortcut Shif+F4).
    • EXPECTED RESULT: Document non-modal dialogs is opened as it's specified in UI specification. Check components and mnemonics. Every item in the list contains icon, and name of document window as displayed in document window headers, it means also with bold font in case if a document has been modified. The list is alphabetically ordered and allows a multi-selection.
  2. Documents dialog - search popup
    1. Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
    2. Open Documents window.
    3. Focus list of documents and write "class_A"
    • EXPECTED RESULT: "Search:" popup is displayed showing typed characters and list moves selection to the matching item in the list. If non of the items matches typed characters, then non of item is selected. The backspace key allows the user to delete the last character. The "Search:" popup is closed if the user hits Enter or Esc. The search is keyboard insensitive.
  3. Documents dialog - switch to document
    1. Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
    2. Open Documents window.
    3. Select item Class_A from the list of documents.
    4. Push button Switch to Document.
    • EXPECTED RESULT: "Class_A" document window is activated and Document dialog is closed.
  4. Documents dialog - close document(s)
    1. Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
    2. Open Documents window.
    3. Select item Class_A from the list of documents.
    4. Push button Close Document(s). Check results.
    5. Select Class_B and Class_C items from the list of documents.
    6. Push button Close Document(s).
    • EXPECTED RESULT: Class_A document window is closed and item is removed from the list. Documents windows is still opened. Then Class_B and Class_C document windows are closed and items are removed from the list. Documents window is closed too.
  5. Documents dialog - save document(s)
    1. Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
    2. Modify all opened files.
    3. Open Documents window.
    4. Select item Class_A from the list of documents.
    5. Push button Save Document(s). Check results.
    6. Select items Class_B and Class_C from the list of documents.
    7. Push button Save Document(s).
    • EXPECTED RESULT: Class_A is saved and document window is still opened and presents in the list of opened documents. Then Class_B and Class_C are saved and document windows are still opened and present in the list of opened documents. Font of items in list are no more bold.
  6. Documents dialog - no document selected
    1. Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
    2. Open Documents window.
    3. Let no one item selected.
    • EXPECTED RESULT: Buttons Switch to document, Close Document(s) and Save Document(s) are disabled.
  7. Documents dialog - close modified documents(s)
    1. Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
    2. Modify files Class_B and Class_C.
    3. Open Documents window.
    4. Select item Class_B and Class_C from the list of documents.
    5. Push button Close Document(s).
    • EXPECTED RESULT: Question dialog rises, if push Save - document is saved, document window is closed and item removed from the list of opened documents. If push Discard - document is closed but not saved, item is removed from the list of opened documents. If push Cancel - document isn't saved neither closed and order of documents in the list of opened documents is unchanged.
  8. Documents quick list
    1. Open ten files.
    • EXPECTED RESULT: Document Window contains a line tabs in the opening order and on the upper right corner (or in the line of tabs) are left, right and bottom (quick list) scroll button. If you click by mouse on the quick list button - quick list popup menu with the list of all opened document windows rises. The items in the popup are ordered alphabetically. Each item in the popup displays an icon and name of document window. If there is not enough space in the main window to fit all the items in one column without a need to scroll then the list is organized into multiple columns.
  9. Documents quick list - switching to the first/last one
    1. Open ten files.
    2. Select last document tab.
    3. Push Quick List button.
    4. From the quick list menu select first opened file. Check result.
    5. Push Quick List button.
    6. From the quick list menu select last opened file.
    • EXPECTED RESULT: Selected and activated document window is the first one opened. Document Window contains a line of tabs 1st, .... , 8th), right tab is shown, right scroll button is enabled, left one disabled. After step 6. the selected and activated document window is the last one opened. Document Window contains a line of tabs (3nd, ..., 10th), left tab is shown, left scroll button is enabled, right one disabled. The quick list contains all of opened document windows.


Test suite: Sliding

Setup: Start IDE with clear userdir.

  1. Hiding and docking window - left/top/right/bottom
    • Comment: You can minimize window by contextual menu from title bar and pushing Minimize, by shortcut Ctrl+Backspace or by main menu Window | Configure Window | Minimize.
      And you can dock window back by contextual menu from toggle button or from title bar and pushing Dock, by shortcut Alt+Shift+D, by Pin button located in upper right corner of window or by main menu Window | Configure Window | Dock.
      In each case use different way how to perform minimizing or docking.
    1. Open Files view.
    2. Minimize Files view. Check result.
    3. Dock Files view back and D'n'D it to the top of the Document area.
    4. Minimize Files view. Check result.
    5. Dock Files view back and D'n'D it to the right of the Document area.
    6. Minimize Files view. Check result.
    7. Dock Files view back and D'n'D it to the bottom of the Document area.
    8. Minimize Files view. Check result.
    • EXPECTED RESULT: When Files view is minimized it disappears from the Docked mode. When is it docked it goes back to the Docked mode to the default position. If Files view is in left or top side of Document Area, the left edge bar is shown with one Files toggle button. And if Files view is in the right/bottom side of Document Area, the right/bottom edge bar is shown with one Files toggle button.
  2. Slide window
    1. Open and minimize Projects view.
    2. Move mouse over Projects toggle button on the left edge bar. Check result.
    3. Wait for Projects window slides from side and move mouse out from that window or button. Check result.
    4. Click on Projects toggle button. Check result.
    5. Click on Projects toggle button again, focus any other part of IDE or press Esc. Check result.
    6. Press shortcut for opening Projects view (Ctrl+1).
    • EXPECTED RESULT: Minimized Projects window slides from side but will not obtain a focus. When mouse is moved out of window, Projects hides once again into Minimized state. When toggle button is pushed window obtain a focus. In step 5. Projects view hides once again into Minimized state. When shortcut is pressed window obtain a focus.
  3. Persistence of minimized window
    1. Open and hide Projects view.
    2. Push Projects toggle button and resize the slided window.
    3. Push Close from contextual menu over Projects toggle button on the left edge bar.
    4. Open Project view again. Check result.
    5. Close Projects view.
    6. Restart IDE.
    7. Open Project view again. Check result.
    8. Press toggle button of Projects view to return window into minimized mode.
    9. Restart IDE.
    10. Projects view is minimized, open Project view one last time.
    • EXPECTED RESULT: Projects view is opened as slided window and will obtain a focus. It's size is same as after resizing.
  4. Transparency of sliding window
    1. Hide Projects view.
    2. Click on Projects toggle button on the left edge bar.
    3. Wait for Projects window slides from side.
    4. Right click the title bar and choose Transparent Window, click OK and press and hold Ctrl+NumPad 0.
    • EXPECTED RESULT: Projects view is transparent. You can see through the window the windows that are under it.


Test suite: Scrollable tabs in Window system

Purpose: The Window System uses scrollable tabs for managing opened documents. A behavior of scrollable tabs is tested by next test cases and scenarios. The UI is specified in UI specification.
Setup: Start IDE with clear userdir.

  1. Scrollable tabbed pane - row of tabs
    1. Open three files.
    • EXPECTED RESULT: Document Window contains a line of tabs and on the upper right corner (or in the line of tabs) are left, right and bottom (quick list) scroll buttons (and button to maximizing/restoring the window).
      The tabbed pane shows all tabs in the view if sum of preferred width of all tabs is less than width of view. The first tab is aligned with the left edge of the view. In this state, left and right scroll buttons are disabled and quick list button is enabled.
  2. Scrollable tabbed pane - view and width of tabs
    1. Open ten files (as many files you need to have not all tabs visible).
    2. Push left scroll button to scroll tabs to the left (to show not fully visible the most left and the most right tab).
    • EXPECTED RESULT: All scroll buttons are enabled. The leftmost and the rightmost visible tabs are partially visible tabs. All other tabs between the leftmost and the rightmost tabs are fully visible. Tabs that are on the left side of the leftmost visible tab or on the right side of the rightmost visible tab are hidden. Each tab contains an icon, label and close button. Check the width for right partially visible tab (minimum and maximum) and left partially visible tab (minimum and maximum).
  3. Scrollable tabbed pane - layout state - tabs hidden on the right/left/both sides
    1. Open ten files (as many files you need to have not all tabs visible).
    2. Push left scroll button to scroll tabs to the left, to show fully visible the most left tab. Check result.
    3. Push right scroll button to scroll tabs to the right, to show fully visible the most right tab. Check result.
    4. Push left scroll button to scroll tabs to the left, to show not fully visible the most right and left tab. Check result.
    • EXPECTED RESULT: When scroll button is pushed it makes fully visible (or fully hidden) only one partially visible tab at the moment. Tabs are hidden on the right (left) side if the first (last) tab is fully visible and the sum of preferred width of all tabs is greater than width of view. The right (left) partially visible tab follows the beginning and end of label rule. The first (last) tab is aligned with the left (right) edge of view. In this state the left (right) scroll button is disabled and right (left) scroll button is enabled. In step 4. tabs are hidden on the right and left side. The right and left partially visible tab follows the beginning and end of label rule. Both scroll buttons are enabled.
  4. Scrollable tabbed pane - scrolling by mouse
    1. Open ten files (as many files you need to have not all tabs visible).
    2. Scroll the tabs by mouse - move mouse over tabbed pane and use scroll wheel.
    • EXPECTED RESULT: The tabs are scrolling as expected. When is leftmost (rightmost) tab fully visible, the left (right) scroll button is disabled and the right (left) one enabled.
  5. Scrollable tabbed pane - adding
    1. Check if the "New document opens next to active document tab" checkbox in the main menu Tools | Options | Miscellaneous > card Windows is unchecked.
    2. Open ten files.
    3. Open new file. Check result.
    4. Activate second tab.
    5. Open new file. Check result.
    6. Uncheck the "New document opens next to active document tab" checkbox in the main menu Tools | Options | Miscellaneous > card Windows.
    7. Activate second tab.
    8. Open new file.
    • EXPECTED RESULT: The tab layout isn't changed and new tab is created as the last tab. It is made the rightmost tab fully visible and active. In the last step the new tab is created as third tab and is active and fully visible.
  6. Scrollable tabbed pane - removing
    1. Check if the "Close activate most recent document" checkbox in the main menu Tools | Options | Miscellaneous > card Windows is checked.
    2. Open ten files.
    3. Activate second tab and then fifth tab.
    4. Close fifth tab. Check result.
    5. Uncheck the "Close activate most recent document" checkbox in the main menu Tools | Options | Miscellaneous > card Windows.
    6. Activate fifth tab. Close it.
    • EXPECTED RESULT: In step 3. after closing fifth tab, the second tab is activated and fully visible. In last step, the activated tab is the fourth one.
  7. Scrollable tabbed pane - resizing
    1. Open ten files (as many files you need to have visible all tabs, but if once more open - will be partially or fully visible).
    2. Activate some tab.
    3. Resize the main window, try to make it smaller/bigger.
    4. Check result and repeat this testcase several times from step 2. but with activated different tab (e.g. first/second/middle/last one).
    • EXPECTED RESULT: Activated tab is always visible. The layout tries to show as much of all tabs as possible.
  8. Scrollable tabbed pane - display of partially visible tabs
    1. Open ten files (as many files you need to have not all tabs visible).
    2. Modify some file (to make font in tab bold) and make that tab right partially visible. Check result.
    3. Make the modified tab left partially visible. Check result.
    • EXPECTED RESULT: If the modified tab is right partially visible it's font is still bold. If the tab is left partially visible than it's font go back to default.


Test suite: Floating Windows

Setup: Start IDE with clear userdir. Have default settings of window system effects.
Don't test by folowing TS via VNC. It can degrade results.

  1. Create floating window
    1. Open Services and some java file (e.g. HelloWorld.java).
    2. Drag a Services and HelloWorld window/tab outside of the main window area. Check result.
    3. Dock the both windows back by tab contextual menu.
    4. Push from tab contextual menu of both windows Float.
    • EXPECTED RESULT: New window is created. The window is called floating window.
  2. Transparency of (non)focused floating windows
    1. Check if the checkbox Transparent floating windows in main menu Tools | Options > Miscellaneous > Appearance panel is checked.
    2. Create a floating window (e.g. Services) and let him to lost the focus. Check result.
    3. Give focus back to transparent floating window.
    • EXPECTED RESULT: After some time when it loose focus the window becomes half transparent. When focus is back, floating window is non-transparent again. It becomes transparent when it lost focus again.
  3. Window snapping
    1. Check if the checkboxes Snapping floating windows and Snap to screen edges in main menu Tools | Options > Miscellaneous > Appearance panel are checked.
    2. Create two floating windows (e.g. Projects and Services).
    3. D'n'd one window close to side of the other one. Check result.
    4. D'n'd one window close to side of the edge of the screen.
    • EXPECTED RESULT: It automatically snaps to the sides of other window or to the screen edge.


Test suite: Windows System vs. L&F

Purpose: The scope of this spec is to test and check UI on all supported Look and Feels.
Setup: Start IDE with clear userdir.
Note: UI specifications are now pretty outdated. Just check, that UI is not broken somehow.

  1. Check IDE on The GTK Look and Feel
    1. Run IDE on the unix based operating system with GNOME desktop - the GTK L&F should be loaded by default.
    2. On other window managers run ./netbeans --laf GTK
    • EXPECTED RESULT: Check the correctness of IDE behavior -> no exceptions, all windows look normally, all items are displayed, etc.
      LaF GTK screenshots: with closed Start Page and with opened project.
  2. Check IDE on The Metal Look and Feel
    1. Run IDE on the unix based operating system ./netbeans --laf Metal
  3. Check IDE on Nimbus Look and Feel
    1. Run IDE on the unix based operating system with ./netbeans --laf Nimbus
  4. Check IDE on The Windows XP Standard Look and Feel
    1. Run IDE on Windows XP with Windows XP theme (standard theme).
  5. Check IDE on The Windows XP Classic Look and Feel
    1. Run IDE on Windows XP with classic theme.
  6. Check IDE on The Windows Vista Look and Feel
    1. Run IDE on Windows Vista.
    • EXPECTED RESULT: Check the look of IDE.
  7. Check IDE on The Windows Vista Look and Feel with Aero
    1. Run IDE on Windows Vista with Aero.
    • EXPECTED RESULT: Check the look of IDE.


Test suite: Memory meter

Purpose: Check that the memory meter displays properly.
Setup: Start IDE with clear userdir.
Note: The Memory meter should not be enabled by default in any mode (debugging, profiling..). It must be enabled via main menu View | Toolbars | Performance.
Note 2: In daily builds could be enabled by default.

  1. GC calling
    1. Open many projests to load the processor/memory.
    2. Click on memory meter tool.
    • EXPECTED RESULT: The numbers in the memory meter will get lower.
  2. Show Text
    1. Invoke popup menu on the memory meter.
    2. Toggle item Show Text.
    • EXPECTED RESULT: The numbers are visible/invisible according to the toggle switch status. Try to toggle it couple of times.
  3. Drop Shadow
    1. Invoke popup menu on the memory meter.
    2. Toggle item Drop Shadow.
    • EXPECTED RESULT: The shadow appears/disappears according to the toggle switch status. Try to toggle it couple of times.
  4. Overlay Grid
    1. Invoke popup menu on the memory meter.
    2. Toggle item Overlay Grid.
    • EXPECTED RESULT: The grid overlay is according to the toggle switch. Try to toggle it couple of times.


Test suite: Miscellaneous tests

Setup: Start IDE with clear userdir.

  1. Remove externally file opened in editor before start again
    1. Open some file in Editor window.
    2. Shut-down IDE.
    3. Delete file from disk.
    4. Run IDE again.
    • EXPECTED RESULT: No error shows up.
  2. Invoke and close main menu by keyboard - F10
    1. Open some file in editor.
    2. Select Editor window.
    3. Open main menu File by keyboard press: F10 and down arrow.
    4. Close menu by keyboard - press Esc.
    • EXPECTED RESULT: On F10 is main menu selected, on pushing down arrow File menu arise and first Esc close it and second Esc give focus back to the editor.
  3. Multiview
    1. Open some form file.
    2. Select main menu View | Editors | Source.
    3. Select main menu View | Editors | Design.
    4. Push the Source button at the top-left corner of the editor pane.
    5. Push the Design button at the top-left corner of the editor pane.
    • EXPECTED RESULT: Source and Form design of the form file is switching as expected.
  4. Open in System action (in JDK6+)
    1. Create new text file.
    2. In Projects view select the created text file and invoke popup menu.
    3. Select menu item Open in System.
    • EXPECTED RESULT: The file opens in the system editor outside of IDE. The action Open in System should appear only on JDK6+.
  5. Check Toolbar actions
    1. Go to main menu View | Toolbars.
    2. Switch the selection of checkbox by each of items in submenu subsequently.
    3. Check that the popup menu invoked on toolbar contains checkboxes in proper status.
    4. Select main menu View | Toolbars | Small Toolbar Icons - the toolbar icons become small.
    5. Select main menu View | Toolbars | Reset Toolbars.
    • EXPECTED RESULT: Toolbars are showing/hiding accordingly when a checkbox is switched. After the Reset Toolbars action is invoked the Toolbars appear in its default state (except the size, it remains as it is).
  6. Customize Toolbars
    1. Go to main menu View | Toolbars and push Customize....
    2. Drag some items to and some items from the toolbars to add and remove them.
    3. Try to create a new toolbar and add some items to it.
    • EXPECTED RESULT: Customization of toolbars works as expected.
  7. Reset Windows
    1. Try to change window layout - open some windows and some documents, D'n'D some tabs, change it's position and size, try to create some new groups, make some windows floating etc..
    2. Push main menu Window | Reset Windows.
    • EXPECTED RESULT: Window layout is in default position. Non-default window tabs is closed, default window tabs is in correct positions, all documents window is still opened, floated document window is docked. Groups are back to normal and Star Page is opened. Active window is last active document window or (in case where no document window was opened) Start page.
  8. Native Look and Feel
    1. In main menu Tools | Options | Miscellaneous | card Windows, check "Maximize use of native look and feel".
    2. Open window "Open Project" (e.g. by Ctrl+Shift+O).
    • EXPECTED RESULT: On Mac OS it should use native file chooser instead of IDE one.
  9. Filtering of the Content in Options Dialog
    1. Open main menu Tools | Options.
    2. In upper right corner there is search field.
    3. Try to type several things you want to find in options (e.g. "diff", "ant", "shortcut", ...)
    • EXPECTED RESULT: It should open a card (area) where is the functionality you looking for and other cards turn gray and unavailable. After pressing Esc they will be available again. If it finds nothing, there should be text "Nothing found".


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo