TS 7 MainWindow

Main Window Test Specification for NetBeans 7

Author: Tomáš Tököly
Last update: 21.8.2012
Introduction: Main window of NetBeans consists of two main parts. First part is menu and menu items, second are toolbars. Both - menu and toolbars - are customizable by user.
For customization use main menu Tools | Options and main menu View | Toolbars. It is based on old TS for NetBeans 6.1.

Contents


Test suite: Main Menus

Purpose: The UI is specified in UI specification and in so called Permanent UI - Menus.
Setup: Start IDE with clear userdir.

  1. Icons
    1. Go to main menu.
    2. Try to open all menus.
    • EXPECTED RESULT: Only items represented by actions shown also in toolbars have icons.
  2. Names of Menu Items
    1. Go to main menu.
    2. Try to open menus.
    • EXPECTED RESULT: Menu items fit to Java L&F; e.g. only prepositions with four or more letters should be capitalized. Menu items followed by "..."(three dots) opens frame/window. Check that separators exist where applicable, assure that there aren't double separators in main menu or the last menu item isn't separator.
  3. Mnemonic Keys Automated
    1. Go to main menu.
    2. Try to open menus and invoke actions only by mnemonic keys.
    • EXPECTED RESULT: Appropriate menu is opened or action invoked. Correct letter is underlined in menu. There could be duplicates of mnemonic key in one menu or submenu.
  4. Check Mnemonic
    1. Check all default menus in Option window.
    • EXPECTED RESULT: There is "&" in front of mnemonic letter in menu.


Test suite: Main Toolbars

Purpose: The scope of this spec is not to test a complete toolbar management. This spec defines only tests of the default actions in default toolbars, default toolbar configurations and ways how the user accesses the currently existing toolbar management menu items.
Setup: Start IDE with clear userdir.

  1. Check View
    1. Expand menu View | Toolbars.
    • EXPECTED RESULT: The items of currently visible toolbars are checked.
  2. Check persistence between toolbar popup menu and main menu
    1. In main menu View | Toolbars enable Debug toolbar and Small Toolbar Icons and disable Run toolbar.
    • EXPECTED RESULT: Check persistence between popup menu over toolbars and main menu View
  3. Change configuration - persistence
    1. In main menu View | Toolbars enable Debug toolbar and Small Toolbar Icons and disable Run toolbar.
    2. Restart the IDE.
    • EXPECTED RESULT: Check persistence between popup menu over toolbars and main menu View
  4. Tooltip and contents
    1. Enable all toolbars.
    2. Hold mouse over dragging area of each toolbar.
    • EXPECTED RESULT: All toolbars appeared. Tooltip for each toolbar is shown and content of each toolbar is right and components are enabled and disabled correctly.
  5. Enable all toolbars - persistence
    1. Enable all toolbars in menu.
    2. Restart IDE.
    • EXPECTED RESULT: All toolbars appeared.
  6. Disable all toolbars
    1. Disable all toolbars in menu.
    • EXPECTED RESULT: All toolbars disappeared.
  7. Disable all toolbars - persistence
    1. Disable all toolbars in menu.
    2. Restart IDE.
    • EXPECTED RESULT: All toolbars disappeared.
  8. Toolbars dragging
    1. Try to drag and move toolbars (e.g. change order of toolbars, place them in more line).
    2. Restart IDE.
    • EXPECTED RESULT: Check the new positions of toolbars.
  9. Reset toolbars - Main menu
    1. Enable/disable some toolbars in menu.
    2. Push from main menu View | Toolbars | Reset Toolbars.
    • EXPECTED RESULT: Toolbars are in default configuration.
  10. Reset toolbars - Contextual menu
    1. Enable/disable some toolbars in menu.
    2. Push from toolbar contextual menu Reset Toolbars.
    • EXPECTED RESULT: Toolbars are in default configuration.
  11. Reset toolbars - Customize toolbars dialog
    1. Enable/disable some toolbars in menu.
    2. Push from contextual menu of toolbar area Customize....
    3. Push Reset Toolbars button.
    • EXPECTED RESULT: Toolbars are in default configuration.
  12. Indication of overflow
    1. Try to grab left or right border of whole IDE and make it smaller.
    • EXPECTED RESULT: While border hit the individual icons in toolbars, they should be changed to drop down menus, where you can click on them.


Test suite: Customize Toolbars

Purpose: Test Customize Toolbars dialog and it's actions.
Setup: Start IDE with clear userdir.

  1. D'n'D icon to toolbar
    1. Open from main menu View | Toolbars | Customize.
    2. Drag Start Page icon from Help section and drop it to the end of the File toolbar.
    3. Close Customize Toolbars dialog.
    • EXPECTED RESULT: The Customize Toolbars dialog is displayed correctly. The Start Page icon is on the toolbars and works properly.
  2. Create new toolbar
    1. Open from contextual menu of toolbar area Customize.
    2. Push New Toolbar... button.
    3. Enter name of new toolbar into the New Toolbar dialog (e.g. MyToolbar).
    4. D'n'D some icon to the newly created toolbar (e.g. Help icon from Help section).
    • EXPECTED RESULT: The Customize Toolbars dialog is displayed correctly. The new toolbar is being displayed in the toolbar area and contains the icon from the step 4.


Test suite: Main Window

Purpose: Test Full Screen function.
Setup: Start IDE with clear userdir.

  1. Toggle full screen from main menu
    1. Push from main menu View | Full Screen to enable Full Screen mode.
    2. Push from main menu View | Full Screen again to disable it.
    • EXPECTED RESULT: IDE goes to Full Screen mode, covers whole screen, window manager decorations and IDE toolbars disappears. Some system panels are displayed even when Full Screen mode is enabled (e.g. on OS X). This is OS specific behavior. Check, that everything goes to normal, when Full Screen mode is disabled.
  2. Toggle full screen using shortcut
    1. Press shortcut (Alt+Shift+Enter or Ctrl+Shift+Enter on Mac) to enable Full Screen mode.
    2. Press Full Screen shortcut again to disable it.
    • EXPECTED RESULT: IDE goes to Full Screen mode, covers whole screen, window manager decorations and IDE toolbars disappears. Some system panels are displayed even when Full Screen mode is enabled (e.g. on OS X). This is OS specific behavior. Check, that everything goes to normal, when Full Screen mode is disabled.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo