TS 72 JavaEditor

Java Editor

Author:Jiri Prox
Version:7.2
Last update:2012/09/05
Introduction:This test specification covers java specific features of the editor.

Contents

Test suite: Start New Line and Split Line

Setup: Type String str = "abcde 123456"; inside a method's body

  1. Smart Enter inside strings
    1. Move caret behind the "abcde"
    2. Press Enter
    • EXPECTED RESULT: If Enter is pressed inside of a string, the string is smartly divided using '+' operator above strings so that there are no errors in code
      Other info:
      - indentation works normally
      - all white characters are preserved
      - caret is moved behind the opening quote at the second line
  2. Undo,Redo and a smart Enter
    1. Follow previous testcase
    2. Invoke Undo and Redo several times
    • EXPECTED RESULT: Undo and Redo is working properly.
  3. Start new line
    1. Move the caret behind "abcde"
    2. Press Shift+Enter.
    • EXPECTED RESULT: The new line is inserted just below actual line and the cursor is moved to the beginning of the new line (indentation is applied). Original line is not modified
  4. Undo/Redo start new line
    1. Try to use Undo and Redo
    • EXPECTED RESULT: Undo/Redo works properly.
  5. Split line
    1. Move caret behind "abcde"
    2. Press Ctrl+Enter
    • EXPECTED RESULT: The sting literal is divided to the two lines, as it was common text. No additional characters are inserted, so there is syntax error in the editor now.
  6. Undo/Redo split line
    1. Try to use Undo and Redo
    • EXPECTED RESULT: Undo/Redo works properly

Test suite: Erroneous Code

  1. Show tooltip
    1. Paste this incorrect field declaration inside a class body: public private int a0;
    2. Hover with mouse cursor over error annotation mark in gutter for a while (wait for tooltip to appear).
    3. Place caret on marked line and press Alt+Enter
    • EXPECTED RESULT: - Erroneous code should be underlined
      - A red annotation mark shows up in the gutter
      - A tooltip should be displayed after you hover above the annotation mark and after you press Alt+Enter, tooltip contains error "Illegal combination of modifiers: private and public"
  2. Cycling through annotations
    1. Place incorrect variable declaration Strin g = "abc"; somewhere into the method body.
    2. Place caret on the line with error and add break point (default shortcut is Ctrl+F8)
    3. Add bookmark (default shortcut is Press Ctrl+Shift+M)
    4. You should see a little arrow by the annotation in the gutter - click it a few times
    5. Remove the breakpoint
    6. Remove the bookmark
    • EXPECTED RESULT: The arrow is used for cycling among multiple annotations, so that you can see all annotations. In this case there should be 3 annotations: the bookmark, the breakpoint and error annotation.

Test suite: Code Templates

Purpose: Tests the code templates functionality inside NetBeans editor.

  1. Code templates UI
    1. Open Options Dialog
    2. Select Editor | Code Templates
    3. Select Language: Java
    • EXPECTED RESULT: The table contains predefined code templates
  2. Code Template Invocation from Abbreviation
    1. Type into editor "fori".
    2. Press tab (default shortcut for code template).
    • EXPECTED RESULT: Code template for the for() cycle with iteration variable i should appear.
  3. Code Template Invocation from Code Completion
    1. Type into editor "for".
    2. Press Ctrl-Space to invoke code completion.
    • EXPECTED RESULT: Several variants of for cycle should appear (over array and over collection). It is possible to choose one of them and cycle using tab through the editable fields.
  4. Adding new Code Template
    1. Open Options Dialog | Editor | Code Template | Language Java
    2. Press New""
    3. Fill in abbreviation for the new code template - abb
    4. Fill in code, which the abbreviation will expand to - for example int x = 1;
    5. Switch to description tab and add some description
    6. Check that the code template was added successfully
    7. Close OD by pressing OK
    8. Try abbreviation in editor - type abb and press tab
    • EXPECTED RESULT: Code template is correctly added. The new abbreviation is correctly expanded to defined code when used.
  5. Adding new Code Template - negative case
    1. Try adding new code template with the abbreviation which is already used
    • EXPECTED RESULT:
  6. Removing Code Template
    1. Open Tools -> Editor -> Code Templates
    2. Select one template
    3. Press Remove
    • EXPECTED RESULT: The code template is removed from the list, the abbreviation is not expanded any more
  7. Change Expand key
    1. Open Tools -> Editor -> Code Templates
    2. Change Expand Key to space
    • EXPECTED RESULT: The abbreviations are now expanded by space and not tab
  8. Change action after expanding
    1. Open Tools -> Editor -> Code Templates
    2. Change On Template Expand value
    3. Try expanding code template in editor
    • EXPECTED RESULT: The template is inserted and chosen action is performed:
      Reformat - the code is reformated, the inserted code is placed at correct position
      Reindent - the template is placed at position related to previous code
      Nothing - the template is inserted at current cursor position as it is
  9. Traversing through Code Templates
    1. Invoke the fori code template.
    2. Cycle through the editable fields by pressing Tab.
    3. Cycle back through editable fields by pressing Shift-Tab.
    4. Try to edit various fields from code template.
    5. Once outside code template try to edit the code inside the for cycle.
    • EXPECTED RESULT: It should be possible to cycle through the template in both directions. Editing should work properly and all synchronized block should be updated at once. When editing code template is finished the synchronized block are not enabled any more.
  10. Defining Custom Code Templates
    1. Open new Options dialog and go to Editor | Code Templates.
    2. Add a code template called forx with code: TBD
    3. Try to invoke the new code template by both code completion and as an abbreviation.
    • EXPECTED RESULT: In both cases the template should be filled in and should work properly.
  11. Using block code templates
    1. Select part of code in editor
    2. Hint icon should be provided. Press Alt-Enter and select some of the "wrap with" template
    • EXPECTED RESULT: Code template is inserted so the selected code is wrapped inside the template

Test suite: Commenting code

  1. Toggle line comment
    1. Open any java file
    2. Try to comment and uncomment several lines by pressing CTRL+/
    • EXPECTED RESULT: The selected lines should be commented by //.
      - If only commented lines are selected this action will uncomment them.
  2. Comment/Uncomment line
    1. Try to comment/uncomment lines using comment and uncomment buttons in editor toolbar
    • EXPECTED RESULT: Comment button should add '//' at the beginning of line, the uncomment button will remove it.

Test suite: Error stripe

Purpose: Error stripe is stripe right to the editor, it provides quick status of the opened file (small color box at the top of the error stripe) and highlights significant lines (lines with error, bookmark, caret position). It also provides quick navigation to the highlighted lines

  1. File is OK
    1. Open java file without any errors or warnings.
    2. Remove all bookmarks, breakpoints, mark occurrences etc...
    • EXPECTED RESULT: The status box is green, the error stripe
  2. File with errors
    1. Open java file from the previous test case
    2. Add code with warning (e.g. override toString method w/o @Override annotation)
    3. Add another warning (e.g unused import)
    4. Add some code with error
    5. Remove all warnings/errors
    • EXPECTED RESULT: When file contains warning the status box is yellow, in the error stripe there is yellow mark. When there is error in the file the status box is red and the mark in error stripe is red. Whenever mouse is hovering over the status box the info about status is showed (e.g. "1 error(s) 2 warning(s)"). After removing the errors and warnings the status box is green again.
  3. Caret position
    1. Open file which is longer than editor window
    2. Try scroll to beginning and end of the document (by arrows, page up/down and scroll wheel)
    • EXPECTED RESULT: The caret symbol in error stripe (thin line with little square in the middle) moves to proper places when scrolling. When the caret is in the beginning of the document the symbol is in the top of error stripe, when the caret is at the end, the symbol is at the bottom.
  4. Error stripe navigation
    1. Open java file
    2. Put several bookmarks in the file and/or use mark occurrences feature
    3. Click on marks in error stripe
    • EXPECTED RESULT: The file is scrolled to show related place in editor, when hovering over the mark the mouse cursor is changed to tooltip informs about the type of the mark
  5. Error stripe colors
    1. Open java file
    2. Put bookmark in it
    3. Put break point in it
    4. Add code with warning
    5. Add code with error
    6. Change line, add line, remove some lines (if the document is under version control)
    7. Turn on mark occurrences and put cart over identifier with more occurrences
    • EXPECTED RESULT: All this actions adds mark in error stripe, these marks differ by color - errors are red, warnings yellow, bookmarks dark gray, changed lines blue, removed lines ping, new lines green, etc...

Test suite: Java Macros

  1. Create macro
    1. Start macro recording (Ctrl+J S or from editor toolbar)
    2. Write some text in editor, move cursor and try to invoke some formatting actions (Shift Line, Comment etc.)
    3. Finish recording macro (Ctrl+J E or in editor toolbar)
    4. Inside appeared dialog, type new macro's name and choose some free keybindings for it. (the warning should appear when trying to assign already used shortcut)
    5. Open java source file into editor and try using new macro's keybinding.
    • EXPECTED RESULT: Macro is added to the list and properly works in editor
  2. Change shortcut
    1. Open Tools | Options | Editor | Macros
    2. Change the shortcut of macro created in previous test case to something else
    3. Invoke macro in editor
    • EXPECTED RESULT: Only new shortcut invokes the macro
  3. Delete macro
    1. Open Tools | Options | Editor | Macros
    2. Delete macro created in previous test case
    3. Try to invoke deleted macro in editor
    • EXPECTED RESULT: Macro is deleted and cannot be invoked any more
  4. Create macro in Options
    1. Open Tools | Options | Editor | Macros
    2. Click to Add button and create new macro
    3. Set shortcut for the new macro
    • EXPECTED RESULT: New macro is created and can be invoked

Test suite: Line tools

Purpose: This suite tests tool for manipulating with whole line or several lines.

  1. Move one line
    1. Put caret in document
    2. Press Alt-Shift-Up / Alt-Shift-Down
    • EXPECTED RESULT: Actual line is moved one line up/down
  2. Move selection
    1. Put caret in document
    2. Select several lines
    3. Press Alt-Shift-Up / Alt-Shift-Down
    • EXPECTED RESULT: Whole selected block (including the lines which are not selected whole but at least partially) is moved
  3. Copy line
    1. Put caret in document
    2. Press Ctrl-Shift-Up / Ctrl-Shift-Down
    • EXPECTED RESULT: The actual line is duplicated below/above current line
  4. Copy block
    1. Put caret in document
    2. Select several lines
    3. Press Ctrl-Shift-Up / Ctrl-Shift-Down
    • EXPECTED RESULT: The whole selection (including whole partly selected lines) is duplicated below/above current selected block
  5. Move horizontally
    1. Put caret in java class
    2. Press Alt-Shift-Left / Alt-Shift-Right
    3. Select several lines are press again Press Alt-Shift-Left / Alt-Shift-Right
    • EXPECTED RESULT: Actual line ( or selected lines) are move left/right by one indentation level (this must respect formatting settings)
  6. Interaction with guarded blocks
    1. Create new JForm file or open any file with guarded blocks
    2. Try to move/copy within guarded block
    3. Select line outside the guarded block and try to move it inside
    • EXPECTED RESULT: Line tools should not affect guarded block, moving line inside guarded block cannot be performed

Test suite: Smart Brackets

  1. Smart pairs
    1. Type private String[[ in body of class
    2. Push Backspace key
    3. Type private String S = new String( in body of class
    4. Push Backspace key
    5. Type if((11=11) & (2==3|) in an empty body of a method (place caret as suggested by '|')
    6. Press ')' key twice
    • EXPECTED RESULT:
      - When you press ')' for the first time, a new bracket is inserted after '3', so that brackets are correctly balanced. When you press ')' for the second time, the bracket is skipped (again - in order to keep number of closing/opening brackets balanced).
  2. Enter after opening curly bracket
    1. Move caret inside a method.
    2. Type if (true) {
    3. Push Enter key
    • EXPECTED RESULT: The closing bracket should be added automatically and indented properly
  3. Undo with bracket completion
    1. Try to Undo actions from previous test cases.
    • EXPECTED RESULT: Undo is working exactly in the opposite direction for all of these actions.
  4. Brackets highlighting
    1. Type in editor: if(true) {

      }
    2. Put caret just behind the some of the closing bracket - '}', ')' or ']'
    3. Press Ctrl+'[['
    4. Repeat with all types of brackets
    • {{result|EXPECTED RESULT: The matching bracket is highlighted, shortcut Ctrl-'[[' moves caret to matching bracket. }}

Test suite: Syntax Coloring

Comments: This test suite requires default fonts & colors settings

  1. Class Members
    1. Open class coloring.Colors from sample project
    2. Check coloring of class members
    • EXPECTED RESULT: Members Coloring
  2. Static Members
    1. Open class coloring.Colors2 from sample project
    2. Check coloring of static members
    3. Delete static keyword
    • EXPECTED RESULT: The static elements (inner class, fields, method) are written in italics. After deleting "static" keyword the fort is changed to regular
  3. Unused Private Elements
    1. Open class coloring.ColorsPrivateUnused from sample project.
    2. Check coloring of private elements
    3. Change the 'private' to 'public' and/or write code which uses private elements
    • EXPECTED RESULT: All unused private elements are underlined by gray line, When used or turned to public the underline is gone.
  4. Method Parameters and Variables
    1. Open class coloring.ColorsParameters from sample project
    2. Check colors
    3. Try to make unused variables used.
    • EXPECTED RESULT: Image:Parameters Coloring
  5. Unused Imports
    1. Open class coloring.Imports from sample project
    2. Make sure that hints are turned off (Tools -> Options -> Editor -> Hints -> Import -> Unused Import) otherwise the underline color will be yellow - default color for fixable hints
    3. Check colors
    • EXPECTED RESULT: Unused imports are gray underlined

Test suite: Camel case setting

Purpose: This suite test camel case navigation in java editor

  1. Jump next/prev
    1. Open java class in editor and type DefaultTableModel s;
    2. Use ctrl-left/right to jump over the declaration
    3. In options disable 'Enable Camel Case Navigation for Java' (Options->Editor->General)
    • EXPECTED RESULT: When the option is enabled the cursor jumps also between upper case letter in identifier. If it is off the cursor jumps among whole words only.
  2. Delete next/prev
    1. Put cursor in the middle of 'DefaultTableModel'
    2. Use ctrl-delte/backspace
    3. In options toggle 'Enable Camel Case Navigation for Java' (Options->Editor->General)
    4. Undo changes and try Use ctrl-delte/backspace
    • EXPECTED RESULT: The part for current position to next/prev upper case letter is deleted when the option is enabled, the part to the end/beginning of word is deleted when the option is off.

Test suite: Fix Imports

  1. Simple Fix Import
    1. Open fiximports.FixImports from the sample project
    2. Delete all import statements
    3. Call Fix Imports (context menu or Ctrl-Shift-I)
    4. Select right classes in comboboxes and confirm
    • EXPECTED RESULT: 3 imports are properly added, one import is marked as <cannot be resolved> in the dialog. Correct the typo from FireReader to FileReader and try it again. All class can be resolved now.
  2. Unresolved Class
    1. Open fiximports.FixImports from the sample project
    2. Add line LoremIpsumDolorSitAmet variable;
    3. Call Fix Import
    • EXPECTED RESULT: The dialog contains <cannot be resolved>
  3. Fast Import
    1. Open fiximports.FixImports from the sample project
    2. Delete all import statements
    3. Put caret on unresolved symbol and press Alt-Shift-I
    4. Select required class from list and confirm by Enter
    • EXPECTED RESULT: Selected class is imported
  4. Fast Import - package
    1. Open fiximports.FixImports from the sample project
    2. Delete all import statements
    3. Put caret on unresolved symbol and press Alt-Shift-I
    4. Select required class from list and confirm by Alt-Enter
    • EXPECTED RESULT: Whole package is imported
  5. Fast Import - FQN
    1. Open fiximports.FixImports from the sample project
    2. Delete all import statements
    3. Put caret on unresolved symbol and press Alt-Shift-I
    4. Select required class from list and confirm by Shift-Enter
    • EXPECTED RESULT: The identifier is replaced with FQN
  6. Fix Import Hint
    1. Open fiximports.FixImports from the sample project
    2. Delete all import statements
    3. At each line with unresolved symbol use hint to add import statement
    • EXPECTED RESULT: All imports are added correctly

Test suite: Mark Occurrences

Purpose:

Setup:

  1. Show Usages
    1. Open occurrences.MarkOccurrences from the sample project
    2. Put cursor on name of variable/field/method/parameter (eg. variable on line 40, field on line 31, method on line 33, param on line 33)
    • EXPECTED RESULT: All occurrences of selected element is highlighted in editor and error stripe.
  2. Return Points
    1. Open occurrences.MarkOccurrences from the sample project
    2. Put caret on return type of method at line 33
    3. Put caret on exception in throws clause statement at line 33
    • EXPECTED RESULT: In step 2 all exit point from method are highlighted (4 occurrences). In next step only places where the selected exception is thrown are highlighted (2 occurrences).
  3. Show Usages - Class
    1. Open occurrences.MarkOccurrences from the sample project
    2. Put caret on String at line 31
    • EXPECTED RESULT: All usages of java.lang.String in current class are highlighted
  4. Options - On/Off
    1. Open options and disable Mark Occurrences Of Symbol Under Caret
    2. Go back to editor, put caret on any identifier (method name, class name, field)
    3. Enable MarkOccurrences again
    • EXPECTED RESULT: While MO (Mark Occurrences) is disabled, no occurrences are highlighted.
  5. Mark Occurrences - Types, Methods
    1. Open options and disable Types and Methods
    2. Put caret on line 33 word method or line 31 word String
    3. Enable options again
    • EXPECTED RESULT: Occurrences on lines 31,33, 40 (for class) and 33,44 (for method) are not highlighted when options are disabled
  6. Mark Occurrences - Constant, Fields, Variables
    1. Open options and disable Constants , Fields and Local Variables
    2. Put caret on line 85 word KONST ,on line 31 word field or on line 40 word variable
    3. Enable options again
    • EXPECTED RESULT: No occurrences of actual element is highlighted in step 2
  7. Mark Occurrences - Exceptions, Exit Points
    1. Open options and disable Exceptions Throwing Points
    2. Put caret on line 33 word String
    3. Put caret on line 33 word IOException
    4. Enable the option again and disable Exit Point From Method
    5. Put caret on line 33 word String
    6. Put caret on line 33 word IOException
    7. Enable the option
    • EXPECTED RESULT: In step 2) the editor highlights both exit point from method (return and throw - 4 occurrences). In step 3) occurrences of class IOException are marked (3 occurrences, watch the Keep Marks option). In step 5) all occurrences of String are highlighted (3) and in step 6) 2 places where can be thrown selected exception are marked
  8. Mark Occurrences - Implementing/Overriding methods
    1. Open options and disable Implementing Method and Overriding Method
    2. Put caret on line 29 word DefaultTableModel or Runnable
    3. Enable the options again and repeat step 2
    • EXPECTED RESULT: When cursor is located over superclass name in extends statement or over implemented interface in implements statement the methods from selected superclass/interface are highlighted. In step 2) this feature is disabled.
  9. Mark Occurrences - Label
    1. Open options and disable Targets of Break and Continue statements
    2. Put caret on words break and continue on lines 74 and 77
    3. Enable the option again and repeat step 2)
    • EXPECTED RESULT: When option is ON the label and closing bracket of the related loop is highlighted, e.g. when caret is placed over break on line 74, the label L1 on line 66 and } on line 82 are marked.
  10. Mark Occurrences - Keep marks
    1. Open options and disable Keep Marks
    2. Select several elements, which can be highlighted
    3. Enable the option again and repeat step 2
    • EXPECTED RESULT: When option is disabled the actual mark occurrences marks are discarded when the location of caret is changed, regardless if another highlights are created or not. When enabled, the old marks are removed only in new set of marks is created.
  11. Browsing
    1. Select element which has more occurrences (e.g class String)
    2. Press Alt-Up, Alt-Down
    • EXPECTED RESULT: The caret jumps among the marks

Test suite: Syntax tree selection

Purpose: This suite tests selection of upper/lover node in AST and moving through AST

  1. Moving to root
    1. Open java class in editor put cursor somewhere in code
    2. Press alt-shift-comma several times
    • EXPECTED RESULT: The selection is enlarge to contain whole parent node in syntax tree -> e.g identifier->method call->block-> method -> class.
  2. Moving to leaf
    1. Just after previous test case press alt-shift-period
    2. Try to mix this two testcases
    • EXPECTED RESULT: The selection is reduced to lower node in AST. It ends when identifier around original cursor position is selected
  3. Moving Element Up
    1. Open MoveElement.java
    2. Put cursor on line 20
    3. Try moving element up as possible (default shortcut ale-shift-page up)
    • EXPECTED RESULT:Whole selected element (toString method + annotation) is moved up in the AST - e.g. is jumps over elements in the same scope (int z; declaration). when the moved element is first in current scope then it is moved one level up in the AST - to the class InnerClass and then to MoveElement class. The IDE beeps when it is not possible to perform move
  4. Moving Element Down
    1. Use Move Element Down (alt-shift-page down) to get element to original position
    • EXPECTED RESULT:Element is moved down in AST, like in previous test case

Test suite: Node tooltips

  1. Contains main method
    1. Create class with main method
    • EXPECTED RESULT: The class node in project view is decorated with green arrow and the tool tip says 'Contains Maim Method'
  2. Error in file
    1. Open any file in project
    2. Add some syntax error in the class
    3. Remove the error again
    • EXPECTED RESULT: The class containing the error is marked with the error badge, the badge is propagated to package, source root and project. The tooltip says 'Error parsing file' for file, and 'Contains files with error' for the other nodes. Once the error is corrected the badges disappears
  3. Need to be compiled
    1. Open any class
    2. Turn of Compile On Save
    3. Make some modification in editor
    4. Built the whole project
    • EXPECTED RESULT: When file is modified a little wrench icon is added to the related node in project view. After building the project the icon is gone

Test suite: Add semicolon

  1. Add semicolon
    1. Open java file
    2. On non-empty line press ctrl-;
    • EXPECTED RESULT: The ';' is added to the end of line
  2. Add semicolon and new line
    1. Open java file
    2. On non-empty line press ctrl-shift-;
    • EXPECTED RESULT: The ';' is added to the end of line and the cursor is moved to the new line

Test suite: Transfer types on Copy&Paste

  1. Simple type transfer
    1. Open imports.SourceClass
    2. Select whole method m()
    3. Copy/Paste it to TargetClass
    • EXPECTED RESULT: When paste action is performed, the dialog is opened. It lists all classes which have to be imported into to the target class in order to keep code compilable. After the dialog is confirmed the content of clipboard is inserted and necessary imports added
  2. Already existing imports
    1. Add import java.io.File into TargetClass
    2. Open SourceClass
    3. Select whole body of the class
    4. Copy/Paste it into target class
    • EXPECTED RESULT: Dialog listing imports which should be added is opened. It contains only one record - ImportedClass
  3. Not resolvable imports
    1. Create new project with one class
    2. Open SourceClass
    3. Copy ImportedClass importedClass; into the another project
    • EXPECTED RESULT: No dialog is opened since the ImportedClass cannot be resolved in the target scope
  4. Implicit import
    1. Open SourceClass
    2. Copy SamePackageClass samePackageClass; into TargetClass2
    • EXPECTED RESULT: The import is added even it was not explicitly written in the origin file
  5. Cancel transfer types
    1. Repeat one of the previous test cases
    2. Do not confirm dialog with needed imports
    • EXPECTED RESULT: Code is pasted but no imports are added

Test suite: Remove Surrounding Code

  1. Remove For cycle
    1. Open RemoveSurrouding.java
    2. Put cursor at line 20
    3. Press Alt+Backspace
    4. From popup select for(...)...
    • EXPECTED RESULT:For cycle is removed, the body of cycle is inserted directly at current position (may introduce syntax errors)
  2. Remove If
    1. Open RemoveSurrouding.java
    2. Put cursor
    3. Put cursor at line 24
    4. Press Alt+Backspace
    5. From popup select if(...)...
    • EXPECTED RESULT:If/else is removed, the body of both parts of if/else is inserted directly at current position
  3. Remove Else
    1. Open RemoveSurrouding.java
    2. Put cursor at line 27
    3. Press Alt+Backspace
    4. From popup select else...
    • EXPECTED RESULT:Else part is removed, the body is inserted directly at current position
  4. Remove While
    1. Open RemoveSurrouding.java
    2. Put cursor at line 33
    3. Press Alt+Backspace
    4. From popup select while(...) ...
    • EXPECTED RESULT:The cycle is removed, the body of cycle is inserted directly at current position
  5. Remove try...catch
    1. Open RemoveSurrouding.java
    2. Put cursor at line 37 or 39
    3. Press Alt+Backspace
    4. From popup select try ...
    • EXPECTED RESULT:Try/catch is removed, the body of both parts are inserted directly at current position
  6. Remove try... catch with resources
    1. Open RemoveSurrouding.java
    2. Put cursor at line 43
    3. Press Alt+Backspace
    4. From popup select try ...
    • EXPECTED RESULT:Try/catch is removed, the body of both parts are inserted directly at current position
  7. Remove synchronized block
    1. Open RemoveSurrouding.java
    2. Put cursor at line 49
    3. Press Alt+Backspace
    4. From popup select synchronized(...) ...
    • EXPECTED RESULT:The block is removed, its body is inserted directly at current position
  8. Remove code - invalid case
    1. Open RemoveSurrouding.java
    2. Put cursor at line when is not surrounding code
    3. Press Alt+Backspace
    • EXPECTED RESULT:IDE beeps and no popup is opened
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo