TS 70 CV - NetBeans Wiki

TS 70 CV

"Test specification name" Test Specification for UI Commit Validation"

Author: Tomas Musil
Version: "1.0"
Last update: "29/10/2010"
Introduction: "Describes basic ui commit validation suite. Based on IDECommitValidationTest.java"
Comments: ""

Contents


Test suite: "Basic IDE Validation suite"

Purpose: "test basic functionality of ide on java based project"
Setup: "Start IDE"

  1. "Help"
    1. "Invoke Help|Help contents"
    • EXPECTED RESULT: "Help window appears, you can navigate through it. Close the window."
  2. "Options"
    1. "Invoke Tools|Options"
    2. "Set manual proxy by filling in proper values into http proxy and port textfields."
    3. "Hit OK to close options"
    • EXPECTED RESULT: "Settings are taken into account and are persistent."
  3. "Create new Java project"
    1. "Open New Project wizard from main menu (File|New Project)"
    2. "Select Java Application project from Java category"
    3. "In the next panel type project name and project location in"
    4. "Finish the wizard"
    • EXPECTED RESULT: "Check that project appeared in Project view (CTRL-1)"
  4. "Global Shortcuts"
    1. "CTRL-N opens New File wizard. Close by ESC"
    2. "SHIFT-F1 opens Javadoc Index Search. Close window."
    3. "CTRL-SHIFT-F8 opens New Breakpoint dialog. Close dialog."
    • EXPECTED RESULT: "All shortcuts work."
  5. "Create new file"
    1. "Open New File wizard from main menu (File|New File)"
    2. "Select created sample project as target"
    3. "Select Java|Java Package file type"
    4. "In the next panel type package name in"
    5. "Finish wizard"
    6. "Open New File wizard from context menu on created package node (New|File)"
    7. "Select Java|Java Main Class file type"
    8. "In the next panel type class name in"
    9. "Finish wizard"
    • EXPECTED RESULT: "Check that class is opened in editor and close all opened documents."
  6. "CVS lite"
    1. "From main menu invoke Team|CVS|Checkout"
    • EXPECTED RESULT: "CVS checkout wizard appears, close the wizard."
  7. "Projects view"
    1. "Switch to projects view (Window|Projects)"
    2. "Expand source hierarchy and find sample class you created in previous testcase"
    3. "Copy sample class and paste it to the same package"
    4. "Refactoring dialog appears, type class name and confirm"
    5. "Verify that class was correctly copied (refactored)"
    6. "Cut sample class you have copied and paste it to another package"
    7. "Confirm refactor-move diaglog."
    8. "Verify that class was correctly moved."
    9. "Delete moved class"
    • EXPECTED RESULT: "All operations can be successfully performed"
  8. "Files view"
    1. "Switch to files view (Window|Files)"
    2. "In file hierarchy navigate to sample java class you created"
    • EXPECTED RESULT: "Class is present in files view"
  9. "Editor"
    1. "Open sample main class in Editor (context menu Open on the node)"
    2. "Type abbreviation 'sout' (hit TAB to expand) into main method and then 'Hello'"
    3. "Verify that it is written 'System.out.println("Hello");'"
    4. "Select the text and call copy from editor's context menu"
    5. "Insert dummy text at next line , select it and paste the text in the clipboard"
    6. "Code has replaced dummy text"
    7. "Select 'Hello' at second line and delete it by context menu"
    8. "Insert 'Good bye' instead"
    • EXPECTED RESULT: "Basic editor operations work"
  10. "Build and Run"
    1. "Select sample main class node and call "Run|Compile" main menu item"
    2. "Wait until compilation finishes (track status bar)"
    3. "Select sample main class node and call "Run|Run File" main menu item"
    4. "Wait run finishes"
    5. "From context menu on project node set sample project as main project"
    6. "Call "Run|Build Main Project" main menu item"
    7. "Wait until build finishes"
    8. "Call "Run|Run Main Project" main menu item"
    9. "Wait until run finishes"
    • EXPECTED RESULT: "Verify that text was correctly printed to output window (CTRL-4 to navigate to output window)"
  11. "Debugging"
    1. "Open sample class in editor"
    2. "Goto line with 'System.out.println("Hello");' and push Shift+F8 to toggle breakpoint"
    3. "Goto line with 'System.out.println("Good bye");' and call 'Toggle Line Breakpoint" context menu item"
    4. "From main menu select Debug|Debug file to start debugger"
    5. "Wait until first breakpoint is reached and call Debug|Continue from main menu"
    6. "Wait until second breakpoint is reached and check 'Hello' is printed to output"
    7. "Finish debugger by main menu action (Debug|Finish Debugger Session)"
    • EXPECTED RESULT: "Debugger is working properly"
  12. "JUnit"
    1. "Add some methods in main class"
    2. "Invoke Tools|Create JUnit Test"
    3. "Select "JUnit 3.x" in "Select JUnit Version" dialog, hit Select button"
    4. "Confirm Create Tests dialog"
    5. "Check whether test was open in editor and if includes test of public, protected, default but not private method"
    6. "Check that test file is present in Projects view under Test packages node"
    7. "Select sample main class, open it in editor"
    8. "Call "Navigate|Go to Test" main menu item"
    9. "Check test class is opened in editor"
    10. "Run single test from main menu Run|Run File"
    • EXPECTED RESULT: "Check status bar that test was executed"
  13. "DB"
    1. "Select Databases node Services window (Window|Services)"
    2. "Select Drivers node"
    3. "Invoke popup on Drivers node, choose Add driver"
    4. "Add driver dialog appears. Close it."
    5. "Choose some existing driver under Drivers node, select from popup menu Connect using"
    6. "Connect using dialog appears. Close it."
    • EXPECTED RESULT: "Dialogs can be invoked successfully"
  14. "Window system"
    1. "Open Favorites window from main menu Window|Favorites"
    2. "Attach Favorites as last tab to output mode"
    3. "attach Favorites to top of Projects tab"
    4. "Attach Favorites to right of output mode"
    5. "Attach Favorites as last tab to explorer mode (next to Projects)"
    6. "Close Favorites"
    7. "Open sample java file in editor"
    8. "Maximize opened editor by menu item "Maximize Window" on its tab"
    9. "Restore editor by menu item "Restore Window" on its tab"
    10. "Close all opened documents by invoking Window|Close All Documents"
    • EXPECTED RESULT: "Window can be attached to various positions, can be maximized, restored and closed"


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo