TS 69 JavaFX Samples

Samples Test Specification

Author: Lark Fitzgerald
Version: 1.2
Last update: 04 August 2010
Introduction: The Java FX SDK Platform
Comments:


Contents



Test suite: Java FX Sample Plugins Installation

Purpose: Installation testing of the plugin. \\ Setup: Install jdk 1.6u10 or higher. \\

Download and Install the Best Practices Samples NBM

  • Invoke 'Tools | Plugins...' from the main menu bar.
  • Under Available Plugins Tag, select JavaFX Weather Sample.
  • Press the Install button.
  • EXPECTED RESULT: Weather should be installed without errors.
  • EXPECTED RESULT: The IDE should automatically restart.
  • EXPECTED RESULT: WeatherSamples should be available from the project dialog: Samples > JavaFX.
  • EXPECTED RESULT: JavaFX Weather Application should show a description under this node. Here is a snapshot of the NB 6.1 M2 release description: "The JavaFX Weather application displays the current weather conditions for three locations, with an animated image of the weather appearing in the background. The application highlights the animation timeline, the user interface APIs (including filter effects), and connectivity to a web service through the Java programming language. The application is a complete NetBeans project that can be immediately run within the IDE."

Download and Install the Best Practices Samples NBM

  • Invoke 'Tools | Plugins...' from the main menu bar.
  • Under Available Plugins Tag, select JavaFX Best Practices.
  • Press the Install button.
  • EXPECTED RESULT: Best Practices module should be installed without errors.
  • EXPECTED RESULT: The IDE should automatically restart.
  • EXPECTED RESULT: Samples should be available from the New Project dialog: Samples > JavaFX > Best Practices.
  • EXPECTED RESULT: The following 9 folders should be listed under Best Practices: Color, Forms, Game, Image, Input, Math, Motion, Simulation, Transform.
  • EXPECTED RESULT: The following folder content should be listed:
  • EXPECTED RESULT: Color: Color Wheel, Linear Gradient
  • EXPECTED RESULT: Forms: Points and Lines, Shape Primitives
  • EXPECTED RESULT: Game: Bounce
  • EXPECTED RESULT: Image: Background Image, Displaying, Transparency
  • EXPECTED RESULT: Input: Clock, Constrain, Easing, Milliseconds, Mouse 1D, Mouse 2D, Mouse Press, Storing Input
  • EXPECTED RESULT: Math: Arctangent, Distance 1D, Distance 2D, Sine, Sine Wave
  • EXPECTED RESULT: Motion: Bouncy Bubbles, Linear
  • EXPECTED RESULT: Simulation: Flocks, Simple Particle System, Smoke Particle System
  • EXPECTED RESULT: Transform: Rotate, Scale, Translate

Test suite: Java FX Sample Creation and Runtime

Purpose: A high level of testing is done on samples to make sure that they are functional across all areas of development and execution. \\ Setup: Install jdk 1.6u10 or higher. \\

Create and Run Weather Sample application

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX.
  • Select JavaFX Weather Application > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: WeatherFXApplication will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Weather Sample application as Applet

  • In the Projects tab, expand the WeatherFXApplication > Source Packages > weatherfx folder.
  • right click on the WeatherApp.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Weather application will be executed as an applet.

Run Weather Sample application File

  • Open the WeatherApp.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The WeatherApp.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Weather Sample application as Web Start

  • Right click the WeatherFXApplication and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Color Wheel Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Color.
  • Select Color Wheel > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Color Wheel will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Color Wheel Sample application as Applet

  • In the Projects tab, expand the Color Wheel > Source Packages > color folder.
  • right click on the ColorWheel.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Color Wheel application will be executed as an applet.

Run Color Wheel Sample application File

  • Open the ColorWheel.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The ColorWheel.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Color Wheel Sample application as Web Start

  • Right click the Color Wheel application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Linear Gradient Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > color.
  • Select Linear Gradient > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Linear Gradient will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Linear Gradient Sample application as Applet

  • In the Projects tab, expand the Linear Gradient > Source Packages > color folder.
  • right click on the GradientSample.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Linear Gradient application will be executed as an applet.

Run Linear Gradient Sample application File

  • Open the GradientSample.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The GradientSample.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Linear Gradient Sample application as Web Start

  • Right click the Linear Gradient application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Points and Lines Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Forms.
  • Select Points and Lines > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Points and Lines will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Points and Lines Sample application as Applet

  • In the Projects tab, expand the Points and Lines > Source Packages > forms folder.
  • right click on the PointsAndLines.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Points and Lines application will be executed as an applet.

Run Points and Lines Sample application File

  • Open the PointsAndLines.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The PointsAndLines.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Points and Lines Sample application as Web Start

  • Right click the Points and Lines application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Shape Primitives Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Forms.
  • Select Shape Primitives > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Shape Primitives will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Shape Primitives Sample application as Applet

  • In the Projects tab, expand the Shape Primitives > Source Packages > forms folder.
  • right click on the ShapePrimitives.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Shape Primitives application will be executed as an applet.

Run Shape Primitives Sample application File

  • Open the ShapePrimitives.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The ShapePrimitives.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Shape Primitives Sample application as Web Start

  • Right click the Shape Primitives application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Bounce Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Game.
  • Select Bounce > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Bounce will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Bounce Sample application as Applet

  • In the Projects tab, expand the Bounce > Source Packages > game folder.
  • right click on the Bounce.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Bounce application will be executed as an applet.

Run Bounce Sample application File

  • Open the Bounce.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Bounce.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Bounce Sample application as Web Start

  • Right click the Bounce application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Background Image Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > image.
  • Select Background Image > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Background Image will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Background Image Sample application as Applet

  • In the Projects tab, expand the Background Image > Source Packages > image folder.
  • right click on the BackgroundImage.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Background Image application will be executed as an applet.

Run Background Image Sample application File

  • Open the BackgroundImage.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The BackgroundImage.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Background Image Sample application as Web Start

  • Right click the Background Image application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Displaying Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > image.
  • Select Displaying > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Displaying will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Displaying Sample application as Applet

  • In the Projects tab, expand the Displaying > Source Packages > image folder.
  • right click on the Displaying.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Displaying application will be executed as an applet.

Run Displaying Sample application File

  • Open the Displaying.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Displaying.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Displaying Sample application as Web Start

  • Right click the Displaying application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Transparency Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > image.
  • Select Transparency > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Transparency will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Transparency Sample application as Applet

  • In the Projects tab, expand the Transparency > Source Packages > image folder.
  • right click on the Transparency.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Transparency application will be executed as an applet.

Run Transparency Sample application File

  • Open the Transparency.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Transparency.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Transparency Sample application as Web Start

  • Right click the Transparency application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Clock Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Input.
  • Select Clock > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Clock will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Clock Sample application as Applet

  • In the Projects tab, expand the Clock > Source Packages > input folder.
  • right click on the Clock.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Clock application will be executed as an applet.

Run Clock Sample application File

  • Open the Clock.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Clock.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Clock Sample application as Web Start

  • Right click the Clock application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Constrain Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Input.
  • Select Constrain > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Constrain will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Constrain Sample application as Applet

  • In the Projects tab, expand the Constrain > Source Packages > input folder.
  • right click on the Constrain.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Constrain application will be executed as an applet.

Run Constrain Sample application File

  • Open the Constrain.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Constrain.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Constrain Sample application as Web Start

  • Right click the Constrain application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Easing Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > input.
  • Select Easing > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Easing will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Easing Sample application as Applet

  • In the Projects tab, expand the Easing > Source Packages > input folder.
  • right click on the Easing.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Easing application will be executed as an applet.

Run Easing Sample application File

  • Open the Easing.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Easing.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Easing Sample application as Web Start

  • Right click the Easing application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Milliseconds Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > input.
  • Select Milliseconds > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Milliseconds will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Milliseconds Sample application as Applet

  • In the Projects tab, expand the Milliseconds > Source Packages > input folder.
  • right click on the Milliseconds.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Milliseconds application will be executed as an applet.

Run Milliseconds Sample application File

  • Open the Milliseconds.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Milliseconds.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Milliseconds Sample application as Web Start

  • Right click the Milliseconds application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Mouse 1D Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > input.
  • Select Mouse 1D > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Mouse 1D will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Mouse 1D Sample application as Applet

  • In the Projects tab, expand the Mouse 1D > Source Packages > input folder.
  • right click on the Mouse1D.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Mouse 1D application will be executed as an applet.

Run Mouse 1D Sample application File

  • Open the Mouse1D.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Mouse1D.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Mouse 1D Sample application as Web Start

  • Right click the Mouse 1D application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Mouse 2D Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > input.
  • Select Mouse 2D > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Mouse 2D will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Mouse 2D Sample application as Applet

  • In the Projects tab, expand the Mouse 2D > Source Packages > input folder.
  • right click on the Mouse2D.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Mouse 2D application will be executed as an applet.

Run Mouse 2D Sample application File

  • Open the Mouse2D.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Mouse2D.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Mouse 2D Sample application as Web Start

  • Right click the Mouse 2D application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Mouse Press Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > input.
  • Select Mouse Press > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Mouse Press will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Mouse Press Sample application as Applet

  • In the Projects tab, expand the Mouse Press > Source Packages > input folder.
  • right click on the MousePress.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Mouse Press application will be executed as an applet.

Run Mouse Press Sample application File

  • Open the MousePress.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The MousePress.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Mouse Press Sample application as Web Start

  • Right click the Mouse Press application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Storing Input Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > input.
  • Select Storing Input > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Storing Input will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Storing Input Sample application as Applet

  • In the Projects tab, expand the Storing Input > Source Packages > input folder.
  • right click on the StoringInput.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Storing Input application will be executed as an applet.

Run Storing Input Sample application File

  • Open the StoringInput.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The StoringInput.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Storing Input Sample application as Web Start

  • Right click the Storing Input application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Arctangent Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Math.
  • Select Arctangent > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Bouncy Bubbles will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Arctangent Sample application as Applet

  • In the Projects tab, expand the Arctangent > Source Packages > math folder.
  • right click on the Arctangent.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Arctangent application will be executed as an applet.

Run Arctangent Sample application File

  • Open the Arctangent.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Arctangent.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Arctangent Sample application as Web Start

  • Right click theArctangent application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Distance 1D Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Math.
  • Select Distance 1D > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Bouncy Bubbles will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Distance 1D Sample application as Applet

  • In the Projects tab, expand the Distance 1D > Source Packages > math folder.
  • right click on the Distance1D.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Distance 1D application will be executed as an applet.

Run Distance 1D Sample application File

  • Open the Distance1D.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Distance1D.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Distance 1D Sample application as Web Start

  • Right click the Distance 1D application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Distance 2D Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Math.
  • Select Distance 2D > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Bouncy Bubbles will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Distance 2D Sample application as Applet

  • In the Projects tab, expand the Distance 2D > Source Packages > math folder.
  • right click on the Distance2D.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Distance 2D application will be executed as an applet.

Run Distance 2D Sample application File

  • Open the Distance2D.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Distance2D.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Distance 2D Sample application as Web Start

  • Right click the Distance 2D application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Sine Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Math.
  • Select Sine > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Bouncy Bubbles will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Sine Sample application as Applet

  • In the Projects tab, expand the Sine > Source Packages > math folder.
  • right click on the Sine.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Sine application will be executed as an applet.

Run Sine Sample application File

  • Open the Sine.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Sine.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Sine Sample application as Web Start

  • Right click the Sine application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Sine Wave Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Math.
  • Select Sine Wave > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Bouncy Bubbles will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Sine Wave Sample application as Applet

  • In the Projects tab, expand the Sine Wave > Source Packages > math folder.
  • right click on the SineWave.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Sine Wave application will be executed as an applet.

Run Sine Wave Sample application File

  • Open the SineWave.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The SineWave.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Sine Wave Sample application as Web Start

  • Right click the Sine Wave application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Bouncy Bubbles Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > motion.
  • Select Bouncy Bubbles > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Bouncy Bubbles will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Bouncy Bubbles Sample application as Applet

  • In the Projects tab, expand the Bouncy Bubbles > Source Packages > motion folder.
  • right click on the BouncyBubbles.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Bouncy Bubbles application will be executed as an applet.

Run Bouncy Bubbles Sample application File

  • Open the BouncyBubbles.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The BouncyBubbles.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Bouncy Bubbles Sample application as Web Start

  • Right click the Bouncy Bubbles application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Linear Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > motion.
  • Select Linear > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Linear will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Linear Sample application as Applet

  • In the Projects tab, expand the Linear > Source Packages > motion folder.
  • right click on the Linear.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Linear application will be executed as an applet.

Run Linear Sample application File

  • Open the Linear.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Linear.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Linear Sample application as Web Start

  • Right click the Linear application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Flocks Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Simulation.
  • Select Flocks > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Flocks will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Flocks Sample application as Applet

  • In the Projects tab, expand the Flocks > Source Packages > particles folder.
  • right click on the FlockDemo.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Flocks application will be executed as an applet.

Run Flocks Sample application File

  • Open the FlockDemo.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The FlockDemo.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Flocks Sample application as Web Start

  • Right click the Flocks application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Simple Particle System Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Simulation.
  • Select Simple Particle System > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Simple Particle System will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Simple Particle System Sample application as Applet

  • In the Projects tab, expand the Simple Particle System > Source Packages > particles folder.
  • right click on the SimpleParticleSystem.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Simple Particle System application will be executed as an applet.

Run Simple Particle System Sample application File

  • Open the SimpleParticleSystem.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The SimpleParticleSystem.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Simple Particle System Sample application as Web Start

  • Right click the Simple Particle System application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Smoke Particle System Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Simulation.
  • Select Smoke Particle System > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: Smoke Particle System will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Smoke Particle System Sample application as Applet

  • In the Projects tab, expand the Smoke Particle System > Source Packages > particles folder.
  • right click on the SmokeParticleSystem.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Smoke Particle System application will be executed as an applet.

Run Smoke Particle System Sample application File

  • Open the SmokeParticleSystem.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The SmokeParticleSystem.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Smoke Particle System Sample application as Web Start

  • Right click the Smoke Particle System application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Rotate Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Transform.
  • Select Rotate > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: __ will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Rotate Sample application as Applet

  • In the Projects tab, expand the Rotate > Source Packages > transform folder.
  • right click on the Rotate.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Rotate application will be executed as an applet.

Run Rotate Sample application File

  • Open the Rotate.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Rotate.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Rotate Sample application as Web Start

  • Right click the Rotate application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Scale Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Transform.
  • Select Scale > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: __ will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Scale Sample application as Applet

  • In the Projects tab, expand the Scale > Source Packages > transform folder.
  • right click on the Scale.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Scale application will be executed as an applet.

Run Scale Sample application File

  • Open the Scale.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Scale.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Scale Sample application as Web Start

  • Right click the Scale application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Create and Run Translate Sample

  • File > New Project to open the New Project Dialog.
  • Samples > JavaFX > Best Practices > Transform.
  • Select Translate > Press Next > Press Finish (Modifier: change the name and press finish).
  • Press F6 to run as application
  • EXPECTED RESULT: __ will be created. If you chose to change the name then the new name will be used.
  • EXPECTED RESULT: F6 will run compile, deploy, and run the

Run Translate Sample application as Applet

  • In the Projects tab, expand the Translate > Source Packages > transform folder.
  • right click on the Translate.fx and select 'Run Applet'.
  • EXPECTED RESULT: The Translate application will be executed as an applet.

Run Translate Sample application File

  • Open the Translate.fx in the editor (double click on it).
  • right click on the editor page and select 'Run File'.
  • EXPECTED RESULT: The Translate.fx will open without errors in the editor.
  • EXPECTED RESULT: The Application will run without errors as it would in a default run.

Run Translate Sample application as Web Start

  • Right click the Translate application and select 'Properties'.
  • Select Category Application > WebStart and set the 'Enable Web Start' option to true.
  • Select Category Run and set the 'Run with Java Web Start' option to true.
  • Press OK.
  • Press F6 to run the application again.
  • EXPECTED RESULT: Property changes made to the application will be saved and viewable.
  • EXPECTED RESULT: The application will run as a Java Web Start (See:

Test suite: Java FX Sample Command Line

Purpose: Samples are also contained within the SDK and need to be tested there as well. \\ Setup: Install jdk 1.6u10 or higher. \\

Run Samples from SDK command line

  • Download and install SDK if different than the one bundled with FX Plugin.
  • cd javafx-sdk1.0 (if using plugin SDK it is in the Netbeans 6.1/javafx directory.
  • cd samples
  • cd SmokeParticleSystem
  • ant run
  • EXPECTED RESULT: ant run should compile and run the Smoke Particle System Sample Application.
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo