TS 68 CDev Sanity

Kenai integration (Connected Developer) Sanity Test Specification for NetBeans 6.8

Author: Jaromir Uhrik
Version: 1.0
Lastupdate: 2009/08/06
Introduction: Testcases for sanity testing of the Kenai integration (Connected Developer) in NetBeans ide
Comments: The testcases in this sanity test specification are intended to cover the main functionality of the Kenai integration. The test specification should be executable manually by 2 hours. For all testsuites it is required that the user must have existing account at kenai.com

Contents



Test suite: Login

Purpose: Test the login dialog with login scenarios
Setup: Start NetBeans IDE with clear userdir.

  1. Check Kenai login menu availability
    1. Go to main menu Team
    • EXPECTED RESULT: The Team menu must contain Kenai submenu. Login to Kenai... item must be available there. If the user is logged in then the item is changed to Logout and vice versa.
  2. Check Kenai Dashboard availability in main menu
    1. Go to Window menu
    • EXPECTED RESULT: The Kenai Dashboard item must be available there with assigned shortcut Ctrl+8.
  3. Check Chat menu availability in main menu
    1. Go to Window menu
    • EXPECTED RESULT: The Chat item must be available there and no shortcut is assigned to this action.
  4. Login (non persistent)
    1. Go to main menu Team>Kenai>Login to Kenai...
    2. The dialog with title Login to Kenai__ appears
    3. Type the Username and Password of your existing user and push Login button
    4. The user logs on and projects of the user are opened in Kenai dashboard
    5. Restart IDE
    • EXPECTED RESULT: The Kenai Dashboard contains projects but they are not in bold (which indicates that the user is not logged in). The first line of the Kenai Dashboard contains Login to Kenai... link. In Team>Kenai main menu there is available item Login to Kenai...
  5. Login (persistent)
    1. Go to main menu Team>Kenai>Login to Kenai...
    2. The dialog with title Login to Kenai appears
    3. Type the Email or Username and Password of your existing user
    4. Select the checkbox Remember me and push Login button
    5. The user logs on and projects of the user are opened in Kenai dashboard
    6. Restart IDE
    • EXPECTED RESULT: The Kenai Dashboard starts to load projects of the persisted user immediately after the restart. The Team>Kenai main menu contains Logout item (besides other items). The kenai dashboard project items appear in bold shortly and its first line contains the name of the logged user
  6. Logout
    1. Go to main menu Team>Kenai>Logout
    • EXPECTED RESULT: The Kenai Dashboard contains projects but they are not in bold (which indicates that the user is not logged in). The first line of the Kenai Dashboard contains Login to Kenai... link. In Team>Kenai main menu there is available item Login to Kenai...
  7. Check the forgot password link
    1. Go to main menu Team>Kenai>Login to Kenai...
    2. Click on the Forgot Your Password? link
    • EXPECTED RESULT: The default system browser appears with the url http://kenai.com/people/forgot_password. It is possible to Enter your user name or your email address and Submit it via this page.
  8. Check the sign up link
    1. Click on the Sign up now. link in opened Login to Kenai dialog
  9. Cancel the login dialog
    1. Push Cancel button in opened Login to Kenai dialog
    • EXPECTED RESULT: The Login to Kenai dialog disappears shortly.

Test suite: Kenai Projects

Purpose: Test the kenai projects maintenance in IDE.
Setup: Start NetBeans IDE with clear userdir.

  1. Create project on Kenai
    1. Log in to Kenai (main menu Team>Kenai>Login to Kenai...)
    2. Invoke Team>Kenai>New Kenai Project from the main menu
    3. Fill in the project details (unique name, display name, description and license)
    4. Click Next
    5. Choose the issue tracking and source code management details
    6. Click Finish and wait for the dialog with the local repository path to show up (note the repository path somewhere)
    • EXPECTED RESULT: A dialog announcing a successful project creation and some other details (local repository path) should show up. A new project is created and opened in the Kenai dashboard - it should be in the bottom of the list and its display name should be in boldface. Check that the local repository was created correctly.
  2. Share project on Kenai
    1. Create a Netbeans project (for example a "My Java Application") or use some existing project that is not versioned yet
    2. Right-click the project in the Projects view and invoke "Share On Kenai"
    3. If you are not logged in to Kenai, log in using the Login button
    4. Fill in some project name, project display name, description and choose some license
    5. Leave the checkbox Commit the source into repository checked
    6. Click the Help button and verify that the Help is displayed properly (close the help then)
    7. Click Finish
    • EXPECTED RESULT: A project is created on Kenai and sources are committed to the repository using the SVN (check it on web). User must be logged in in order to create a project on Kenai.
  3. Open/Find Kenai project
    1. Go to Kenai dashboard and in its top-right corner push Open Project...
    2. Type anagram to the Search textfield
    3. Push Search button
    4. In the list below there appears some items - select Anagram Game (anagram-game) and push OK button
    • EXPECTED RESULT: The Anagram Game project appears in kenai dashboard.
  4. Get Sources from Kenai
    1. Select the Anagram Game in kenai dashboard
    2. Expand its Sources node
    3. Click on the "get" (blue part) of Source Code Repository(get)
    4. The Get Sources from Kenai dialog apppears with preselected repository https://svn.kenai.com/svn/anagram-game~subversion
    5. Push Get From Kenai button
    • EXPECTED RESULT: The dialog diappears and the status bar shows the checkout progress. Shortly the Checkout Completed dialog appears and asks whether to open the project. Push Open Project causes that the Projects view is selected and contains AnagramGame project. In Kenai dashboard below the current node there appear links AnagramGame; Open local project... and Browse....


Test suite: Bugtracking

Purpose: Test the Bugtracking support in IDE.
Setup: Start NetBeans IDE with clear userdir. Log in to kenai. The support for JIRA is available at the update center so it is necessary to install it through Plugin manager (main menu Tools>Plugins.)

  1. Create Issuezilla/JIRA connectors
    1. Go to the Services tab (by Ctrl+5 shortcut)
    2. Select the Issue Trackers node
    3. Invoke popup menu and Create Issue Tracker...
    4. Create one for JIRA and one for Bugzilla
    • EXPECTED RESULT: Issue tracker nodes appear under the Issue Trackers node.
  2. Create issue, add attachment, comment issue, change summary and other fields
    1. Create issue, add attachment, comment issue, change summary and other fields
    • EXPECTED RESULT: Check that the issue is in appropriate state at the server. Repeat this testcase for local JIRA, local Bugzilla, JIRA at kenai and Bugzilla at kenai.
  3. Resolve issue, resolve on commit, apply patch
    1. Resolve issue, resolve on commit, apply patch to an issue
    • EXPECTED RESULT: Check that the issue is in appropriate state at the server. Repeat this testcase for local JIRA, local Bugzilla, JIRA at kenai and Bugzilla at kenai.
  4. Find issue, Create query and work with query filters
    1. Find issue, Create query and work with query filters in query mask
    • EXPECTED RESULT: Check that the issue is in appropriate state at the server. Repeat this testcase for local JIRA, local Bugzilla, JIRA at kenai and Bugzilla at kenai.


Test suite: Chat Window

Purpose: Test the kenai chat
Setup: Start NetBeans IDE with clear userdir.

  1. Show kenai chat window
    1. Log in to kenai (as a user $USER1)
    2. Select a project ($PRJ1)in kenai dashboard and push the chatroom link
    3. On a different machine go to main menu Window>Chat and push Login to Keani... and follow the login as a different user ($USER2 which is observer of $PRJ1) to kenai
    • EXPECTED RESULT: Both users have the Chat window available at the top-right corner of IDE.
  2. Send private message
    1. Select the combobox in Chat window of $USER2 and push the $USER1 item
    2. Type a message in the window below and push Enter key
    • EXPECTED RESULT: The message appears at the Envelop icon in the toolbar of $USER2. Clicking on it opens the tab in Chat window with the name $USER2.
  3. Send project message
    1. Select the combobox in Chat window of $USER2 and push the $PRJ1 item
    2. Type a message in the window below and push Enter key
    • EXPECTED RESULT: The message appears at the Envelop icon in the toolbar of $USER2. Clicking on it opens the tab in Chat window with the name $PRJ1.



Test suite: Hudson support

Purpose: Test the Hudson support in NetBeans IDE
Setup: Start NetBeans IDE with clear userdir.

  1. Create a new Hudson instance
    1. Open the Services view (Ctrl+5)
    2. Right-click the Hudson Builders node and invoke Add Hudson Instance
    3. Close the dialog by clicking Cancel
    4. Right-click the Hudson Builders node and invoke Add Hudson Instance again
    5. Fill in an arbitrary name, for example "My Hudson", in the Name field (this will be used as an alias for the instance)
    6. Specify the URL of a Hudson instance
    7. Click Add button
    • EXPECTED RESULT: A new node named My Hudson is added in the services view (under the Hudson Builders node). Expanded node contains jobs subnodes (if any jobs are available at the hudson server)
  2. Check the Hudson instance popup menu
    1. Right-click the Hudson instance (for example "My Hudson")
    • EXPECTED RESULT: Menu contains following five items: New Build, Synchronize, Open in Browser, Remove, Properties.
  3. Create a simple job
    1. Create a new "Hello World" Java Application, and make it versioned in SVN
    2. Right-click the Hudson instance and choose New Build...
    3. Select the project versioned in subversion from the combobox
    4. Change the default name to "My Job - 1"
    5. Confirm the dialog by pushing Create button
    • EXPECTED RESULT: A new Hudson job is created, it must be visible in the services view. System default browser pops up and shows the hudson's page.
  4. Run Hudson job
    1. Make sure the application can be built (commit the changes, if any)
    2. Right-click the Hudson job node under Hudson instance node in the Services view
    3. Choose Start Job from the popup menu
    4. Right-click the Hudson instance and choose Synchronize from the popup menu to see that the job is being built (you will see a little badge by the node)
    5. Wait for a while (15seconds)
    6. Right-click the Hudson instance and choose Synchronize from the popup menu
    • EXPECTED RESULT: Successful build is indicated by the blue balloon. If you committed some changes to the source code before the build, they are visible after you invoke "Show Changes" from the build popup menu. The build console can be displayed by "Show Console" command from the build popup menu.
  5. Showing build console
    1. Right-click any build of a job under Hudson instance node
    2. Invoke Show Console from the context menu
    • EXPECTED RESULT: A console output for last (potentially running) job of the given project is opened in the Output window.
  6. Hudson instance - Remove
    1. Right-click the Hudson instance (for example "My Hudson")
    2. Invoke Remove from the context menu
    3. Click Cancel in the dialog that shows up
    4. Invoke Remove from the context menu again
    5. Click OK
    • EXPECTED RESULT: A Hudson instance is removed after you click OK and it mustn't be removed after you click Cancel.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo