TS 67 PHP Interface

PHP Interface Test Specification for NetBeans 6.7

Author: Filip Zamboj
Version: 1.0
Introduction: This specification provides default settings of NetBeans IDE

Contents


Test suite: Verify Correct PHP Interface Setting After Successful PHP Module Activation

Purpose: Verify that all default options and settings are present and they values are correctly set.
Setup: PHP engine and Apache 2.2 are configured. Apache 2.2 is installed.

  1. Verify Initial Interface after PHP module Activation
    1. activate PHP module in Tools -> Plugins -> Installed -> PHP and choose activate
    • EXPECTED RESULT: there are (as well) following buttons present in IDE: Run Project, Debug Project
  2. Verify PHP Options After PHP Module Activation
    1. Choose Tools -> Options
    • EXPECTED RESULT PHP tab is present and
    • PHP 5 Interpreter contains path to php (verify that!!)
    • Output Window option is enabled by default
    • Debugger Port is set up to 9000
    • Session ID is netbeans-xdebug
    • Stop at the first line is checked by default
  1. Verify Editor->Hints Options After PHP Module Activation
    1. Choose Tools -> Options -> Editor -> Hints and
    • EXPECTED RESULT PHP and Javascript language is present in drop-down menu. All stable features for PHP and all General features for Javascript are enabled by default.
  2. Verify Editor -> Code Templates for Presence of All necessarry languages
    1. Choose Tools -> Options -> Editor -> Code Templates
    • EXPECTED RESULT: language drop down menu contains following languages (as well)
    • Cascading Style Sheet
    • DTD
    • HTML
    • JSON
    • JavaScript
    • JavaScript comments
    • PHP
    • PHP Documentor Comments
    • SQL
    • YAML
  1. Verify Editor -> Fonts & Colors for Presence of All necessarry languages
    1. Choose Tools -> Options -> Fonts & Colors -> Syntax
    • EXPECTED RESULT: language drop down menu contains following languages (as well)
    • Cascading Style Sheet
    • DTD
    • HTML
    • JSON
    • JavaScript
    • JavaScript comments
    • PHP
    • PHP Documentor Comments
    • SQL
    • YAML
  1. Verify Editor -> Mark Occurences for Presence of All necessarry languages and default settings
    1. Choose Tools -> Options -> Editor -> Mark Occurences
    • EXPECTED RESULT: language drop down menu contains PHP Language and checkbox Mark Occurences Of Symbol Under Caret is checked


teradown TEARDOWN Restart NB with clean userdir }}

Test suite: Verify Correct PHP Interface Setting After Successful PHP Project Creation

Purpose: Verify that all default options and settings are present and they values are correctly set.
Setup: PHP engine and Apache 2.2 are configured. Apache 2.2 is installed.

  1. Verify Interface after Project is created
    1. Create Sample PHP Project AirAlliance
    • EXPECTED RESULT: project is created and Project Tab contains tree with a root of Created Project with a correct name and two children Source Files and Include Path. Buttons Debug and Run are not shadowed anymore. You can find several mistakes in tasks window. You, eventually, can compare to the interface screenshot File:verify_interface_after_project_created_TS_67_PHP_Interface.png

}}teradown Teardown: delete project and restart NB with clean userdir }}


Test suite: Verify Correct Menu Setting After Successful PHP Project Creation

Purpose: Verify that all default options and settings are present and they values are correctly set.
Setup: PHP engine and Apache 2.2 are configured. Apache 2.2 is installed.

  1. Verify Navigate Menu after Project is created
    1. invoke Main Menu -> navigate
    • EXPECTED RESULT: Following items are enabled
    • Go To File
    • Go To Type
    • Go To Symbol
  1. Verify Run Menu after Project is created
    1. invoke Main Menu -> Run
    • EXPECTED RESULT: Following items are enabled
    • Run Project (<Project Name>)
    • Test Project (<Project Name>)
    • Set Project Configuration
    • * Default (set)
    • * Customize ...
    • Set Main Project
    • * None (set)
    • * <project name>
    • Test File
  1. Verify Debug Menu after Project is created
    1. invoke Main Menu -> Debug
    • EXPECTED RESULT: following items are enabled
    • Debug Project <Project Name> (set)
    • Attach Debugger
    • New Watch
  1. Verify Window Menu after Project is created
    1. invoke Main Menu -> Window -> Other
    • EXPECTED RESULT: following items are enabled
    • Exception Reporter
    • CSS Preview
    • CSS Style Builder

}}teradown Teardown: delete project and restart NB with clean userdir }}


Test suite: Verify Palette after opening a file

Purpose: Verify that palette opens after php file is open

  1. Verify Interface after Project is created
    1. Create Sample PHP Project AirAlliance
    2. open file index.php
    • EXPECTED RESULT: A Palette will be open on the right side of the editor. Check the image for further reference.

File:verify_palette_TS_67_PHP_Interface.png }}teradown Teardown: delete project and restart NB with clean userdir }}

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo