TS 65 Tasklist

"Tasklist" Test Specification for "NetBeans 6.5"

Author: "Lukas Hasik"
Version: "1.0"
Last update: "22/09/2008"
Introduction: "Tasklist is part of the NetBeans distribution and its window is visible by default. User can see list of "tasks" in the window."
Comments: ""

Next version: TS_70_Tasklist.
Previous version: None

Contents


Test suite: "Default settings"

Purpose: Check the default settings of the task list after start of IDE with fresh user dir
Setup: Start IDE with fresh userdir, create a new java project

  1. "Tasklist window is open"
    1. Start NB IDE
    • EXPECTED RESULT: "Tasklist is opened. Its position is bottom right. It occupies the whole area under editor."
  2. "Default settings"
    1. Check that "All opened projects" icon is selected by default
    2. Check that "Default Filter" is set as filter
    3. Click the funnel icon in tasklist window
    4. Choose Edit
    • {{{1}}}


Test suite: "Show me results"

Purpose: ""
Setup: open attached projects TasklistScenarios, TasklistDependencies, TasklistLibraryProject in IDE. Open following files TasklistScenarios.tasklistscenarios.ClazzWithErrors, TasklistLibraryProject.library.LibraryClazz, TasklistDependencies.tasklistdependencies.Main

  1. Edited file only
    1. Focus in is an file in editor
    2. Click the "Show tasks for currently edited file only" icon in Tasklist window
    • EXPECTED RESULT: Only tasks for opened documant are shown in tasklist
  2. Main Project and all that depends on it
    1. Set TasklistDependencies project as Main project
    2. Click the "Main Project and all that depends on it" icon in Tasklist window
    • EXPECTED RESULT: Only tasks for TasklistDependencies, TasklistLibraryProject projects are shown in tasklist
  3. "All opened projects"
    1. Click the "All opened projects" icon in Tasklist window
    • EXPECTED RESULT: Tasks for ALL opened projects are shown in tasklist
  4. "No main project set"
    1. Run > Set Main Project > None
    2. Click the "Main Project and all that depends on it" icon in Tasklist window
    3. Change the selected project in Projects window
    • EXPECTED RESULT: Only tasks for selected project are shown in tasklist
  1. "Group tasks by category"
    1. Click the "Group tasks by category" icon in Tasklist window
    • EXPECTED RESULT: Tasks in tasklist window are sorted in categories - e.g. Error, ToDo etc.
  1. "Display tasks as list"
    1. Click the "Display tasks as list" icon in Tasklist window
    • EXPECTED RESULT: Tasks in tasklist window are unsorted. Just a list/table of tasks.
  2. "Double click on result row"
    1. Double click on a row with error/task in tasklist window
    • EXPECTED RESULT: Error/Task line opens in editor. Focus is in editor on the line with error. User can start fixing/writing immediately.
  3. "Enter on result row"
    1. Press ENTER on a row with error/task in tasklist window
    • EXPECTED RESULT: Error/Task line opens in editor. Focus is in editor on the line with error. User can start fixing/writing immediately.
  1. "Window > Tasks"
    1. Close the Tasks window
    2. Window > Tasks
    • EXPECTED RESULT: Tasks window opens again.
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo