TS 65 OptionsDialog

Options Dialog Test Specification for NetBeans 6.5

Author: Petr Chytil
Lastupdate: 07/03/2008
Introduction: This document serves as a testspeciation of the options dialog. The Options dialog was redesigned completely and replaces the old options dialog. The main goals of redesign were improved UI, better usability and especially easier discoverability of indivdual options. This testspec focuses on core functionality of new Options dialog. Tests of individual options from additional modules plugged into Options dialog should be included in testspecs for these modules.

Contents


Test suite: General Options

Purpose: General tests of Options dialog.
Setup: Start the IDE.

  1. Options Startup
    1. Invoke new Options dialog from main menu in Tools | Options.
    • EXPECTED RESULT: Progress bar should be displayed untill new Options dialog is opened. Startup time should be less than 5 secs on standard workstation. Categories should be displayed on the top and General section should be opened by default.
  1. Options After Startup
    1. Start the IDE.
    2. Right after startup, open new Options dialog from Tools | Options.
    3. Click through all sections and tabs of the Options dialog right after startup.
    • EXPECTED RESULT: No exceptions should be thrown. The dialog should look reasonable even if data is not loaded yet. All sections should be accessible.
  1. Web Browser
    1. Try to change web browser to all available options.
    2. Open web browser from Window | Web | Web Browser.
    • EXPECTED RESULT: www.netbeans.org should appear in all available browsers. Only browsers which are present on your OS should be listed among options - see issue 223957
  1. Proxy Settings
    1. Try to change proxy settings.
    2. Check if web is accessible or not accessible according to the proxy settings change.
    3. Go to Tools | Plugins and check if all changes are propagated to Update Center.
    4. Change Proxy settings at Settings tab in Plugins and check if changes are propagated properly to Options dialog.
    • EXPECTED RESULT: Settings should persist, no values should be lost. Changes in Options should propagate to Plugins and vice versa.


Test suite: Miscellaneous

  1. Ant Settings
    1. Try to change all of the Ant settings.
    2. Verify that all options work as defined.
    • EXPECTED RESULT: All settings should work as expected.
  1. GUI Builder Settings
    1. Try to change all of the GUI Builder settings.
    2. Verify that all options work as defined.
    • EXPECTED RESULT: All settings should work as expected.


Test suite: Miscellaneous - File types

  1. New file type
    1. Invoke Options > Miscellaneous > File types dialog.
    2. Click on "New.." button.
    3. Write "fodt" as a file extension into dialog window.
    4. Set it's Associated File Type (MIME) to "XML Files (text/xml) and click on OK.
    5. Download hello_TS_65_OptionsDialog.fodt
    6. Open "hello_TS_65_OptionsDialog.fodt" file in IDE.
    • EXPECTED RESULT: File is opened and treated as XML file. Syntax highlighting, source formating etc. works properly.
  1. Remove custom file type
    1. Invoke Options > Miscellaneous > File types dialog.
    2. Select "fodt" File Extension and click on "Remove" button.
    3. Close the Options window by clicking on OK button.
    4. Open "hello_TS_65_OptionsDialog.fodt" file in IDE.
    • EXPECTED RESULT: File is opened and treated as a plain text file. Syntax highlighting, source formating etc. does not work.
  1. Default file type
    1. Invoke Options > Miscellaneous > File types dialog.
    2. Select some File extension from combo box (e.g. ant).
    3. Change it's MIME type (e.g. to Form Objects (text/x-java)) and remember yourself the default type.
    4. Click OK to close Options dialog.
    5. Invoke again File types dialog and check whether the change persisted.
    6. Select File Extension, which have you previously changed (ant).
    7. Click on "Default" button and check whether MIME type changed properly.
    • EXPECTED RESULT: Changes are always persistent and the default button changes MIME to it's initial value.


Test suite: Preselected category

Purpose: Verify, that Options dialog can be opened with preselected category/subcategory.

  1. Diff options
    1. Open two .java files.
    2. Select both files in Projects window (ctrl+click on each).
    3. Invoke context menu on one of them (right click) and select Tools > Diff.
    4. Click on "Options..." button in newly opened diff view in editor.
    • EXPECTED RESULT: Options dialog is opened. The Miscellaneous > Diff category is selected.



Test suite: Advanced Options

Purpose: Verify, that Options dialog shows Advanced Options button. Setup: Clean IDE installation with fresh userdir to ensure that there are no advanced setting files

  1. No Advanced Options button
    1. Open Tools | Options
    • EXPECTED RESULT: Options dialog is opened. There is no Advanced Options button
  1. Show Advanced Options button
    1. Setup: add a file to nb_user_dir/config/UI/Services
    2. Open the Options dialog
    • EXPECTED RESULT: Options dialog is opened. IDE recognized advanced setting and Advanced Options button is displayed.
  1. Browse Advanced Options
    1. Click on "Advanced Options..." button
    2. View of Options changes to Advance Options table
    • EXPECTED RESULT: You can browse the advanced options table. You can change the settings.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo