TS 61 JDA

Java Desktop Project - Basic Shell Test Specification for NetBeans 6.1

Author: Jana Maleckova
Version: 6.1
Last update: 2008/01/29
Introduction: This Test Specification tests wizard for Java Desktop Project - Basic shell. It will generate a basic application skeleton containing everything needed to start with a general desktop application.

Contents


Test suite: Test step 1. in wizard for Java Desktop Project - Basic Shell

Purpose: This shows Swing Application Framework support in action and creating of Java Desktop Application (Basic shell) wizard. It will generate a basic application skeleton containing everything needed to start with a general desktop application.
Setup: Start IDE with clear userdir

  1. Invoke Project wizard from File menu
    1. Go to File -> New Project
    2. Select Java node in Categories tree
    3. Select Java Desktop Application in Projects tree
    4. Press button Cancel on wizard
    • EXPECTED RESULT: Nothing was created and no exception was thrown. When Java Desktop Application node is selected in Project tree, Description area in the New Project wizard contains text:
      "Creates a skeleton of a desktop application based on Swing Application Framework (JSR 296)..."
  1. Invoke Project wizard by shortcut
    1. Press Ctrl+Shift+N
    2. Select Java node in Categories tree
    3. Select Java Desktop Application in Project tree
    4. Press Escape on keyboard
    • EXPECTED RESULT: Dialog "New Project" is opened and user can select Java Desktop Application node in Project tree. When Escape key is pushed, wizard should be closed without any changes and no project should not be created
  1. Invoke Project wizard by pressing a toolbar button
    1. Click button File:NewProjectIco.png in the Toolbar
    2. Select Java node in Categories tree
    3. Select Java Desktop Application in Project tree
    4. Press Help button
    5. Close Help
    6. Press button Next
    • EXPECTED RESULT: Dialog "New Project" is opened and user can select Java Desktop Application node in Project tree. Help button should invoke IDE help "New Project Wizard: Choose Project". After clicking the Next button, user should proceed to the second step of wizard. Title of the window should be named "New Desktop Application". Dialog should contain fields for defining Name and Location of a project. No exception should be thrown and no project is created at this moment.


Test suite: Test step 2 in wizard for Java Desktop Application

Purpose: Test if all fields can be filled and all buttons are corretly working
Setup: Go to File -> New Project -> Select Java node in Categories tree -> Select Java Desktop Application in Project tree -> Press button Next

  1. Test Field "Project Name"
    1. Fill name with spaces
    2. Fill name with special characters
    3. Fill name of already existed Project in your directory
    • EXPECTED RESULT:
      1. step -> Wizard should pass
      2. step -> Wizard should warn you as well: "Application Class is not a valid class name"
      3. step -> Wizard should warn you: "Project Folder already exist and is not empty".
      In all cases wizard should disable Finish button, only buttons Back and Cancel must be enabled
  1. Test field Project Location
    1. Write wanted project location by hand
    2. Past copied project location
    3. Invoke Project Location browser and select location and cancel it
    4. Invoke Project Location browser and select location and confirm it
    • EXPECTED RESULT: All steps except step no. 3 should pass without any problem and in every case, path should be set correctly. Step 3 should not fill any path. Field Project path is all the time disabled and display path filled in Project Location field
  1. Test field Application Class
    1. Fill class name with spaces
    2. Fill class name with special characters
    3. Fill class name but without dot
    4. Fill class name in correct format: e.g. DesktopAppl.DesktopAppl
    • EXPECTED RESULT:
      steps 1-3 -> wizard should warn you about incorrect name of application class.
      step 4 should pass
  1. Test Application Shell options
    1. Select Basic Application by mouse
    2. Select Database Application by mouse
    • EXPECTED RESULT:
      Step 1 -> Basic Application node should be selected and appropriate text about basic skeleton should be in description window. Only buttons Back, Finish, Cancel and Help should be enabled (Next button is disabled).
      Step 2 -> Database Application node should be selected and description window should contained appropriate information as well. Enabled buttons are: Back, Next, Cancel and Help


Test suite: Test - Create Basic Java Desktop Application

Purpose: To test both steps together
Setup: Start IDE with fresh userdir

  1. Test wizard with default settings
    1. Invoke wizard for New Project (File -> New Project)...
    2. Select Java node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press Next
    5. Press Finish
    • EXPECTED RESULT: No exceptions are thrown and a new project DesktopApplication1 is created in specified directory (~/NetBeansProjects by default). Project is displayed in Project window and 3 classes are generated in desktopapplication1 package:
      1. DesktopApplication.class which is responsible for launch, startup, exit and shutdown of gui
      2. DesktopApplication1Frame.class - simple GUI which should represent basic usual desktop application
      3. DesktopApplication1AboutBox.java - represents "About" window.
      Generated resources with appropriate bundles and required icons (subpackages resources - contains ResourceBundle of each Class - and resources.busyicons - contains icons designed for processes) are also contained in Projects window. Project is set as Main project by default.
  1. Test wizard with user settings
    1. Invoke wizard by pressing shortcut Ctrl+Shift+N
    2. Select Java node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press Next
    5. Fill correct name of Project but different from default (${projectName})
    6. Fill different project location from it's default
    7. Uncheck option - Set as Main Project
    8. Fill correct but different Application Class name
    9. Press Finish
    • EXPECTED RESULT: No exceptions are thrown and new project with name ${projectName} is created in specified directory. Project is displayed in Project Window and 3 classes are generated in ${projectName} package:
      1. ${projectName}.class which is responsible for launch, startup, exit and shutdown of gui
      2. ${projectName}Frame.class - simple GUI which should represent basic usual desktop application
      3. ${projectName}AboutBox.java - represents "About" window.
      There are also generated resources with appropriate bundles and required icons in the Projects window (as mentioned in previous test case). Project is not set as Main project.
  1. Test cancellation of wizard
    1. Invoke wizard by pressing icon File:NewProjectIco.png in toolbar
    2. Select Java node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press Next button
    5. Fill correct name of Project but different from default (${projectName})
    6. Fill different project location from it's default
    7. Uncheck option - Set as Main Project
    8. Fill correct but different Application Class name
    9. Press Cancel button
    • EXPECTED RESULT: Wizard should be closed and no project is created
  1. Test buttons Back and Next
    1. Invoke wizard by pressing shortcut Ctrl+Shift+N
    2. Select Java node in Categories
    3. Select Java Desktop Application node in Projects
    4. Press Next
    5. Fill correct name of Project but different from default (${projectName})
    6. Fill different project location from it's default
    7. Fill correct but different Application Class name
    8. Press Back button
    9. Press Next button
    10. Press Finish button
    • EXPECTED RESULT: Project should be created in chosen location and should have structure described in TestCase no. 2. If user pushes a Back button in the second step and then he returns back using a Next button, all previously entered settings should be reloaded again.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo