TS 61 BPELProjectWizards

Orchestration Projects/Wizards Test Specification

Author: Victoria Zhukovskaya
Version: 1.1
Last update: 01 October 2007
Introduction: This specification provides a usecases of creation of the BPEL project in the in the Orchestration module.
Comments:


Contents


Test suite: Create a new MyBPELModule1

Purpose: Check the Wizard.
Setup:

  1. Create new MyBPELModule1 with help Wizard
    1. Invoke from main menu "File" -> "New Project ..."
    2. Select "SOA" from Categories and select "BPEL Module" from Projects. Press "Next" button.
    3. Enter the name of project - "MyBPELModule1" and select a location. Press "Finish" button.
    • EXPECTED RESULT: A "New Project" wizard appears.
    • EXPECTED RESULT: A "New BPEL Module" wizard appears.
    • EXPECTED RESULT: The "MyBPELModule1" node apears on project tab.
  1. Entering incorrect project name
    1. Invoke from main menu "File" -> "New Project ..."
    2. Select "SOA" from Categories and select "Orchestation Project" from Projects. Press "Next" button.
    3. Enter the name of project - "MyBPELModule*" and select a location.
    4. Press "Cancel" button.
    • EXPECTED RESULT: A "New Project" wizard appears.
    • EXPECTED RESULT: "New BPEL Module" wizard appears.
    • EXPECTED RESULT: "Finish" button should be disabled. There should be "Project Name is not a valid folder name" text.
    • EXPECTED RESULT: The project should not be opened.
  1. Entering empty project location
    1. Invoke from main menu "File" -> "New Project ..."
    2. Select "SOA" from Categories and select "BPEL Module" from Projects. Press "Next" button.
    3. Enter the Project Name - "MyBPELModule2"
    4. Empty the "Project Location" and select a location.
    5. Press "Finish" button.
    • EXPECTED RESULT: A "New Project" wizard appears.
    • EXPECTED RESULT: "New BPEL Module" wizard appears.
    • EXPECTED RESULT: "Finish" button should be enabled. And "MyBPELModule2" node apears on project tab. The porject created in the default location
  1. Create the project with existing name
    1. Invoke from main menu "File" -> "New Project ..."
    2. Select "SOA" from Categories and select "BPEL Module" from Projects. Press "Next" button.
    3. Enter the Project Name - "MyBPELModule3" select the "Project Location" and select a location. Press Finish.
    4. Right click on "MyBPELModule3" on "Project" tab and select "Close Project".
    5. Invoke from main menu "File" -> "New Project ..."
    6. Select "SOA" from Categories and select "BPEL Module" from Projects. Press "Next" button.
    7. Enter the Project Name - "MyBPELModule3" select the same "Project Location" (as in step 3) and select a location.
    8. Press "Cancel".
    • EXPECTED RESULT: A "New Project" wizard appears.
    • EXPECTED RESULT: "New BPEL Module" wizard appears.
    • EXPECTED RESULT: "MyBPELModule3" node apears on project tab.
    • EXPECTED RESULT: "MyBPELModule3" node disapears on project tab.
    • EXPECTED RESULT: A "New Project" wizard appears.
    • EXPECTED RESULT: "New BPEL Module" wizard appears.
    • EXPECTED RESULT: "Finish" button should be disabled. There should be "Project Folder already exists and is not empty." text.
    • EXPECTED RESULT: "MyBPELModule3" node dos not apears on project tab.


Test suite: Check file wizards for Orchestration projects

Purpose: Check the Wizards of xsd, wsdl, bpel files.
Setup: BPELModule should be created. Name of the project is MyBPELModule4. MyBPELModule4 node shold be opened on Projects Tab.

  1. Create xsd file
    1. Right Click on Process Files node on Project Tab and select New -> Other...
    2. Select XML Category and then select XML Schema. Press Next.
    3. Press Finish.
    4. Right click on newXmlSchema.xsd and select Delete.
    • EXPECTED RESULT: New File Wizard should be appeared
    • EXPECTED RESULT: There should be Name and Location part of wizard. File Name is newXmlSchema.
    • EXPECTED RESULT: newXmlSchema.xsd is appeared under Process Files node on Project Tab.
    • EXPECTED RESULT: newXmlSchema.xsd is disappeared under Process Files node on Project Tab.
  1. Create wsdl file
    1. Right-click on Process Files node on Project Tab and select New -> Other...
    2. Select XML Category and then select WSDL Document. Press Next.
    3. Press Finish.
    4. Right click on newWSDL.wsdl and select Delete.
    • EXPECTED RESULT: New File Wizard should be appeared.
    • EXPECTED RESULT: There should be Name and Location part of wizard. File Name is newWSDL
    • EXPECTED RESULT: newWSDL.wsdl is appeared under Process Files node on Project Tab.
    • EXPECTED RESULT: newWSDL.wsdl is disappeared under Process Files node on Project Tab.
  1. Create wsdl file and import xsd
    1. Right Click on Process Files node on Project Tab and select New -> Other...
    2. Select XML Category and then select WSDL Document. Press Next.
    3. Type newWSDL1 in File Name field. Toggle to tru Import XML Schema File(s) check box.
    4. Press Browse ...
    5. Expand "By File" -> MyBPELModule4 -> Process Files and Toggle to tru Import for newXmlSchema.xsd.
    6. Press Finish.
    • EXPECTED RESULT: New File Wizard should be appeared.
    • EXPECTED RESULT: There should be Name and Location part of wizard.
    • EXPECTED RESULT: Browse button will be enabled.
    • EXPECTED RESULT: Add Import window will be opened.
    • EXPECTED RESULT: XML Schema(s) will have path to newXmlSchema.xsd.
    • EXPECTED RESULT: newWSDL1.wsdl is appeared under Process Files node on Project Tab.
  1. Crete bpel file
    1. Right Click on Process Files node on Project Tab and select New -> Other...
    2. Select SOA Category and then select BPEL Process. Press Next.
    3. Press Finish.
    4. Right click on newWSDL.wsdl and select Delete.
    • EXPECTED RESULT: New File Wizard should be appeared.
    • EXPECTED RESULT: There should be Name and Location part of wizard. File Name is newProcess.
    • EXPECTED RESULT: newProcess.bpel is appeared under Process Files node on Project Tab.
    • EXPECTED RESULT: newProcess.bpel is disappeared under Process Files node on Project Tab.
  1. Remove all file xsd, wsdl and bpel into Folder
    1. Right Click on Process Files node on Project Tab and select New -> Other...
    2. Select XML Category and then select XML Schema. Press Next.
    3. Press Finish.
    4. Right-click on Process Files node on Project Tab and select New -> Other...
    5. Select XML Category and then select WSDL Document. Press Next.
    6. Press Finish.
    7. Right Click on Process Files node on Project Tab and select New -> Other...
    8. Select SOA Category and then select BPEL Process File Type. Press Next.
    9. Press Finish.
    10. Right Click on Process Files node on Project Tab and select New -> Other...
    11. Select Other Category and then select Folder. Press Next.
    12. Press Finish.
    13. Select all files under on Process Files node and dnd int newFolder.Expand newFolder.
    14. Right click on newFolder and select Delete.
    • EXPECTED RESULT: New File Wizard should be appeared
    • EXPECTED RESULT: There should be Name and Location part of wizard. File Name is newXmlSchema.
    • EXPECTED RESULT: newXmlSchema.xsd is appeared under Process Files node on Project Tab.
    • EXPECTED RESULT: New File Wizard should be appeared.
    • EXPECTED RESULT: There should be Name and Location part of wizard. File Name is newWSDL
    • EXPECTED RESULT: newWSDL.wsdl is appeared under Process Files node on Project Tab.
    • EXPECTED RESULT: New File Wizard should be appeared.
    • EXPECTED RESULT: There should be Name and Location part of wizard. File Name is newFolder
    • EXPECTED RESULT: newFolder is appeared under Process Files node on Project Tab.
    • EXPECTED RESULT: newFolder has 3 files - newProcess.bpel, newWSDL.wsdl and newXmlSchema.xsd.
    • EXPECTED RESULT: newFolder and 3 files are deleted.


Test suite: Check testcases for Orchestration projects

Purpose: Check the Wizards creation testcases.
Setup: Create Synchronouse Sample. Deploy SynchronouseSample.

  1. Check files and menu of Testcase
    1. Expand SynchronouseSampleApplication -> Test -> TestCase0
    2. Right-click on SynchronouseSampleApplication -> Test node.
    3. Right-click on SynchronouseSampleApplication -> Test -> TestCase0 node
    • EXPECTED RESULT: There are Input and Output nodes.
    • EXPECTED RESULT: There is menu items: 'New TestCase', 'Delete All Results'
    • EXPECTED RESULT: There is menu items: 'Run', 'Debug', 'Diff' (disabled menu item), 'Delete', 'Delete Results', 'Properies'.
  1. Create/Edit/Delete TestCase
    1. Right-click on SynchronouseSampleApplication -> Test node and select 'New TestCase'.
    2. Enter myTestCase1 name and press Next.
    3. Select SynchronouseSampe.wsdl and press Next.
    4. Select operation1 and press Finish.
    5. Change '?string?' value into 'Hi!' in opened editor .
    6. Right-click on SynchronouseSampleApplication and select 'Test'. Answer Yes for Overwrite Empty Output Dialog.
    7. Expand TestCase0 node.
    8. Expand myTestCase1 node.
    9. Right-click myTestCase1 node and select Run.
    10. Right-click on SynchronouseSampleApplication -> Test and select 'Delete All Results'. Answer Yes for Overwrite Empty Output Dialog.
    11. Expand TestCase0 and myTestCase1 nodes.
    12. Right-click on myTestCase1 node and select Delete.
    • EXPECTED RESULT: New Test Case dialog is appeared.
    • EXPECTED RESULT: New Test Case - Select the WSDL Document step of dialog is appeared.
    • EXPECTED RESULT: New Test Case - Select the Operation to Test step of dialog is appeared.
    • EXPECTED RESULT: Input.xml file is opened for edit. SynchronouseSampleApplication -> Test has myTestCase1 node wich cantain Input and Output. Output.xml is empty.
    • EXPECTED RESULT: Input.xml file is opened for edit. SynchronouseSampleApplication -> Test has myTestCase1 node wich cantain Input and Output. Output.xml is empty.
    • EXPECTED RESULT: See output results.
    • EXPECTED RESULT: There is new node with results of running testing. It is passed - node is gray.
    • EXPECTED RESULT: There is new node with results of running testing. It is passed but checked as not passed - node is red. Output.xml file is not empty now.
    • EXPECTED RESULT: There is new node with results of running testing. It is passed - node is gray. Output.xml file is not empty now.
    • EXPECTED RESULT: There are not testresults nodes.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo