TS 60 MobilityCreateNew

Mobility Pack Test Specification for Create New actions

Author: Lukas Hasik
Version: 0.1
Lastupdate: 31.05.2007
Introduction: Test specification for creating new objects in Mobility Pack 6.0

Contents


Test suite: New Project wizard

Purpose: Create all the project types that are available in NetBeans Mobility Pack 6.0
Comment: Please, note that there is bundled only CLDC/MIDP runtime - Sun Java Wireless Toolkit - with Mobility Pack. If you wanna create CDC applications you have to add an CDC SDK to the IDE first. You can use one of the supported CDC SDKs

  1. Create New MIDP Application with Hello MIDlet
    1. New Project > Mobility > MIDP Application
    2. Specify a project name and location
    3. Let the Set as Main Project check box checked
    4. Let the Create Hello MIDlet check box checked
    5. Press Finish button
    • EXPECTED RESULT: New Mobile project is created with the name in the location. HelloMidlet visual midlet opens in editor. Project is set as main and is bold in Project view. You can Run project and it starts the HelloMidlet in emulator
  2. Create New MIDP Application
    1. New Project > Mobility > MIDP Application
    2. Specify a project name and location
    3. Uncheck the Set as Main Project check box
    4. Uncheck the Create Hello MIDlet check box
    5. Press Finish button
    • EXPECTED RESULT: New empty Mobile project is created with the name in the location.
  3. Create New Mobile Class Library
    1. New Project > Mobility > Mobile Class Library
    2. Specify a project name and location
    3. Press Finish button
    • EXPECTED RESULT: New empty Mobile Class Library project is created with the name in the location.
  4. Create New CDC Application
    1. New Project > Mobility > CDC Application
    2. Specify platform, device, profile. Next.
    3. Specify a project name and location.
    4. Let the Set as Main Project check box checked
    5. Let the Create Main Class check box checked
    6. Press Finish button
    • EXPECTED RESULT: New empty CDC Application project is created with the name in the location. Project is set as main and is bold in Project view. New Main class is created and the right template is used according to selected platform. You can run the project. It will start in emulator.
  5. Create New CDC Class Library
    1. New Project > Mobility > CDC Class Library
    2. Specify platform, device, profile. Next.
    3. Specify a project name and location
    4. Press Finish button
    • EXPECTED RESULT: New empty Mobile Class Library project is created with the name in the location.
  6. Create New Mobile Application When Platform Is Not Available
    1. New Project > Mobility > Mobile Application
    2. Install platform
    3. Specify a project name and location
    4. Uncheck the Set as Main Project check box
    5. Uncheck the Create Hello MIDlet check box
    6. Press Finish button
    • EXPECTED RESULT: New empty Mobile project is created with the name in the location. The IDE must ask to install the new platform.
  7. Create New CDC Application When Platform Is Not Available
    1. New Project > Mobility > CDC Application
    2. Install platform
    3. Specify platform, device, profile. Next.
    4. Specify a project name and location.
    5. Let the Set as Main Project check box checked
    6. Let the Create Main Class check box checked
    7. Press Finish button
    • EXPECTED RESULT: New empty CDC Application project is created with the name in the location. Project is set as main and is bold in Project view. New Main class is created and the right template is used according to selected platform. The IDE must ask to install the new platform.
  8. Import Mobile Project from Existing MIDP Sources
    1. New Project > Mobility > Mobile Project from Existing MIDP Sources
    2. Browse for Sources Location
    3. Specify a project name and location.
    4. Let the Set as Main Project check box checked
    5. Press Finish button
    • EXPECTED RESULT: New project is created with the name in the location. Project is set as main and is bold in Project view. The sources stays in the original location. You can check it in the Files view. The sources folders are visible under Sources Packages of project.
  9. Import Wireless Toolkit Project
    1. New Project > Mobility > Import Wireless Toolkit Project
    2. Browse for WTK Location. The bundled WTK is selected by default
    3. Select any of the Detected Applications
    4. Specify a project name and location
    5. Let the Set as Main Project check box checked
    6. Press Finish button
    • EXPECTED RESULT: New project is created with the name in the location. Project is set as main and is bold in Project view. The original sources are copied into the new location. You can check it in the Files view.
  10. Import CDC Pack 5.5 Project
    1. New Project > Mobility > Import CDC Pack 5.5 Project
    2. Browse for the old Project Location. You need a project created with NetBeans Mobility Pack 5.5 for CDC.
    3. Specify a project name and location.
    4. Let the Set as Main Project check box checked
    5. Press Finish button
    • EXPECTED RESULT: New project is created with the name in the location. Project is set as main and is bold in Project view. The original sources are copied into the new location. You can check it in the Files view.
  11. Import CDC Toolkit project
    1. New Project > Mobility > Import CDC Toolkit Project
    2. Browse for the Project Location. You need a project created with Sun Java Toolkit 1.0 for CDC.
    3. Specify a project name and location.
    4. Let the Set as Main Project check box checked
    5. Press Finish button
    • EXPECTED RESULT: New project is created with the name in the location. Project is set as main and is bold in Project view. The original sources are copied into the new location. You can check it in the Files view.


Test suite: New File wizard

Purpose: Create all the file types that are available in Mobility project
Setup: Open File > New File wizard on a mobility project

  1. Create New Visual MIDlet
    1. MIDP > Visual MIDlet, Next
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New Visual MIDlet is created in the package. The visual midlet opens in editor. The active view is Flow. There is Mobile Device at the Flow Design. The midlet is added to midlet list in project properties (jad).
  2. Create New Visual Design
    1. MIDP > Visual Design
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New Visual design is created in the package. The visual design opens in editor. The active view is Flow. There is no Mobile device in the Flow Design.
  3. Create New MIDlet
    1. MIDP > MIDlet, Next
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New MIDlet is created in the package. The midlet opens in editor. The midlet is added to midlet list in project properties (jad).
  4. Create New Canvas
    1. MIDP > Canvas
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New canvas is created in the package, it opens in editor.
  5. Create New Visual Game design
    1. MIDP > Visual Game Design
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New GameDesign is created in the package. The game designer opens in editor. The active view is Game Builder Navigator.
  6. Create New Xlet
    1. CDC > Xlet
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New xlet is created in the package, it opens in editor.
  7. Create New Personal Profile Xlet Form
    1. CDC > Personal Profile Xlet Form
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New awtxlet is created in the package, it opens in editor.
  8. Create New AGUI Xlet Form
    1. CDC > AGUI Xlet Form
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New aguixlet is created in the package, it opens in editor.
  9. Create New Ricoh Xlet
    1. CDC > Ricoh Xlet
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New ricoh xlet is created in the package, it opens in editor.
  10. Create New CreMe JFrame Form
    1. CDC > CreMe JFrame Form
    2. Specify a name and package
    3. Press Finish button
    • EXPECTED RESULT: New frame is created in the package, it opens in editor.
  11. Create New SVG File
    1. Others > SVG File
    2. Specify a filename and folder
    3. Press Finish button
    • EXPECTED RESULT: New SVG file is created in the folder, it opens in editor.
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo