TS 60 Maven

NetBeans Maven Support Test Specification

Author: Jaromir Uhrik
Last update: 30.10.2007
Introduction: In NetBeans 6.0 the Maven support is not the part of the standard NetBeans distribution and it is only available on Update Center. The user needs to install the plugin first to the NetBeans IDE through the Plugin Manager that is available in main menu Tools->Plugins (just install Maven plugin which is available in Java category).

Contents


Test suite: Maven installation

Purpose: Test if there is no problem with installation of the Maven plugin to the NetBeans IDE.
Setup: Start IDE with clean userdir.


  1. Plugin availability test
    1. Go to the main menu Tools->Plugins
    2. In Available Plugins tab write 'Maven' to the Search field.
    • EXPECTED RESULT: Only the Maven plugin is visible in the list, others are filetered off.
  1. Plugin installation test
    1. Push Install to install Maven plugin and proceed the installation.
    • EXPECTED RESULT: The plugin is installed successfully. The IDE restart is not required. In New Project wizard there appears new category Maven


Test suite: Maven Quick Archetype project

Purpose: Test working with Quick Archetype projects.

  1. Create new Maven Quick Archetype project
    1. In main menu push File|New Project...
    2. Select Maven|Maven Project and push Next button.
    3. Select 'Maven Quickstart Archetype' and push Next button.
    4. Push Finish button.
    • EXPECTED RESULT: The project is created and is set as default - its node is bold in Projects view
  1. Close project
    1. In Projects view invoke Close action in popup menu on the project
    • EXPECTED RESULT: The project closes - its node disappears from the Projects view
  1. Open Project
    1. Open project by File|Open Project and close it again
    • EXPECTED RESULT: The project opens and closes successfully.
  1. Open Recent Project
    1. In File|Open Recent Project select just closed project
    • EXPECTED RESULT: The project opens successfully. Close it again.
  1. Open project by new project action
    1. Go to main menu File|New Project
    2. Select Maven|Maven Project with Existing POM
    3. Push Next button
    4. The panel appears and tells that Any Maven2 based project can be opened and used within the IDE without any import procedure.
    5. Push Finish and the Open Project dialog appears
    6. Browse previously closed project and push Open Project
    • EXPECTED RESULT: The project opens successfully and its node is bold - this is the common behavior of main project.
  1. Check App.java existence
    1. Check that App.java exists in the project
    2. Edit its main method - add some print line to the code
    3. Run project by F6
    • EXPECTED RESULT: The dialog appears and tells that profile is needed. Push OK button so that the Informational dialog disappears
  1. Run project
    1. Open Project Properties (from popup in Projects view select Properties item while the focus stays in the project top node)
    2. Select Run in the left list of the properties dialog
    3. Push Browse button by the Main Class field then push Select Main Class Button and push OK to close project properties dialog
    4. Push F6 to execute project
    • EXPECTED RESULT: "Hello World!" and the custom string is printed in the output.
  1. Decline Delete project
    1. Select the project node in the Projects view and select Delete
    2. Push No button
    • EXPECTED RESULT: The project is still executable - try it by F6.
  1. Delete project
    1. Select the project node in the Projects view and select Delete
    2. Push Yes button
    • EXPECTED RESULT: The project disappears from the Projects view but check in some native file manager that the project folder exists with complete src folder.
  1. Delete project with sources
    1. Create new Maven Quick Archetype project
    2. Select the project node in the Projects view and select Delete
    3. Set checkbox selected
    4. Push Yes button
    • EXPECTED RESULT: The project disappears from the Projects view. Also check in some native file manager that the project folder disappeared from the disk.


Test suite: Creation of other archetype projects

Purpose: Test that other archetype projects can be created and deleted.

  1. Create Maven Webapp Archetype project
    1. In main menu push File|New Project...
    2. Select Maven|Maven Project and push Next button.
    3. Select Maven Webapp Archetype and push Next button.
    4. Push Finish button.
    • EXPECTED RESULT: The project is successfully created.
  1. Delete Maven Webapp Archetype project
    1. Select the project node in the Projects view and select Delete
    2. Set checkbox selected
    3. Push Yes button
    • EXPECTED RESULT: The project disappears from the Projects view. Also check in some native file manager that the project folder disappeared from the disk.
  1. Create Maven Mojo Archetype project
    1. In main menu push File|New Project...
    2. Select Maven|Maven Project and push Next button.
    3. Select Maven Mojo Archetype and push Next button.
    4. Push Finish button.
    • EXPECTED RESULT: The project is successfully created.
  1. Delete Maven Mojo Archetype project
    1. Select the project node in the Projects view and select Delete
    2. Set checkbox selected
    3. Push Yes button
    • EXPECTED RESULT: The project disappears from the Projects view. Also check in some native file manager that the project folder disappeared from the disk.


Generated: Oct 30 15:18:28 CET 2007

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo