TS 60 MainWindow

Main Window Test Specification for NetBeans 6.0

Author: Petr Chytil
Last update: 01/11/2008
Introduction: Main window of NetBeans consists of two main parts. First part is menu and menu items, second are toolbars. Both - menu and toolbars - are customizable by user. For customization use Tools -> Options and View -> Toolbars.

Contents


Test suite: Main Menus

Purpose: The UI is specified in UI specification and in so called permanent UI specification.
Setup: Start IDE with clear userdir.

  1. Icons
    1. Go to main menu.
    2. Try to open all menus.
    • EXPECTED RESULT: Only items representd actions shown also in toolbars have icons.
  1. Names of Menu Items
    1. Go to main menu.
    2. Try to open menus.
    • EXPECTED RESULT: Menu items fit to Java LF e.g. only prepositions with four or more letters should be capitalized.
               Menu items followed by "..."(three dots) opens frame/window.
               Check that separators exist where applicable, assure that there aren't double separators in main menu or the last menu item isn't separator. 
 
  1. Mnemonic Keys Automated
    1. Go to main menu.
    2. Try to open menus and invoke actions only by mnemonic keys.
    • EXPECTED RESULT: Appropriate menu is opened or action invoked. Correct letter is underlined in menu.
               There are no duplicates of mnemonic key in one menu or submenu. 
 
  1. Adding New Separator Automated
    1. Expand some menu node - e.g. "& File" and right click on it. Choose Add->Separator from popup menu.
    2. Separator Move Up to destination where should be visible (not last item, nor beside another separator)
    • EXPECTED RESULT: Assure that it was added correctly (as last item under that node).
  1. Move Up/Down Separator Automated
    1. Try move up/down some separators in menu bar in Options. Right click for Move Up/Down in popup menu on separator node.
    • EXPECTED RESULT: Item is moved and look of menu is changed - check that appropriate menu was changed.
  1. Deleting Separator Automated
    1. Delete separator.
    • EXPECTED RESULT: Item is deleted and look of menu is changed - check that appropriate menu was changed.
  1. Check Mnemonic
    1. Check all default menus in Option window.
    • EXPECTED RESULT: There is "&" in front of mnemonic letter in menu.
  1. Adding New Menu Automated
    1. Choose Add Menu from popup on Menu Bar in Options window under IDE Configuration, Look and Feel
    2. Type "Test Menu" into dialog that appears.
    • EXPECTED RESULT: New node is added in Option window and new menu appears in main menu.
  1. Change Order of Menus Automated
    1. Invoke Change Order... from popup on Menu Bar node in Options window under IDE Configuration, Look and Feel
    2. Change order of main menu items with Move Up/Down buttons.
    3. Finish pressing OK
    • EXPECTED RESULT: Menu order is changed according what you set.
  1. Deleting Menu Automated
    1. Delete menu.
    • EXPECTED RESULT: Item is deleted and look of menu is changed - check that appropriate menu disappeared.
  1. Rename Menu Automated
    1. Rename some menu node under Menu Bar in Options window, IDE Configuration, Look and Feel
    • EXPECTED RESULT: Node is renamed and menu name is changed in main menu too.
  1. Change Order of Menu Items
    1. Try move up/down some menu items under menu in Menu bar in Options. Right click for Move Up/Down in popup menu on menu item node.
    • EXPECTED RESULT: Item is moved and look of menu is changed - check that appropriate menu was changed.
  1. Deleting Menu Item Automated
    1. Delete menu.
    • EXPECTED RESULT: Item is deleted and look of menu is changed - check that appropriate menu disappeared.


Test suite: MainToolbars

Purpose: The scope of this spec is not to test a complete toolbar management. This spec defines only tests of the default actions in default toolbars, default toolbar configurations and ways how the user access' the currently existing toolbar management menu items.
Setup: Start IDE with clear userdir in Compact Windows Mode (default).


  1. Check View
    1. Expand menu View | Toolbars
    • EXPECTED RESULT: The items of currently visible toolbars are checked.
  1. Check persistence between toolbar popup menu and main menu
    1. In main menu View | Toolbars enable Versioning toolbar and disable Debug toolbar
    2. Push from main menu View | Toolbars | Small Toolbar icons
    • EXPECTED RESULT: Check persistence between popup menu over toolbars and main menu View
  1. Change configuration - persistence
    1. Push from main menu View | Toolbars
    2. Enable Versioning toolbar and disable Debug toolbar
    3. Push from main menu View | Toolbars | Small Toolbar icons
    4. Restart the IDE.
    • EXPECTED RESULT: Check persistence between popup menu over toolbars and main menu View
  1. Tooltip and contents
    1. Hold mouse over dragging area of each toolbar.
    • EXPECTED RESULT: Tooltip for each toolbar is shown and content of each toolbar is right and components are enabled and disabled correctly.
  1. Toolbars dragging
    1. Try to drag and move toolbars - e.g. change order of toolbars, place them in more line...
    2. Restart IDE.
    • EXPECTED RESULT: Check the new positions of toolbars.
  1. Disable all toolbars
    1. Push from main menu View | Toolbars
    2. Disable all toolbars in menu.
    • EXPECTED RESULT: All toolbars disappeared.
  1. Disable all toolbars - persistence
    1. Push from main menu View | Toolbars
    2. Disable all toolbars in menu.
    3. Restart IDE.
    • EXPECTED RESULT: All toolbars disappeared.
  1. Enable all toolbars
    1. Push from main menu View | Toolbars
    2. Enable all toolbars in menu.
    • EXPECTED RESULT: All toolbars appeared.
  1. Enable all toolbars - persistence
    1. Push from main menu View | Toolbars
    2. Enable all toolbars in menu.
    3. Restart IDE.
    • EXPECTED RESULT: All toolbars appeared.
  1. Reset toolbars
    1. Enable/disable some toolbars in menu.
    2. Push from main menu View | Toolbars | Reset Toolbars
    • EXPECTED RESULT: Toolbars are in default configuration.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo