TS 60 Autoupdate

NetBeans Autoupdate Test Specification

Author: Lukas Hasik, Jaromir Uhrik
Last update: 29.01.2007
Introduction: The Autoupdate client module provides the update of module or a group of modules available on the Autoupdate server through the Update Center Wizard. This document covers the specification of testing features included in the Autoupdate module. These tests should recognize issues contained in the Autoupdate module and check the module usability. If it is not pointed up explicitly then we suppose install/update of modules set that contains at least one module that needs IDE restart. Take care also about builds that are installed from rpm or solaris pkg because these build don't allow 'Global' installation but only installation to userdir. Global update of these modules is provided only by new rpm or solaris pkg.

Contents


Test suite: Proxy Configuration

Purpose: Test if the proxy configuration is working.
Setup: Start IDE with clean userdir, run Update Center Wizard. Proxy configuration dialog appears after click on button "Proxy Configuration...".


  1. Successful connection
    1. Click Proxy Configuration... button.
    2. Set up proxy (if you connect to internet through proxy)
    3. Press OK button.
    4. Press Next button.
    • EXPECTED RESULT: The Connecting dialog and then step 2 of the Update Center Wizard appears.
  1. Unccessful connection
    1. Click Proxy Configuration... button.
    2. Set up proxy to wrong values
    3. Press OK button.
    4. Press Next button.
    • EXPECTED RESULT: The Error dialog with text Unable to Connect to the Update Center Server appears.
  1. Proxy dialog possibilities
    1. Check that values set up in Proxy Port or Proxy Server are not remembered after Cancel
    2. Check that values set up in Proxy Port or Proxy Server are remembered after OK
    3. Check that check box Unable proxy works
    • EXPECTED RESULT: OK saves the values, Cancel let them unchanged.



Test suite: Autoupdate types

Purpose: Test of Autoupdate types (modify and create) in Options. The changes from Options should be propagated to Update Center wizard.
Setup: Configure the proxy properly. Open Tools | Options -> IDE Configuration | System | Autoupdate Types node (on Mac OS there is NetBeans | Preferences... instead of Tools | Options).


  1. Add new Autoupdate Type
    1. Choose New | General Update Center from popup on node IDE Configuration | System | Autoupdate Types in Tools | Options
    2. Type name AAA and press OK.
    • EXPECTED RESULT: The AAA autoupdate type appears in Options. Check that the AAA update center appears in Update Center wizard too! Issue 42855
  1. Bad URL in Autoupdate type
    1. Change Server URL to wrong value in Properties of a Autoupdate Type in Tools | Options
    2. Open Update Center wizard, enable only the Update Center with the wrong value and press Next.
    • EXPECTED RESULT: The Connecting dialog and then Error dialog appears
  1. Propagation of change
    1. Change enabled checkbox to enabled/disabled in Properties of a Autoupdate Type in Tools | Options
    2. Open Update Center wizard
    • EXPECTED RESULT: Check that change is propagated properly.



Test suite: Second panel

Purpose: Test second panel of Update center wizard.
Setup: Start the Update Center Wizard and configure the proxy properly. Select at least one Update Center to Install Module(s) from. Click Next button - and you're on second panel of Update Center wizard.


  1. Buttons
    1. Button >> - moves all modules from "Available Updates and New Modules" to "Include in Install"
    2. Button << - moves all modules from "Include in Install" to "Available Updates and New Modules"
    3. Button > - moves selected modules (one or more) from "Available Updates and New Modules" to "Include in Install"
    4. Button << - moves selected modules (one or more) from "Include in Install" to "Available Updates and New Modules"
    • EXPECTED RESULT: Check that buttons work properly.
  1. Accept license
    1. Add any module(s) to "Include in Install" in 2.step "Select Modules to Install" and press Next button
    2. Accept license
    • {{result|EXPECTED RESULT: You will be moved to the third panel of the Update Center Wizard.
       The IDE starts immediately download the selected modules. 
 
  1. Skip download step
    1. Add any module(s) to "Include in Install" in 2.step "Select Modules to Install" and press Next button
    2. Accept license
    3. Wait till download is finished. Press Back button.
    4. Press Next button again
    • EXPECTED RESULT: You will skip the download and will be moved to the fourth panel of the Update Center Wizard - View Certificates and Install modules.



Test suite: Fourth panel

Purpose: Test fourth panel of Update center wizard.
Setup: Start the Update Center Wizard and configure the proxy properly. Select at least one Update Center to Install Module(s) from. Click Next button. Choose at least two module to download and Next, let them download and Next.


  1. Include check box
    1. Un/Check Include checkbox
    2. Module Certificate dialog appears
    3. Try the buttons Accept/Reject/Do not allways accept
    • EXPECTED RESULT: Include checkbox is checked or unchecked properly.
  1. Save Copy ...
    1. Select any of the downloaded modules
    2. Press Save Copy ... button
    3. Choose directory to save the module. Press Save.
    • EXPECTED RESULT: Module is saved to choosed location
  1. Save Copy with wrong name
    1. Select any of the downloaded modules
    2. Press Save Copy ... button
    3. Type name of not existing dir to File name and press Save.
    • EXPECTED RESULT: No directory named xxx exist message appears



Test suite: Installation

Purpose: Check that modules are installed properly.
Setup: Start the Update Center Wizard and configure the proxy properly. Select at least one Update Center to Install Module(s) from. Click Next button. Choose at least two module to download and Next, let them download and Next.


  1. Module installation without restart
    1. Press Finish button on 4-th panel of Update Center wizard
    2. Update Center wizard is closed
    • EXPECTED RESULT: Module is installed. Check it in Tools
  1. Module installation with restart
    1. Press Finish button on 4-th panel of Update Center wizard
    2. Update Center wizard is closed
    3. Check Restart the IDE radio button (it's the default option)
    • EXPECTED RESULT: IDE restasrts. Module is installed. Check it in Tools
  1. New module installation - global
    1. Check Global checkbox for a new module(this module wasn't installed before, it's new for this IDE)
    2. Finish
    • EXPECTED RESULT: Module is installed to highest cluster(in case of NetBeans nb4.0). Any user of IDE can use it. Test it with new userdir, the module should be installed.
  1. Module update
    1. Module update is available on Update Center
    2. Download it to install and check Global installation, Finish
    • EXPECTED RESULT: Module is updated in the cluster where it was before.
  1. Select later update
    1. Press Finish button on 4-th panel of Update Center wizard
    2. Choose the Install Later radiobutton.
    3. Press OK button.
    4. The Update Center Wizard should hide and IDE must work without restarting.
    5. Close the IDE and restart again.
    • EXPECTED RESULT: The 'installed later' module will be installed on restart.



Test suite: Accessibility

Purpose: Accessibility of the Update Center Wizard.
Setup: Open Tools->Update Center


  1. Tab traversal
    1. Test the tab traversal at each dialog belonging to the Autoupdate module.
    • EXPECTED RESULT: All components in each of the dialog have to be accessible by tab.
  1. Mnemonics
    1. Test the mnemonics at each dialog belonging to the Autoupdate module.
    • EXPECTED RESULT: All components in each of the dialog must have unique mnemonic.



Test suite: Autoupdate module uninstall/install

Purpose: Check the stability of the module when it is uninstalled and then installed again.
Setup: Run IDE with the clean user directory.


  1. Uninstall of Autoupdate module
    1. Select main menu Tools | Options.
    2. Expand Configuration | System | Modules | Infrastructure.
    3. Select AutoUpdate
    4. Disable module (uncheck property Enabled).
    5. Close Options
    6. Expand main menu Tools.
    • EXPECTED RESULT: The menu item Autoupdate in the Tools menu is missing.
  1. Install of Autoupdate module
    1. Select main menu Tools | Options
    2. Expand IDE Configuration | System | Modules | Infrastructure.
    3. Select AutoUpdate
    4. Enable module (check property Enabled).
    5. Close Options
    6. Expand main menu Tools.
    • EXPECTED RESULT: The menu item Autoupdate should be back in Tools menu.
  1. Testing update
    1. Start Update Center Wizard.
    2. Try to download some module(s).
    • EXPECTED RESULT: There should be no problem with the Wizard functionality. The $USER_HOME/update/download/ must
       contain the downloaded .nbm file(s) 
 


Test suite: Update from local .nbm files

Purpose: Local modules selection, copying and install test.
Setup: Run IDE with clean userdir, start Update Center Wizard, select second radiobutton (Install Manually Downloaded Modules (.nbm Files)).


  1. Add modules
    1. Press Next.
    2. Check buttons on the displaied 2nd panel of Update Center Wizard (Back - enabled, Next - disabled, Finish - disabled, Cancel - enabled, button Add... must be enabled, Remove - disabled).
    3. Press Add and select the modules through appeared Open dialog (use daily .nbm files from daily builded archive of modules).
    4. Check buttons on the Update Center Wizard panel (Back - enabled, Next - enabled, Finish - disabled, Cancel - enabled).
    5. Click some module(s), remove them and add them again.
    6. Press Next button.
    • EXPECTED RESULT: The select panel of the step 2 is visible now. All modules are on the right so move them to the left (by << button).
  1. Select modules
    1. Check buttons on the displayed 2nd panel of Update Center Wizard (Back - enabled, Next - disabled, Finish - disabled, Cancel - enabled).
    2. Select some module(s), press > and they will move to the right.
    3. Move them back by < button.
    4. Select some module that depends on another ones (not selected), press > and they will move to the right.
    5. Check that required module(s) appears in the selected list along with the chosen module(s).
    6. Remove modules other modules are dependent on - Dependent modules should be removed as well.
    7. Add all modules again (if the connection is slow then select only subset).
    8. Click some module and check the module description, size...
    9. Press More button to open module description in the web browser.
    10. Press Next button.
    • EXPECTED RESULT: Accept license will appear.
  1. Accept license
    1. Refuse license - you will be in the step 2 of the Update Center Wizard.
    2. Press Next and accept license.
    • EXPECTED RESULT: You will be moved to the third panel of the Update Center Wizard.
       The IDE starts immediately download the selected modules. 
       While the download is in progress the Next button is disabled. 
       Immediately after the finish of the download the phase of verification should start. 
       The Next button is enabled then. 
       The time of the download has to be short because modules are copied locally.  
 
  1. Modules storing
    1. Press Next to go to step 4 of the wizard.
    2. Check buttons on the Update Center Wizard panel (Back - enabled, Next - disabled, Finish - enabled, Cancel - enabled).
    3. Copy files from $USER_HOME/update/download/ to some local directory ($LOCAL_MODULES).
    4. Press Back.
    • EXPECTED RESULT: The wizard will display panel 2 and the modules that have already been downloaded must be signed by green icon.
  1. Certificate settings
    1. Press Next and Accept the license(s) to go to step 4 of the wizard again.
    2. Select some trusted module in the list of downloaded.
    3. View Certificate button will become enabled.
    4. Press View Certificate.
    • EXPECTED RESULT: Module Certificate dialog appears - contains buttons Do Not Always Accept, Close and Help.
       There should be contained these information:
       Distinguished Owner of the trusted module and the Issuer of the certificate,
       Signer's certificate serial number,
       Validity of the certificate (from - until),
       Certificate fingerprints - MD5 hash of the certificate.
 
  1. Signed modules
    1. Try the functionality of the Help and Close buttons.
    2. View Certificate again.
    3. Press Do Not Always Accept.
    4. Check the modules will be now Signed instead Trusted.
    5. View Certificate.
    • EXPECTED RESULT: The Certificate dialog contains buttons Accept, Always Accept and Reject instead of Do Not Always Accept.
  1. Install modules
    1. Press Always Accept to have modules trusted.
    2. Press Finish on Update Center Wizard.
    • EXPECTED RESULT: The .jar files extracted from .nbm modules stored in $USER_HOME/update/download should be created in the $USER_HOME/modules/. Moreover the $USER_HOME contains newly created xml file update_tracking.xml and into the $USER_HOME/update/ is added update.log file and the directory backup. While the IDE restarts the Updater splash screen appears first and then the modules are installing and IDE runs.



Test suite: Install .NBMs from All Files

Purpose: Installation of .NBM visible in All Files.
Setup: Run IDE with clean userdir.


  1. Install the .NBM from All Files tab
    1. Select any .NBM file in All Files tab and do double click on the node.
    • EXPECTED RESULT: The Update Center wizard will appear and the single module will be in the list on the right.
  1. Create Empty .NBM file
    1. Take some system tool and create the text file with .NBM suffix
    2. Select the .NBM file in All Files tab and do double click on the node.
    • EXPECTED RESULT: The Update Center wizard should appear first and then the Warning dialog 'Zip file ... is corrupted. ...' appears and it is modal. Close it and the Update Center wizard too.



Test suite: Automatic Update check on IDE startup

Purpose: Checking of new updates on startup of the IDE.
Setup: Run IDE with clean userdir.


  1. Change settings
    1. Go to menu Tools | Options.
    2. Select node IDE Configuration | System | Update Center.
    3. Set Check Period to Every Startup.
    4. Close the Settings dialog.
    5. Restart the IDE.
    • EXPECTED RESULT: After the IDE finishes start the dialog Automatic Update Check appears.
  1. Enable checkbox
    1. Set the checkbox in the dialog Enabled.
    2. Remember the status of the values in the dialog.
    3. Close the dialog.
    4. Start the Update Center Wizard and open Options.
    • EXPECTED RESULT: The remembered values must be the same as those of in Options and first panel of Update Center Wizard.



Test suite: Smoke test of AutoUpdate wizard

Purpose: Quickly test main functionality of Update Center wizard. Create a new autoupdate type, set up proxy, download modules, save module and install it. Really quick test of AU client functionality.
Setup: Run IDE with clean userdir.


  1. Smoke test
    1. Open Tools | Options. Go to IDE Configuration | System | AutoUpdate types
    2. Create new AutoUpdate type and name it test. Close Options.
    3. Open Tools | Setup Wizard. On third panel set Period of Automatic Update Check to /Every startup/ and check Show Dialog Before Automatic Update Check. Finish.
    4. Open Tools | Update Center.
    5. Check that Error message appears. To achive it you have to set up bad Proxy configuration.
    6. Correct the Proxy Configuration (not needed when you don't use proxy).
    7. Click Next on first panel. You should get to second panel - Select Modules to Install.
    8. Choose some modules for installation. Select the modules in Available Updates and New Modules and move them with > to Include in Install
    9. Move all modules back with << and repeat previous step.
    10. Modules for installation are choosed, click Next. Accept licence(s).
    11. Wait on modules download and verification and then press Next on third panel.
    12. Select a module on fourth panel and click Save Copy...
    13. Write non-existing folder name to File Name textfield. Click Save. Error message appears.
    14. Press Save Copy.. button again and select an existing folder. Save the copy of module.
    15. Play for a while with Include check box - check and uncheck some modules. Accept/Reject certificate etc.
    16. Select at least one module for Global installation.
    17. Press Finish button and choose Restart the IDE radiobutton then.
    • EXPECTED RESULT: IDE restarts and installs the modules. The Check fo New Updates dialog appears after restart. Check that the modules are really installed. Don't forget to check even those that are installed globally.



Generated: Thu Dec 14 15:18:28 CET 2006

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo