TFTCL10nMainMenuShortcutsTesting

NB 6.0 Shortcuts Testing Test Specification for 6.0

Author: Jeremie
Version: 1.1
Lastupdate: 2007/10/17
Introduction: This module contains shortcuts testing related test cases. Completing this module ensure that shortcuts localization of main menu is correct.
Comments: To report any issue found when performing this module, please fill a bug using IssueZilla.
To help you reporting an l10n issue you can just click use below link and fill missing issue information.
Report L10n Issue in IssueZilla

Contents

Test suite: Shortcuts Testing

Purpose: Verify Shortcuts Localization Functionnalities
Comments: Shortcuts/Mnemonics/Hotkeys are used to open tabs, open windows or perform specific action (e.g. Save) in fast and manner.

For instance, in NetBeans 6.0 ENGLISH version, you can simply combine "Alt" key and "F" to open the "File" pull-down menu.

Localization of these shortcuts is often an issue as translated shortcuts can conflict with other shortcuts. This is test suite tends to guide tester through all test main menu shortcuts.

Setup: This test case can be performed on any platforms. Install NetBeans 6.0 Multi Language. Only NetBeans Java SE (Base IDE + Java SE) is required to perform this test case.

  1. Verify Sortcuts Localization of Main Tabs
    • Setup: Start NB 6.0
    1. Start NetBeans 6.0 Multi Language
    2. The Main menu top bar contains pull-down menu title. One letter per title is underlined. Verify that a letter is underlined only ONCE in the whole main menu bar.
    3. Try combination of "Alt" + Underlined Letters, one by one.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Pull-down menu should be opened after pressing key combination
      3. Correct pull-down menu is opned
  2. Verify 'File' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. Click on main menu 'File'
    3. Verify that a letter is underlined only ONCE in the whole File pull-down menu.
    4. Try combination of "Alt" + Underlined Letters, one by one. (After trying each combination you need to repeat Step 2.)
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. A window should be opened after pressing key combination
      3. Correct window is opned
  3. Verify 'Edit' sub-menus shortcuts
    • Comments:

To proceed this test case:
Create any "File" ("File" -> "New File")
Enter any text in this new file
Select entered text

    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. (If not yet done) Create any "File" ("File" -> "New File"). Enter any text in this new file. Select entered text
    3. Click on main menu 'Edit'
    4. Verify that a letter is underlined only ONCE in the whole File pull-down menu.
    5. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2. Possibly you will need to re-select some text to enable some actions.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  1. Verify 'Naviagate' sub-menus shortcuts
    • Comments:

To proceed this test case:
Create any "File" ("File" -> "New File")
Enter any text in this new file
Leave text cursor active in this file

    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. (If not yet done) Create any "File" ("File" -> "New File"). Enter any text in this new file. Leave text cursor active in this file
    3. Click on main menu 'Navigate'
    4. Verify that a letter is underlined only ONCE in the whole File pull-down menu.
    5. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2. Possibly you will need to re-select some text to enable some actions.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  1. Verify 'Source' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. (If not yet done) Create any "File" ("File" -> "New File"). Enter any text in this new file. Leave text cursor active in this file
    3. Click on main menu 'Source'
    4. Verify that a letter is underlined only ONCE in the whole File pull-down menu.
    5. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2. Possibly you will need to re-select some text to enable some actions.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  2. Verify 'Refractor' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. (If not yet done). Create any "File" ("File" -> "New File"). Enter any text in this new file. Leave text cursor active in this file.
    3. Click on main menu 'Refractor'
    4. Verify that a letter is underlined only ONCE in the whole File pull-down menu.
    5. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2. Possibly you will need to re-select some text to enable some actions.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  3. Verify 'Build' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. (If not yet done) Create any "Project" ("File" -> "New Project"). Click on created project.
    3. Click on main menu 'Build'
    4. Verify that a letter is underlined only ONCE in the whole File pull-down menu. Even from the items that are not enabled
    5. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  4. Verify 'Run' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. (If not yet done) Create any "Java Project" ("File" -> "New Project" -> "Java" -> "Java Application"). Click on .java file of created project.
    3. Click on main menu 'Run'
    4. Verify that a letter is underlined only ONCE in the whole File pull-down menu. Even from the items that are not enabled.
    5. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  5. Verify 'Profile' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. Click on main menu 'Profile'
    3. Verify that a letter is underlined only ONCE in the whole File pull-down menu. Even from the items that are not enabled.
    4. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  6. Verify 'Tools' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. Click on main menu 'Tools'
    3. Verify that a letter is underlined only ONCE in the whole File pull-down menu. Even from the items that are not enabled
    4. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  7. Verify 'Window' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. Click on main menu 'Window'
    3. Verify that a letter is underlined only ONCE in the whole File pull-down menu. Even from the items that are not enabled
    4. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed
  8. Verify 'Help' sub-menus shortcuts
    • Setup: Start NB 6.0
    1. Start NB 6.0 Multi Language
    2. Click on main menu 'Help'
    3. Verify that a letter is underlined only ONCE in the whole File pull-down menu. Even from the items that are not enabled
    4. Try combination of "Alt" + Underlined Letters, one by one. After trying each combination you need to repeat Step 2.
    • EXPECTED RESULT:
      1. Only one instance of underlined letter exists
      2. Correct action is proceed

}}
}}

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo