TFTCJavaAppBasic

NB 6.0 Java Basics Test Specification for 6.0

Author: Magda
Version: 1.1
Lastupdate: 2007/11/08
Introduction: The module helps with a quick testing of IDE bases through the creation of a simple Java console application
Comments: To report any issue found when performing this module, please fill a bug using IssueZilla.
To help you reporting an l10n issue you can just click use below link and fill missing issue information.
Report L10n Issue in IssueZilla

Contents

Test suite: Java Quick Start

Purpose: Verify Basic Localization Functionnalities and IDE Behaviour
Setup:
This test case can be performed on any platforms.
The J2SE Development Kit (version 5.0 or compatible)
NetBeans IDE 6.0 ML

  1. Set Up the Project
    1. Start NetBeans 6.0 Multi Language
    2. Choose File > New Project
    3. In the displayed New Project wizard, expand Java category
    4. (For Java category) Go through all items in Projects window and check their names and descriptions
    5. Select Java Application in Projects window and click Next
    6. Check all strings in the Name nad Location page of the wizard
    7. In the Project Name field type 'HelloWorldApp' (write it in your language even using multi bytes characters)
    8. In the Create Main Class field, type 'helloworldapp.HelloWorldApp' (first string depends on project name)
    9. Leave the Set as Main Project checkbox selected and click Finish
    • EXPECTED RESULT:
      1. All menu items, you need to go through, are localized
      2. All strings in the displayed wizards are localized
      3. In the New Project wizard Java Projects and their descriptions are localized
      4. All localized strings makes sense in the context
      5. Multi byte characters are correctly displayed
      6. The project is created and opened in the IDE
  2. Work with the Source File
    1. Replace the line:
      // TODO code application logic here
      with the line:
      System.out.println("Hello World!");
      Type 'Hello World!' in your language
    2. Choose File > Save
    3. Choose Build > Build Main Project from IDE's main menu
    4. Check the Output window (Window > Output > Output)
    • EXPECTED RESULT:
      1. All menu items, you need to go through, are localized
      2. There is no error when building, the build output concludes with the statement BUILD SUCCESSFUL
  3. Run the Project
    1. Choose Run > Run Main Project from the IDE's menu bar
    2. Check the Output window
    • EXPECTED RESULT:
      1. All menu items, you need to go through, are localized
      2. There is no error when executing, 'Hello World!' in your language is corretly displayed in the Output


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo