SpanishTranslationTutorialesplugins

Inicio rápido de Plugins con NetBeans

Image:buscando_SpanishTranslationTutorialesplugins.jpg

===Ver También===
[http://platform.netbeans.org/tutorials/nbm-google.html NetBeans Plugin Quick Start]


[[{TableOfContentsTitle=TablaDeContenidos} | {TableOfContents title='Tabla de contenidos'}]]

Introducción

Este tutorial es una introducción rapida y simple para la creación de pluings con NetBeans, a traves de este tutorial se creara una nueva barra de herramientas para el IDE. Una vez que haya terminado con este tutorial, usted tendrá un conocimiento general de cómo crear, construir, instalar y complementos para NetBeans IDE.


Software Necesario

NetBeans IDE Versión 6.5
Java Developer Kit (JDK) Versión 6

File:netbeans-stamp65_SpanishTranslationTutorialesplugins.gif Se crea una barra de herramientas que permita realizar busquedas en Google Search. Usted escribe el texto a buscar y presiona Enter, esto abrira el navegador y buscara en google los resultados. Para crear esta barra de herramientas, se utiliza el API de NetBeans para ampliar el conjunto de funciones del IDE. Especificamente , crearas un action que sera invocado por un botón, en la barra de herramientas. Necesitas crear un contenedor Swing JPanel un JLabel y JTextField como componentes de la interfaz de usuario, finalmente sobreescribir el método getToolbarPresenter() para retornar el JPanel de modo que se muestre en la barra de herramientas en lugar del botón.

Configurar el Módulo del Proyecto

Cuando desarrolla un módulo, usted tiene que asegurarse de que la estructura de su proyecto está configurada correctamente. NetBeans IDE proporciona un asistente de Proyecto de Módulo que establece todos los ficheros básicos necesarios para un módulo.

1.Seleccione Archivo> Nuevo Proyecto (Ctrl + Shift + N). En categorías, seleccione Módulos de NetBeans. En Proyectos, seleccione Módulo. Haga clic en Siguiente. Image:newproject_SpanishTranslationTutorialesplugins.jpg 2. En el panel de Nombre y Ubicación, escriba GoogleToolbar en el campo nombre del proyecto. En la ubicación del proyecto seleccione un directorio de su computadora. Deje seleccionada la opción Standalone y seleccione la casilla Configurar como Proyecto Principal. Image:nombre_SpanishTranslationTutorialesplugins.jpg

3.En el panel Configuración Basica del Módulo, escriba org.avbravo.googletoolbar en Code Name Base.

4. Seleccione "Generate XML Layer". Deje los lugares tanto de la localización de paquetes y el layer de archivo XML a fin de que esten almacenados en un paquete con el mismo nombre org/avbravo/googletoolbar. Haga Click en el botón Finish

Image:basica2_SpanishTranslationTutorialesplugins.jpg

El IDE creaa el proyecto GoogleToolbar . El proyecto contiene contiene todas las fuentes y metadatos, como un proyecto Ant con su script build. El proyecto es abierto en el IDE. Puede ver la estructura lógica en la ventana de Projectos (Ctrl+1) y la estructura de archivos en la ventana Archivos(Ctrl+2).

Image:projectwindow_SpanishTranslationTutorialesplugins.jpg

Codificando el Módulo

Para crear un módulo es necesario seguir los siguientes pasos:

  • Crear Action
  • Crear JPanel
  • Resolver Errores
  • Sobreescribir getToolbarPresenter()


Crear el Action

1.Click derecho en el nodo proyecto y escoja New > Action. Image:newaction_SpanishTranslationTutorialesplugins.jpg Presione el botón Siguiente.

2.En el panel Action Type deje los valores predeteminados , el IDE creara una acción en la subclase ActionListener.

Image:actiontype_SpanishTranslationTutorialesplugins.jpg

3. En el panel Registro GUI, seleccione File desde la lista desplegable de categoría. La lista desplegable de categoría controla donde la acción es mostrada en las teclas de atajo en el editor del IDE. Siguiente, quite la selección "Global Menu Item" y seleccione Global Toolbar Button. En la lista desplegable Toolbar, selecccione Archivo, en la lista desplegable Position seleccione una posición, como se muestra en la figura: Image:nweaction2_SpanishTranslationTutorialesplugins.jpg Click en el botón Siguiente

4. En el panel Nombre y Ubicación, escriba GoogleAction como nombre de Clase y Google Action como nombre a Desplegar. Seleccione un icono con un tamaño de 16x16 pixels (es opcional), en lugar de ello , le mostrará el formulario de JPanel que cree en la siguiente sección. Sin embargo, el nuevo asistente de Acción requiere que usted especifique un icono. Por lo tanto, el icono puede ser de cualquier dimensión, ya que no se utilizan. Haga clic en Finalizar. Nota: GoogleAction.java es agregado al paquete org.avbravo.googletoolbar en el proyecto. Image:googletoolbar_SpanishTranslationTutorialesplugins.jpg

Crear el JPanel

1. Click derecho en el nodo proyecto y seleccionar New New > Other. Image:other_SpanishTranslationTutorialesplugins.jpg En Categorías, seleccionar Swing GUI Forms. En Proyectos, seleccionar JPanel Form. Image:tipos_SpanishTranslationTutorialesplugins.jpg Click Next.

2. En el panel de Nombre y Ubicación , escriba GooglePanel como el nombre de clase y seleccione el paquete desde la lista desplegable. Image:panel_SpanishTranslationTutorialesplugins.jpg

Haga  Click en el botón Terminar.
GooglePanel.java es agregado al paquete y es abierto en la vista de diseño en el editor de fuentes.

Image:form_SpanishTranslationTutorialesplugins.jpg

3.Coloque el cursor en en jPanel y ajuste los tamaños del jPanel: Image:tamano_SpanishTranslationTutorialesplugins.jpg.

4. Inserte un JTextField y un JLabel Image:jtextfield_SpanishTranslationTutorialesplugins.jpg 5. Asegurese que el Inspector de Propiedades este abierto (Window > Navigating > Inspector), entonces haga click derecho en JTextField y seleccione Events > Key > keyTyped. Esto genera el método jTextField1KeyTyped() en GooglePanel.java , que seran mostrados en el editor: Image:key_SpanishTranslationTutorialesplugins.jpg

copiar el código

private void TextField1KeyTyped(java.awt.event.KeyEvent evt) {
    int i = evt.getKeyChar();
    if (i==10){//The ENTER KEY
        // we display the google url.
        try{
            URLDisplayer.getDefault().showURL
                    (new URL("http://www.google.com/search?hl=en&q="+jTextField1.getText()+"&btnG=Google+Search"));
        } catch (Exception eee){
            return;//nothing much to do
        }
    }
}

Resolviendo Errores

El IDE envia el mensaje de error en la línea

URLDisplayer.getDefault().showURL

indicando que no encuentra el paquete Image:error_SpanishTranslationTutorialesplugins.jpg

Para solucionar esto, debe seguir los siguientes pasos: 1. Desde el menú Archivo ->Project Properties (GoogleToolbar) y escoja propiedades. En el diálogo Propiedades del Proyecto, seleccione Libraries en la categoría. Image:libraries_SpanishTranslationTutorialesplugins.jpg Entonces en Dependencias de Módulos hacer click en el botón Agregar.

Se muestra el diálogo Add Module Dependency 2. En la caja de texto del filtro, escriba URLDisplayer y en el listado de seleccioón retornar el API "UI Utilities" Image:api_SpanishTranslationTutorialesplugins.jpg Haga click en OK.

3. Ahora vamos el editor, y damos click derecho y seleccionamos Fix Imports (Alt+Shift+F). Se muesta un diálogo listando las sugerencias:

Se importan estos paquetes

import java.net.URL;
import org.openide.awt.HtmlBrowser.URLDisplayer;


Sobreescribir getToolbarPresenter()

El JPanel que se creo, es el componente actual que despliega la barra de herramientas Google, se necesita sobreescribir el método getToolbarPresenter() en la clase action . En GoogleAction.java.
do the following:

1.Abra GoogleAction.java este contiene:


package org.avbravo.googletoolbar;

import java.awt.event.ActionEvent;
import java.awt.event.ActionListener;

public final class GoogleAction implements ActionListener {

    public void actionPerformed(ActionEvent e) {
        // TODO implement action body
    }
}

2. Cambie la firma de manera que la clase extienda de CallableSystemAction extends, en lugar de ActionListener . Añada las sentencias import mostradas acontinuación y no retorne nada para cada método:

package org.avbravo.googletoolbar;

import org.openide.util.HelpCtx;
import org.openide.util.actions.CallableSystemAction;

public final class GoogleAction extends CallableSystemAction {

    @Override
    public void performAction() {
        
    }

    @Override
    public String getName() {
        return "";
    }

    @Override
    public HelpCtx getHelpCtx() {
        return null;
    }
    
}

3. Abra layer.xml, y puede ver lo siguiente:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE filesystem PUBLIC "-//NetBeans//DTD Filesystem 1.2//EN" "http://www.netbeans.org/dtds/filesystem-1_2.dtd">
<filesystem>
    <folder name="Actions">
        <folder name="File">
            <file name="org-avbravo-googletoolbar-GoogleAction.instance">
                <attr name="SystemFileSystem.localizingBundle" stringvalue="org.avbravo.googletoolbar.Bundle"/>
                <attr name="delegate" newvalue="org.avbravo.googletoolbar.GoogleAction"/>
                <attr name="displayName" bundlevalue="org.avbravo.googletoolbar.Bundle#CTL_GoogleAction"/>
                <attr name="iconBase" stringvalue="org/avbravo/googletoolbar/Google-16x16.png"/>
                <attr name="instanceCreate" methodvalue="org.openide.awt.Actions.alwaysEnabled"/>
                <attr name="noIconInMenu" stringvalue="false"/>
            </file>
        </folder>
    </folder>
    <folder name="Toolbars">
        <folder name="File">
            <file name="org-avbravo-googletoolbar-GoogleAction.shadow">
                <attr name="originalFile" stringvalue="Actions/File/org-avbravo-googletoolbar-GoogleAction.instance"/>
                <attr name="position" intvalue="150"/>
            </file>
        </folder>
    </folder>
</filesystem>

El contenido fue creado por el asistente New Action. Elimine las siguientes líneas del archivo layer.xml, ya que no son necesarias en este tutorial: Las líneas que definenen el atributo "delegate" attribute, el atributo "displayName" , el atributo "iconBase" , y el atributo "instanceCreate".

Quedaria de esta manera:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE filesystem PUBLIC "-//NetBeans//DTD Filesystem 1.2//EN" "http://www.netbeans.org/dtds/filesystem-1_2.dtd">
<filesystem>
    <folder name="Actions">
        <folder name="File">
            <file name="org-avbravo-googletoolbar-GoogleAction.instance">
                <attr name="SystemFileSystem.localizingBundle" stringvalue="org.avbravo.googletoolbar.Bundle"/>
              
                <attr name="noIconInMenu" stringvalue="false"/>
            </file>
        </folder>
    </folder>
    <folder name="Toolbars">
        <folder name="File">
            <file name="org-avbravo-googletoolbar-GoogleAction.shadow">
                <attr name="originalFile" stringvalue="Actions/File/org-avbravo-googletoolbar-GoogleAction.instance"/>
                <attr name="position" intvalue="150"/>
            </file>
        </folder>
    </folder>
</filesystem>

4. Por debajo de la declaración de la clase GoogleAction.java, declarar y establecer las siguientes variables:

GooglePanel retValue = new GooglePanel();

5.Defina el método getToolbarPresenter() que retorne la variable retValue :

@Override
public java.awt.Component getToolbarPresenter() {
    return retValue;
}


Compilando, Instalando y Usando el Módulo

NetBeans IDE utiliza script de Ant para compilar e instalar tu módulo en el IDE. El script constructor fue creado cuando se creo el proyecto de Módulo. Ahora el módulo esta listo para ser compilado y agregado al IDE, puede usar el soporte de Ant en el IDE para:

1. En la ventana Proyectos, de click derecho en el nodo del proyecto GoogleToolbar y elija Install/Reload in Target Platform. El módulo es construido e instalado en una nueva instancia del IDE. De manera predeterminada la plataforma destino es la versión más reciente del IDE en que estas trabajando. La plataforma destino se abre para que usted pueda abrir y probar el módulo.

2.Cuando es exitosa la instalación, el módulo agrega un nuevo botón en la barra de herramientas del IDE. Image:instalar_SpanishTranslationTutorialesplugins.jpg

Nota: El botón de la barra de herramientas no despliega el icono, en su lugar se muestra el panel que se creo: File:Barra.jpg

3. Escriba el texto a buscar y presione Enter

Image:buscando_SpanishTranslationTutorialesplugins.jpg


Compartiendo el Módulo

Ahora podemos compartir nuestro módulo En la ventana de proyectos damos click derecho en el nodo GoogleToolbar y elejimos Create NBM.

Image:crearnbm_SpanishTranslationTutorialesplugins.jpg El nuevo archivo NBM es creado y este puede ser visto en la ventana archivo (Ctrl+2):

Image:nbm_SpanishTranslationTutorialesplugins.jpg


Regresar

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo