STS 70 WindowSystem

Window System Sanity Test Specification for NetBeans

Author: Petr Chytil & Lukáš Hasík
Edited and updated by: Tomáš Tököly
Version: 7.0
Last update: 19.4.2011
UI specifications:

Contents


Test suite: Window

Purpose: The UI is specified in UI specification.
Setup: Start IDE with clear userdir.

  1. Open opened but not activated window
    1. Open a window (e.g. Files).
    2. Open another window (e.g. Services - it's opened at the same position as Files as new tab).
    3. Push from main menu Window | Files.
    • EXPECTED RESULT: Both Windows are still opened, Files View is active (has focus), covers Services Window and there is only one instance of Files View in the IDE.
  2. Persistence of Window System - Files view - close
    1. Open Files view and expand some nodes.
    2. Remember selected node, expanded tree and scrollbar positions.
    3. Close Files (by pushing on close button from header of Files view).
    4. Open Files (by pushing main menu Window | Files).
    • EXPECTED RESULT: Files View is opened at the same position as it has been before close. The same node is selected and scrollbars have the same positions as before close.
  3. Maximize window - by doubleclick on header
    1. Open Services window from main menu (push main menu Window | Services), if not already opened.
    2. Doubleclick on header of Services Window.
    • EXPECTED RESULT: Services Window (whole window consists of Files and Services tab) is maximized and Services Window is selected and activated. Contextual menu and main menu Window contains Restore Window item instead of Maximize Window.
  4. Restore window - by doubleclick on header
    1. Open Services window from main menu (push Window | Services), if not already opened.
    2. Maximize Services Window (by shortcut).
    3. Doubleclick on header of Services Window.
    • EXPECTED RESULT: Services Window(whole window consists of Files and Services tab) is restored and Services Window is selected and activated. Contextual menu and main menu Window contains Maximize Window item instead of Restore Window.


Test suite: Window System Effects

Purpose: Check the functionality of the effect available in window system. There are effects for drag and drop of windows, effect for floating windows and snapping of floating windows. The effect's setup can be changed in Options.
Setup: Start IDE with clear userdir.
Comment: All the testcase that don't state anything else are using the default level of effects.

  1. Default Level of WS Effects
    1. Open main menu Tools | Options.
    2. Choose the Miscellaneous > Windows.
    • EXPECTED RESULT: All checkboxes in the panel on the top are by default switched on. In Solaris OS is Drag window image by default turned off, other settings are turned on.
  2. D'n'd a Window/Tab/Window group
    1. Drag Projects tab.
    2. Take it to the restricted (e.g. document) area.
    3. Drop it here.
    • Comment: Transparency works on Unix OS only when composite window manager is in use. That means Compiz, Beryl, visual effects is turned on in Ubuntu etc. Otherwise are dragged windows opaque.
    • EXPECTED RESULT: The dragged window is showing its content in "ghost image" when you are dragging it. The ghost image is half transparent. The ghost image follows the cursor when you are dragging the window to new area. When you take it to the restricted (document) area, the dragged ghost image is darken to visually notify the user that drop is not allowed. The dropped ghost image moves back to origin location with a visual effect (flying).
  3. Undock a window
    1. Select Undock window action from Files window tab contextual menu to create a floating window.
    2. Give focus to editor window.
    • EXPECTED RESULT: The Files floating window becomes transparent in a few seconds.
  4. Undock a document window
    1. Open some file in editor.
    2. Select Undock window action from editor window tab contextual menu to create a floating window.
    3. Give focus to IDE main window.
    • EXPECTED RESULT: The editor floating window remains opaque and does not become transparent.
  5. Change D'n'D effects settings
    1. Turn off transparent drag window image in Options > Miscellaneous > Windows.
    2. D'n'D Files window and check if it stays opaque during D'n'D.
    3. Turn off drag window image in Options > Miscellaneous > Windows.
    4. D'n'D Files window and check, that there is no image with window content during D'n'D.
    • EXPECTED RESULT: The effects change correctly.
  6. Change Snapping settings
    1. Turn off snap to screen edges in Options > Miscellaneous > Windows.
    2. Undock Favorites window and try to snap it to edges of the screen.
    3. Turn off snapping of floating windows in Options > Miscellaneous > Windows.
    4. Undock Favorites window and Projects window and check if snapping works between them.
    • Comment: In Unix OS (Linux) you must turn off snapping of window directly in OS (e.g. in CompizConfig Settings Manager), otherwise the OS settings overrides the settings of IDE.
    • EXPECTED RESULT: The effects change correctly.
  7. Change Floating window settings
    1. Turn off transparent floating window in Options > Miscellaneous > Windows.
    • EXPECTED RESULT: The effects change correctly - floating windows stay opaque.


Test suite: Document Window

Purpose:
Setup: Start IDE with clear userdir.

  1. Open, Modify, Save and Close the Document Window - java file
    1. Open some 2 java files (e.g. HelloWorld.java and HelloWorld_2.java).
    2. Modify file HelloWord in editor.
    3. From contextual menu of Window push Save Document.
    4. Push close button on the tab HelloWorld.java.
    • EXPECTED RESULT: Source Editor is opened, it contains Source Editor tab HelloWorld.java, this tab is selected and focus is inside editor. After modifying the title of selected Document Window contains "HelloWorld.java" and its font is bold (modified status). After saving, the HelloWorld (and only HelloWorld) document is saved and tab font back to normal. And after closing the HelloWorld (and only HelloWorld) Document Window is closed.
  2. Close All Documents - by main menu
    1. Open some 2 java files (e.g. HelloWorld_1.java, HelloWorld_2.java).
    2. From main menu push Window | Close All Windows.
    • EXPECTED RESULT: All (both HelloWorld_1 and HelloWorld_2) Document Windows are closed.
  3. Close All Documents - split - by contextual menu
    1. Open some 2 java files (e.g. HelloWorld_1.java, HelloWorld_2.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From contextual menu of HelloWorld_1 Document Window push Close All Windows.
    • EXPECTED RESULT: Only HelloWorld_1 Document Window is closed.
  4. Close All Documents - split - by main menu
    1. Open some 2 java files (e.g. HelloWorld_1.java, HelloWorld_2.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From main menu push Window | Close All Windows.
    • EXPECTED RESULT: All Document Windows are closed.
  5. Close Other Documents - by contextual menu
    1. Open some 3 java files (e.g. HelloWorld_1.java, HelloWorld_2.java, HelloWorld_3.java).
    2. From contextual menu of HelloWorld_2.java push Close Other Windows.
    • EXPECTED RESULT: HelloWorld_1.java and HelloWorld_3.java Document Windows are closed, only HelloWorld_2.java stays opened.
  6. Close Other Documents - split - by contextual menu
    1. Open 3 java files (e.g. HelloWorld_1.java, HelloWorld_2.java, HelloWorld_3.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From contextual menu of HelloWorld_2.java push Close Other Windows.
    • EXPECTED RESULT: HelloWorld_3.java Document Window is closed, HelloWorld_2.java and HelloWorld_1.java stay opened.
  7. Close Other Documents - split - by main menu
    1. Open 3 java files (e.g. HelloWorld_1.java, HelloWorld_2.java, HelloWorld_3.java).
    2. D'n'D HelloWorld_1 window to the bottom of Document Area.
    3. From main menu push Close Other Windows.
    • EXPECTED RESULT: HelloWorld_2.java and HelloWorld_3.java Document Windows are closed only HelloWorld_1.java stays opened.
  8. Clone Window
    1. Try to clone this windows by push main menu Window | Clone Document (the proper window must be selected and activated):
    2. Some java file (e.g. HelloWorld.java).
    3. Welcome Screen (you can open it by main menu Help | Welcome Screen).
    4. Files window (you can open it by main menu Window | Files).
    • EXPECTED RESULT: HelloWorld as original and HelloWorld as clone (new tab in Editor Area) are opened. For other two cases (Welcome Screen and Files view) is main menu Window
  9. Persistence of maximized Document Window - restart
    1. Open java file (e.g. HelloWorld.java).
    2. Doubleclick on header of Services Window.
    3. Restart IDE.
    • EXPECTED RESULT: Editor Window (whole window consists of all opened document windows) is maximized and HelloWorld source editor tab is selected and activated. Contextual menu contains Restore Window item instead of Maximize Window. Main menu Window contains Restore Window item instead of Maximize Window.
  10. Restore Document Window - by main menu
    1. Open java file (e.g. HelloWorld.java).
    2. Maximize Services Window (by main menu).
    3. From main menu push Window | Restore Window.
    • EXPECTED RESULT: Editor Window (whole window consists of all opened document windows) is maximized and HelloWorld source editor tab is selected and activated. Contextual menu contains Restore Window item instead of Maximize Window. Main menu Window contains Restore Window item instead of Maximize Window.
  11. Select next document tab and select previous document tab actions
    1. Open three or more files.
    2. Give focus to editor.
    3. Press CTRL+PGDOWN to select next document tab.
    4. Press CTRL+PGUP to select previous document tab.
    • EXPECTED RESULT: Both actions work as expected - next/previous document tab is selected when shortcut is pressed.
  12. List of actually opened documents
    1. Open three or more files.
    2. Give focus to editor.
    3. Press and hold CTRL and press TAB few times while still holding CTRL.
    4. Press and hold CTRL+SHIFT and press TAB few times while still holding CTRL+SHIFT.
    • EXPECTED RESULT: List of actually opened documents is shown in the middle of the screen. CTRL+TAB traverses downwards the list, CTRL+SHIFT+TAB traverses upwards. Items in the list are not sorted alphabetically, but actually active document is always first, previously active document is second etc.


Test suite: Window Area

Purpose:
Setup: Start IDE with clear userdir.

  1. Window area contains only Window type of windows (no Document Window)
    1. Open few windows from Window menu.
    2. Open some file.
    3. Try to D'n'D Document Window to all possible positions in Window Area.
    • EXPECTED RESULT: All Windows are open in Window Area (no one opened in Document Area). Document Window is opened in Document Area (no Window Area). It's impossible drop Document Window to Window Area.
  2. Attach Window - to the Window - left
    1. Open Files View from Window menu.
    2. Open Properties from Window menu.
    3. Drag Properties Window and Drop it inside to the left side of Files View.
    • EXPECTED RESULT: Properties Window is moved to the new location. There is Files View on the right side and Properties Window on the left side of the same cell, cell is divided by splitter.
  3. Attach Window - to the Window - as a new tab
    1. Open Files View from Window menu.
    2. Open Properties from Window menu.
    3. Drag Properties Window and Drop it to the Files View as a new tab.
    • EXPECTED RESULT: Properties Window is moved to the new location. There is Files View - overlaped by Properties Window (selected) as a new tab.
  4. Attach Window - to the Window Area - top
    1. Open Files View from Window menu.
    2. Open Services from Window menu.
    3. Drag Services Window and Drop it to the top of Window Area.
    • EXPECTED RESULT: Services Window is moved to the new location. There is Files View on the left and Services Window on the top of Window Area, between windows is splitter.
  5. Attach Window - to the Document Area - right
    1. Open Files View from Window menu.
    2. Open some file.
    3. Drag Files View and Drop it to the right side of Document Area.
    • EXPECTED RESULT: Files View is opened on the right side and source editor on the left side, between windows are splitters.
  6. More windows in a split cell - change selection
    1. Open Files from Window menu.
    2. Open Projects from Window menu.
    3. Open Services from Window menu.
    4. Select (click on a header of) Projects Window.
    • EXPECTED RESULT: All three windows are shown at the one split cell, Projects Window is selected.
  7. More windows in a split cell - close first window
    1. Open Files from Window menu.
    2. Open Projects from Window menu.
    3. Open Services from Window menu.
    4. Select (click on a header of) Files View.
    • EXPECTED RESULT: Files View is closed but Services and Projects Windows stay opened and Projects Window is selected.
  8. Maximized Split Cell
    1. Open Files View from Window menu.
    2. Open some java file.
    3. Open Projects from Window menu.
    4. Doubleclick on a selected header (Projects Window).
    • EXPECTED RESULT: Split cell with Files View and Projects windows is maximized - it means just Window Area is visible and Projects Window is selected.
  9. Maximized Split Cell - restore
    1. Open Files View from Window menu.
    2. Open some java file.
    3. Open Projects from Window menu.
    4. Doubleclick on a selected header (Projects Window).
    5. Doubleclick on a selected header (Projects Window) again.
    • EXPECTED RESULT: Split cell with Files View and Projects windows isn't maximized, Document Window with opened java file is visible and Projects Window is selected.
  10. Maximized Split Cell - Switch to document
    1. Open Files View from Window menu.
    2. Open some java file.
    3. Open Projects from Window menu.
    4. Doubleclick on a selected header (Projects Window).
    5. Push from main menu Window | Documents... | Switch to Document.
    • EXPECTED RESULT: Split cell with Files View and Projects windows isn't maximized, Document Window with opened java file is visible and selected.
  11. Vertical Split Cell
    1. Open Files View from Window menu.
    2. Open Projects from Window menu.
    3. Drag Files View and drop to the left side of Projects Window.
    • EXPECTED RESULT: Chain of vertical split cells is visible.
  12. Vertical Split Cell - resize
    1. Open Files View from Window menu.
    2. Open Projects from Window menu.
    3. Drag Files View and drop to the left side of Projects Window.
    4. Move splitter between Files View and Document Area.
    • EXPECTED RESULT: Chain of vertical split cells is visible. Only Files View is resized Projects Window holds the same size.
  13. Vertical Split Cell - persistence after closing
    1. Open Files View from Window menu.
    2. Open Projects from Window menu.
    3. Drag Files View and drop to the left side of Projects Window.
    4. Move splitter between Files View and Document Area.
    5. Close Files View.
    6. Open Files View from Window menu.
    • EXPECTED RESULT: Files View is opened on the left side of Projects Window and its size is the same as before closing.
  14. Horizontal Split Cell
    1. Open Files View from Window menu.
    2. Open Projects from Window menu.
    3. Drag Files View and drop to the top side of Projects Window.
    • EXPECTED RESULT: Chain of horizontal split cells is visible.
  15. Select next window tab and select previous window tab actions
    1. Open three or more windows in one split cells (one window content is visible, others are present only as tabs).
    2. Press CTRL+PGDOWN to select next window tab in split cell.
    3. Press CTRL+PGUP to select previous window tab in split cell.
    • EXPECTED RESULT: Both actions work as expected - next/previous window tab in split cell is selected when shortcut is pressed.


Test suite: Window Groups

Purpose:
Setup: Start IDE with clear userdir.

  1. GUI editing window group
    1. Open some form file - HelloWorld.java
    • EXPECTED RESULT: One tab is added to Editor (Designer). Designer has own toolbars called (selection mode, connection mode and preview design). Design is selected by default. Form Editor consists of 3 Components (Form Designer Palette, and Properties. Properties contains 4 buttons (Properties, Binding, Event, Code) Check titles and position of views.
  2. GUI editing window group - closing group
    1. Open some form file - HelloWorld.java.
    2. Close opened form file.
    • EXPECTED RESULT: Palette, Properties, Source editor, History and Form designer are closed.
  3. GUI editing window group - change layout - persistence
    1. Open some form file - HelloWorld.java.
    2. Drag Properties Window to the Files View as a new tab.
    3. Close opened form file.
    4. Open the another form file.
    • EXPECTED RESULT: Two tabs are added to Editor, first is source code and second form editor. Form Editor consists of Component Palette, Component Inspector and Form Designer. Properties Window is opened on its new position as new tab in Files View. Check titles and position of views.
  4. Debugging window group
    1. Open some java file - HelloWorld.java.
    2. Run debugger to cursor on line with System.out.println("Hello World").
    • EXPECTED RESULT: Debugging window group is opened. It consists of Output, Local Variables, Watches and Call Stack. If debugging is finished just Output window stays opened.
  5. Debugging window group - change layout - persistence
    1. Open some java file - HelloWorld.java
    2. Run debugger to cursor on line with System.out.println("Hello World")
    3. Drag Call Stack Window to the right side of Document Area.
    4. Drag Watches Window to the same cell as Call Stack Window as a new tab.
    5. Drag Local Variables Window to the Files View as a new tab.
    6. Push from main menu Run | Finish Debugger Session.
    7. Run debugger to cursor on line with System.out.println("Hello World")
    • EXPECTED RESULT: Debugging window group is opened. All windows are opened at the same positions as they were before finish debugging.


Test suite: Documents dialog

Purpose:
Setup: Start IDE with clear userdir.

  1. Documents dialog - check layout
    1. Open some file.
    2. Push main menu Window | Documents... .
    • EXPECTED RESULT: Document non-modal dialogs is opened as it's specified in UI specification. Check components and mnemonics.
  2. Documents dialog - list of documents
    1. Open files in defined order : Class_A.java Class_C.java Class_B.java.
    2. Modify file Class_B.java
    3. Open Documents window.
    • EXPECTED RESULT: Every item is the list contains icon, and name of document window as displayed in document window headers, it means also with asterisk in case a document has been modified. The list is alphabetically ordered and allows a multi-selection.
  3. Documents dialog - search for popup
    1. Open files in defined order : Class_A.java Class_C.java Class_B.java.
    2. Open Documents window.
    3. Focus list of documents and write "class_A".
    • EXPECTED RESULT: "Search for" popup is displayed showing typed characters and list moves selection to the matching item in the list. If non of the items matches typed characters, then the selection stays at the last item. The backspace key allows the user to delete the last character. The "Search for" popup is closed if the user hits Enter, Esc, or the arrow keys. The search is keyboard insensitive.
  4. Documents dialog - switch to document
    1. Open files in defined order: Class_A.java Class_C.java Class_B.java. (Class_B document is active and has focus)
    2. Open Documents window.
    3. Select item Class_A from the list of documents.
    4. Push button Switch to Document.
    • EXPECTED RESULT: "Class_A" document window is activated and Document dialog is still opened.
  5. Documents dialog - close document
    1. Open files in defined order : Class_A.java Class_C.java Class_B.java.
    2. Open Documents window.
    3. Select item Class_A from the list of documents.
    4. Push button Close Document(s).
    • EXPECTED RESULT: Class_A document window is closed and item is removed from the list.
  6. Documents dialog - save document
    1. Open files in defined order : Class_A.java Class_C.java Class_B.java.
    2. Modify file Class_A.java
    3. Open Documents window.
    4. Select item Class_A from the list of documents
    5. Push button Save Document(s)
    • EXPECTED RESULT: Class_A is saved and document window is still opened and presents in the list of opened documents.
  7. Documents dialog - close modified document
    1. Open files in defined order : Class_C.java Class_B.java Class_A.java.
    2. Modify file Class_B.
    3. Open Documents window.
    4. Select item Class_B from the list of documents
    5. Push button Close Document(s)
    • EXPECTED RESULT: Question dialog (Save dialog) rises, if push Save - document is saved, document window is closed and item removed from the list of opened documents. If push Discard - document is closed but not saved, item is removed from the list of opened documents. If push Cancel - document isn't saved neither closed and order of documents in the list of opened documents is unchanged.
  8. Documents dialog - close two modified documents
    1. Open files in defined order : Class_C.java Class_B.java Class_A.java.
    2. Modify file Class_B.
    3. Modify file Class_C.
    4. Open Documents window.
    5. Select item Class_B and Class_C from the list of documents
    6. Push button Close Document(s)
    • EXPECTED RESULT: Question dialog (Save dialog) rises, if push Save - document is saved, document window is closed and item removed from the list of opened documents. If push Discard - document is closed but not saved, item is removed from the list of opened documents. If push Cancel - document isn't saved neither closed and order of documents in the list of opened documents is unchanged.
  9. Documents quick list - many documents
    1. Open many files (10-20).
    • EXPECTED RESULT: Document Window contains a line tabs in the opening order and on the upper right corner (or in the line of tabs) are left,bottom(quick list) and right scroll button. If you click by mouse on the quick list button - quick list popup menu with the list of all opened document windows rises. The items in the popup are ordered alphabetically. Each item in the popup displays an icon and name of document window. If there is not enough space in the main window to fit all the items in one column without a need to scroll then the list is organized into multiple columns.
  10. Documents quick list - switch to the last one
    1. Open ten files.
    2. Select first document tab.
    3. Push Quick List button.
    4. From the quick list menu select last menu item.
    • EXPECTED RESULT: Selected and activated document window is the last one opened. Document Window contains a line of tabs (3nd, .... , 10th), left tab is shown, left scroll button is enabled. The quick list contains all of opened document windows.
  11. Documents quick list - switch to the first one
    1. Open ten files.
    2. Select last document tab.
    3. Push Quick List button.
    4. From the quick list menu select first menu item.
    • EXPECTED RESULT: Selected and activated document window is the first one opened. Document Window contains a line of tabs 1st, .... , 8th), right tab is shown, right scroll button is enabled. The quick list contains all of opened document windows.


Test suite: Sliding

Purpose:
Setup: Start IDE with clear userdir

  1. Hide window to the left
    1. Click on Minimize Window button in the Files View title bar.
    • EXPECTED RESULT: Files View disappears from the Docked mode, the left edge bar is shown with one Files toggle button.
  2. Hide window docked in the top
    1. D'n'D Files View to the top of the Document area.
    2. Click on Minimize Window button in the Files View title bar.
    • EXPECTED RESULT: Files View disappears from the Docked mode, the left edge bar is shown with one Files toggle button.
  3. Hide window to the left - edge bar exists
    1. Hide Projects View.
    2. Click on Minimize Window button in the Files View title bar.
    • EXPECTED RESULT: Files View disappears from the Docked mode, the left edge bar contains two buttons first is Projects button and second one is Files toggle button.
  4. Slide window - move mouse over button
    1. Hide Projects View.
    2. Move mouse over Projects toggle button on the left edge bar.
    • EXPECTED RESULT: Minimized Projects window slides from side but will not obtain a focus.
  5. Slide window - click on button
    1. Hide Projects View.
    2. Click by mouse on Projects toggle button on the left edge bar.
    • EXPECTED RESULT: Minimized Projects window slides from side and will obtain a focus.
  6. Dock window - click on icon
    1. Hide Projects View.
    2. Move mouse over Projects toggle button on the left edge bar.
    3. Push Dock button on the title bar of slided window.
    • EXPECTED RESULT: Projects View is docked back to the default position, size of the window is the same was before hiding.
  7. Dock window - by contextual menu over title bar
    1. Hide Projects View.
    2. Move mouse over Projects toggle button on the left edge bar.
    3. Uncheck Minimize Window from contextual menu over title bar of slided window.
    • EXPECTED RESULT: Projects View is docked back to the default position, size of the window is the same was before hiding.
  8. Minimize window from mouse over sliding mode
    1. Hide Projects View.
    2. Move mouse over Projects toggle button on the left edge bar.
    3. Wait for Projects window slides from side and move mouse out from that window or button.
    • EXPECTED RESULT: Projects View hides once again into Minimized state.
  9. Minimize window from mouse click sliding mode
    1. Hide Projects View.
    2. Click by mouse on Projects toggle button on the left edge bar.
    3. Wait for Projects window slides from side and focus any other part of IDE or press ECS.
    • EXPECTED RESULT: Projects View hides once again into Minimized state.
  10. Minimize window from sliding mode by shortcut
    1. Hide Projects View.
    2. Press shortcut for opening Projects View (Ctrl+1).
    3. Wait for Projects window slides from side and focus any other part of IDE or press ECS.
    • EXPECTED RESULT: Projects View hides once again into Minimized state.
  11. Check persistence - hide, close, open
    1. Hide Projects View.
    2. Push Close Window from contextual menu over Projects toggle button on the left edge bar.
    3. Open Project View from main menu.
    • EXPECTED RESULT: Projects View is opened as slided window and will obtain a focus.
  12. Check persistence - hide, close, restart, open
    1. Hide Projects View.
    2. Push Close Window from contextual menu over Projects toggle button on the left edge bar.
    3. Restart IDE.
    4. Open Project View from main menu.
    • EXPECTED RESULT: Projects View is opened as slided window and will obtain a focus.
  13. Check persistence - hide, restart, open
    1. Hide Projects View.
    2. Restart IDE.
    3. Projects View is minimized, open Project View from main menu.
    • EXPECTED RESULT: Projects View is opened as slided window and will obtain a focus.
  14. Close window in sliding mode
    1. Hide Projects View.
    2. Move mouse over Projects toggle button on the left edge bar.
    3. Push Close Window from contextual menu over title bar of slided window.
    • EXPECTED RESULT: Projects View is closed.
  15. Close window in Minimized mode
    1. Hide Projects View.
    2. Push Close Window from contextual menu over Projects toggle button on the left edge bar.
    • EXPECTED RESULT: Projects View is closed.
  16. Transparency of sliding window
    1. Hide Projects View.
    2. Click by mouse on Projects toggle button on the left edge bar.
    3. Wait for Projects window slides from side.
    4. Right click the title bar and choose Transparent Window
    • EXPECTED RESULT: Projects View is transparent. You can see through the window the windows that are under it.
  17. Transparency of sliding window isn't persistent
    1. Hide Projects View.
    2. Click by mouse on Projects toggle button on the left edge bar.
    3. Wait for Projects window slides from side.
    4. Right click the title bar and choose Transparent Window
    5. Click the Project window title once more
    • EXPECTED RESULT: Projects View isn't transparent. The transparency of window isn't persistent.


Test suite: Scrollable tabs in Window system

Purpose: The Window System uses scrollable tabs for managing open documents. A behavior of scrollable tabs is tested by next test cases and scenarios. The UI is specified in UI specification.
Setup: Start IDE with clear userdir.

  1. Scrollable tabbed pane - row of tabs
    1. Open three files.
    • EXPECTED RESULT: Document Window contains a line of tabs and on the upper right corner (or in the line of tabs) are left,right and bottom(quick list) scroll buttons, but only quick list button is enabled, left and right buttons are disabled.
  2. Scrollable tabbed pane - view of tabs
    1. Open ten files (as many files you need to have not all tabs visible).
    2. Push left scroll button to scroll tabs to the left (to show not fully visible the most left and the most right tab).
    • EXPECTED RESULT: All scroll buttons are enabled. The leftmost and the rightmost visible tabs are partially vissible tabs. All other tabs are fully visible between the leftmost and the rightmost tabs. Tabs that are on the left side of the leftmost visible tab or on the right side of the rightmost visible tab are hidden.
  3. Scrollable tabbed pane - tab width
    1. Open ten files (as many files you need to have not all tabs visible).
    2. Push left scroll button to scroll tabs to the left (to show not fully visible the most left and the most right tab).
    • EXPECTED RESULT: Each tab contains an icon, label and close button. Check the width for right partially visible tab (minimum and maximum) and left partially visible tab (minimum and maximum).
  4. Scrollable tabbed pane - layout state - tabs hidden on both sides
    1. Open ten files (as many files you need to have not all tabs visible).
    • EXPECTED RESULT: Tabs are hidden on the left side if the last tab is fully visible and the sum of preferred width of all tabs is greater than width of view. The left partially visible tab follows the beginning and end of label rule. The last tab is aligned with the right edge of view. In this state both scroll buttons are enabled.
  5. Scrollable tabbed pane - activating hidden tab
    1. Open ten files (as many files you need to have not all tabs visible).
    2. Select from the Quick list the tab hidden on the left (right) side.
    • EXPECTED RESULT: It is made the leftmost fully visible tab(it is made the rightmost fully visible tab) active.
  6. Scrollable tabbed pane - removing tab - hidden tab
    1. Open ten files (as many files you need to have the rightmost tab hidden).
    2. Select the hidden file in Document dialog and push Close button.
    • EXPECTED RESULT: Closing a hidden tab doesn't modify the tabs layout.
  7. Scrollable tabbed pane - resizing (tailing off) - active tab is the second one
    1. Open ten java files (as many files you need to have visible all tabs, but if once more open - will be partially or fully visible).
    2. Select the first tab.
    3. Resize the main window (make it smaller).
    • EXPECTED RESULT: The tab row doesn't move until selected tab becomes partially visible. The tabbed pane keeps selected tab inside the tabs view.
  8. Scrollable tabbed pane - resizing (enlarging) - active tab is the first one - the rightmost partially visible
    1. Open ten java files (as many files you need to have visible all tabs, but if once more open - will be partially or fully visible).
    2. Select the first tab.
    3. Resize the main window (make it smaller) - to the rightmost tab is partially visible and last one is hidden.
    4. Resize the main window (enlarge).
    • EXPECTED RESULT: The first tab is active and fully visible while resizing and the tab view is aligned to the right edge of tabs (it means leftmost partially visible tab isn't changed) until all tabs visible then the tab row alignes to the left edge of tabs view.
  9. Scrollable tabbed pane - scrolling to the left
    1. Open ten java files (as many files you need to have the leftmost(third) tab partially visible, the first and second tabs are hidden).
    2. Select the last tab.
    3. Push left scroll button.
    • EXPECTED RESULT: The last tab is active while scrolling. It makes the left partially visible tab (the third tab) the leftmost fully visible tab, the first left hidden tab (the second tab) the left partially visible tab and the first tab is hidden.
  10. Scrollable tabbed pane - scrolling to the right
    1. Open ten java files (as many files you need to have the rightmost(two before last) tab partially visible, the last and one before last tabs are hidden).
    2. Select the first tab.
    3. Push right scroll button.
    • EXPECTED RESULT: The first tab is active while scrolling. It makes the right partially visible tab (the two before last tab) the rightmost fully visible tab, the first right hidden tab (the one before last tab) the right partially visible tab and the last tab is hidden.


Test suite: Floating Windows

Purpose:
Setup: Start IDE with clear userdir. Have default settings of window system effects.

  1. Create floating window
    1. Drag a window/tab outside of the main window area
    • EXPECTED RESULT: New window is created. The window is called floating window. This behavior completely replaces old SDI mode of IDE.
  2. Half transparent non focused floating windows
    1. Let a floating window to lost the focus
    • EXPECTED RESULT: After some time when it loose focus the window becomes half transparent
  3. Focused half transparent non focused floating windows
    1. Give focus to transparent floating window
    • EXPECTED RESULT: Focus floating window is non-transparent again. It becomes transparent when it lost focus again.
  4. Window snapping of two floating windows
    1. Have two floating windows
    2. D'n'd one window close to side of the other one
    • EXPECTED RESULT: it automatically snaps to the sides of other window.
  5. Window snapping to screen edges
    1. Have a floating window
    2. D'n'D the floating window to side of the edge of the screen.
    • EXPECTED RESULT: It automatically snaps to the screen edge.


Test suite: Multiview

  1. Multiview - switching between Source and Design
    1. Open some form file.
    2. Select main menu View | Editors | Source.
    3. Select main menu View | Editors | Design.
    4. Push the Source button at the top-left corner of the editor pane.
    5. Push the Design button at the top-left corner of the editor pane.
    • EXPECTED RESULT: In each case if you click on Source, the Source of the form file is the current opened file. Otherwise, if you click on Design, form design of the form file is the current opened file.


Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo