NetBeans 69 Supported Platforms

Java SE

  • 6.0 - Full test : Win, Linux, Solaris 10, Mac OS X
  • 7.0 - Acceptance test: Win, Linux, Solaris 10
  • OpenJDK - Sanity test: Linux, OpenSolaris

Testing is done on Java SE update release available no later than 1 month prior RC1. 32bit JVM is the priority. 64 bits JVM will be tested if time permits

  • NOTE - Java SE 5 is NOT supported platform for NetBeans 6.9!

JavaFX

SoMa (1.3?) when FCS build is available.

Operating Systems

Check specifics of Java SE on particular OS

Windows Linux Solaris Mac OS X
Full test Windows XP Pro SP3 Ubuntu 9.10 Solaris 10 10.5 Intel
Acceptance test Windows 7 Professional Ubuntu 10.04 (April 2010)
Oracle Enterprise Linux 5
OpenSolaris (automated only) 10.6 Intel


32 bits OS are priority ones, 64 bit OS will be tested only if time permits

Look and Feels on each OS are:

  • GTK - running on Gnome and JDK 6u1 or newer
  • Metal - for JDK 1.5 and for JDK 6u1 or newer running on other VMs
  • Solaris - Metal
  • OpenSolaris - GTK
  • Mac OS X - Aqua

... details available on NBLookAndFeels


Servers and tested Java EE versions for particular servers

Full test Glassfish 3.0.1 , Tomcat 6.0 (Java EE5 + persistence in web, JAX-WS), JBoss 5.0
Sanity Glassfish v2.1.1, WebLogic 11g (10.3.3.0) , Tomcat 5.5, JBoss 4.2.3 (J2EE 1.4)
Acceptance AS 8.2 PE

Databases

Full test JavaDB(supplied with IDE), MySQL 6.x
Sanity test Oracle 11 thin JDBC driver 11.1.0.7
Acceptance test Postgres SQL 8.x, MSSQL ?


VCS

Full test Subversion 1.6, Mercurial 1.1
Sanity CVS 1.12

Emulator Platforms of Mobility Pack

Supported SDKs:

  • Sun Java Wireless Toolkit 2.5.2 for CLDC - Windows and Linux version - BUNDLED
  • Sun Java ME SDK 3.0

Possibly supported - depends on vendor support or quality of SDK

  • Java Card 3 SDK (Sun)
  • Sun Java Media Client (Sun)
  • RICOH SDK 1.14 (Ricoh)
  • BlackBerry (RIM)
  • MicroEmulator (http://www.microemu.org/)

Other 3rd party SW

  • Apache Ant 1.8 (any final version released before we go into high resistance mode)
  • Apache Maven 2.1.0 or later (any final version released before we go into high resistance mode)

... list may be longer, depends on libraries requested by Connected Developer

Issuetracking Support

  • BugZilla up to 3.4
  • Jira up to 3.4

Web Browsers

Windows 7 Windows XP Linux Solaris Mac OS X
Full test IE 8 IE 6/Firefox 3.5 Firefox 3.5 Firefox 3.5 Safari latest
Sanity test - - - - -
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo