FedoraPackagingNB65

Fedora - Packaging of the NetBeans 6.5

Contents


Overview

The NetBeans 6.5 is released for Fedora 11 (currently, it can be installed via the yum tool from the rawhide repo). See also Fedora 10 - How to install the NetBeans 6.5?

This page accumulates info about effort in the scope of the Bug 473075 - RFE: update NetBeans to 6.5 to create software packages of the NetBeans 6.5 that complement the Fedora 10, 11 (currently rawhide). Basic Cluster of the NetBeans 6.5 is the target software configuration to be packaged for Fedora.

The Basic Cluster includes NetBeans Platform, version 9. Source RPM for the netbeans-platform is already prepared (See Bug 475058 - Review Request: netbeans-platform - NetBeans 6.5 Platform 9). Note, the version number is not used in the name of the package since this release, and the new netbeans-platform package obsoletes the old package netbeans-platform8.

External dependencies

Sources: netbeans-6.5-200811100001-base-src-linux.tar.gz published here is the sources segment of released sources netbeans-6.5-200811100001-ml-src.zip accessible on the official page NetBeans IDE 6.5 Download.

=== BINARY LISTS in the netbeans-6.5-200811100001-ml-basic_cluster-src ===
./apisupport.feedreader/external/binaries-list
jdom-1.0.jar
rome-0.6.jar
rome-fetcher-0.6.jar
./db.drivers/external/binaries-list
mysql-connector-java-5.1.6-bin.jar
postgresql-8.3-603.jdbc3.jar
./db/external/binaries-list
derby-10.2.2.0.jar
derby-10.2.2.0.zip
./db.sql.visualeditor/external/binaries-list
javacc-3.2.jar
./hibernatelib/external/binaries-list
hibernate-3.2.5-lib.zip
./httpserver/external/binaries-list
tomcat-webserver-3.2.jar
./j2ee.toplinklib/external/binaries-list
glassfish-persistence-v2-build-58g.jar
glassfish-persistence-v2ur1-build-09d.jar
./junit/external/binaries-list
Ant-1.7.1-binary-patch-72080.jar
junit-3.8.2-api.zip
junit-3.8.2.jar
junit-4.5-api.zip
junit-4.5-src.jar
./lexer/external/binaries-list
antlr-2.7.1.jar
lexer-gen-antlr-2.7.1.jar
./libs.cglib/external/binaries-list
cglib-2.2.jar
./libs.commons_logging/external/binaries-list
commons-logging-1.1.jar
./libs.commons_net/external/binaries-list
commons-net-1.4.1.jar
./libs.freemarker/external/binaries-list
freemarker-2.3.8.jar
./libs.ini4j/external/binaries-list
ini4j-0.2.6.jar
./libs.jakarta_oro/external/binaries-list
jakarta-oro-2.0.8.jar
./libs.javacapi/external/binaries-list
javac-api-nb-7.0-b07.jar
./libs.javacimpl/external/binaries-list
javac-impl-nb-7.0-b07.jar
./libs.jaxb/external/binaries-list
activation.jar
jaxb-api.jar
jaxb-impl.jar
jaxb-xjc.jar
jsr173_api.jar
./libs.jsch/external/binaries-list
jsch-0.1.39.jar
./libs.lucene/external/binaries-list
lucene-core-2.3.2.jar
./libs.springframework/external/binaries-list
spring-2.5.jar
./libs.svnClientAdapter/external/binaries-list
svnClientAdapter-1.4.0.jar
svnjavahl-1.5.0.jar
./libs.xerces/external/binaries-list
xerces-2.8.0.jar
./o.apache.tools.ant.module/external/binaries-list
ant-libs-1.7.1.zip
ant-misc-1.7.1.zip
./o.apache.xml.resolver/external/binaries-list
resolver-1.2.jar
./o.jdesktop.beansbinding/external/binaries-list
beansbinding-1.2.1-doc.zip
beansbinding-1.2.1.jar
./servletapi/external/binaries-list
servlet-2.2.jar
./swingapp/external/binaries-list
appframework-1.0.3-doc.zip
appframework-1.0.3.jar
swing-worker-1.1.jar
./web.flyingsaucer/external/binaries-list
core-renderer-R7final.jar
./websvc.jaxws21/external/binaries-list
jaxws-2_1-api-doc.zip
jaxws-2.1.zip

Required Software Packages

The table below explains a list of the external Libraries that are required for the chosen configuration of the NetBeans IDE. The table also establish relation between required library and a Fedora package if it is exists.

External Binary File Module Cluster Fedora 10 Package Comments
activation.jar libs.jaxb ide10 Origin: jaxb.dev.java.net
Ant-1.7.1-binary-patch-72080.jar junit java2
It is patch for the Ant's <junit> task.
Ant-1.7.1-source-code-patch-72080.diff is inside of the Ant-1.7.1-binary-patch-72080.jar.
Installation image of the NB 6.5 contains ./java2/ant/patches/72080.jar (renamed Ant-1.7.1-binary-patch-72080.jar)
ant-libs-1.7.1.zip o.apache.tools.ant.module java2 ant-1.7.1
ant-libs-1.7.1.zip contains JARs of the Ant.
Installation image of the NB 6.5 doesn't contain ant-libs-1.7.1.zip
antlr-2.7.1.jar lexer ide10 antlr-2.7.7
Installation image of the NB 6.5 doesn't contain antlr-2.7.1.jar
ant-misc-1.7.1.zip o.apache.tools.ant.module java2 ant-1.7.1 ant-misc-1.7.1.zip contains /bin and /etc of the Ant
appframework-1.0.3-doc.zip swingapp java2 appframework-1.03
appframework-1.0.3.jar swingapp java2 appframework-1.03
beansbinding-1.2.1-doc.zip o.jdesktop.beansbinding java2 beansbinding-1.2.1
beansbinding-1.2.1.jar o.jdesktop.beansbinding java2 beansbinding-1.2.1
cglib-2.2.jar libs.cglib java2
NOT EXISTS
Library for extending JAVA classes and implementing interfaces at runtime.
Origin: http://cglib.sourceforge.net/
commons-logging-1.1.jar libs.commons_logging ide10
jakarta-commons-logging-1.0.4
commons-net-1.4.1.jar libs.commons_net ide10 jakarta-commons-net-1.4.1
core-renderer-R7final.jar web.flyingsaucer ide10
NOT EXISTS
Java XHTML+CSS renderer
Origin: https://xhtmlrenderer.dev.java.net/
derby-10.2.2.0.jar db ide10
NOT EXISTS
derby-10.2.2.0.zip db ide10
NOT EXISTS
freemarker-2.3.8.jar libs.freemarker ide10 freemarker-2.3.13
glassfish-persistence-v2-build-58g.jar j2ee.toplinklib java2
NOT EXISTS
glassfish-persistence-v2ur1-build-09d.jar j2ee.toplinklib java2
NOT EXISTS
hibernate-3.2.5-lib.zip hibernatelib java2
NOT EXISTS
ini4j-0.2.6.jar libs.ini4j ide10 ini4j-0.3.2
jakarta-oro-2.0.8.jar libs.jakarta_oro ide10 jakarta-oro-2.0.8
javac-api-nb-7.0-b07.jar libs.javacapi java2 netbeans-javaparser-6.1
javacc-3.2.jar db.sql.visualeditor ide10 javacc-4.0
javac-impl-nb-7.0-b07.jar libs.javacimpl java2 netbeans-javaparser-6.1
jaxb-api.jar libs.jaxb ide10
NOT EXISTS
Origin: jaxb.dev.java.net
jaxb-impl.jar libs.jaxb ide10
NOT EXISTS
Origin: jaxb.dev.java.net
jaxb-xjc.jar libs.jaxb ide10
NOT EXISTS
Origin: jaxb.dev.java.net
jaxws-2_1-api-doc.zip websvc.jaxws21 java2
NOT EXISTS
Optional documentation.
Not needed to build and run.
Origin: jax-ws.dev.java.net
jaxws-2.1.zip websvc.jaxws21 java2
NOT EXISTS
Description: JAX-WS Reference Implementation
Origin: jax-ws.dev.java.net
jdom-1.0.jar apisupport.feedreader apisupport jdom-1.0
jsch-0.1.39.jar libs.jsch ide10 jsch-0.1.39
jsr173_api.jar libs.jaxb ide10
NOT EXISTS
Origin: jaxb.dev.java.net
junit-3.8.2-api.zip junit java2 junit-javadoc-3.8.2
Optional documentation. Not needed to build and run.
junit-3.8.2.jar junit java2 junit-3.8.2
junit-4.5-api.zip junit java2
junit-4.5-src.jar junit java2 SRPM? :-)
TODO Check it: Optional sources. Not needed to build and run.
lexer-gen-antlr-2.7.1.jar lexer ide10
Does antlr-2.7.7 provide it?
lucene-core-2.3.2.jar libs.lucene ide10
lucene-2.3.1
CHANGES
Origin: lucene.apache.org
Source: svn.apache.org/repos/asf/lucene/java/trunk
mysql-connector-java-5.1.6-bin.jar db.drivers ide10
mysql-connector-java-3.1.12
postgresql-8.3-603.jdbc3.jar db.drivers ide10
postgresql-8.3.5
resolver-1.2.jar o.apache.xml.resolver ide10
netbeans-resolver-6.1
upgrade to 6.5 (xml-commons-resolver-1.2)
rome-0.6.jar rome-0.9
rome-fetcher-0.6.jar
Required in apisupport.feedreader
rome.dev.java.net
Rome Fetcher, Java Apis to retrieve RSS Feeds
servlet-2.2.jar servletapi ide10
Check it! tomcat5-servlet-2.4-api-5.5.26.jar tomcat5-jsp-2.0-api-5.5.26.jar
or
tomcat6-servlet-2.5-api-6.0.18.jar tomcat6-jsp-2.1-api-6.0.18.jar
servlet-2.2.jar includes:
javax.servlet.*
javax.servlet.http.*
javax.servlet.jsp.*
javax.servlet.jsp.tagext.*
Source: jakarta-servletapi-src.zip
Comment: Servlet API 2.2 is a JCP standard, however we are including it under the Apache 1.1 license, as it comes with Tomcat 3.2, which includes it under the OSR: 87170
Origin: http://java.sun.com/products/servlet/2.2/
Description: Java Servlet API
spring-2.5.jar
svnClientAdapter-1.4.0.jar
eclipse-subclipse-1.2.4
svnjavahl-1.5.0.jar subversion-javahl-1.5.4
swing-worker-1.1.jar swingapp java2
As of Java 6, SwingWorker is included in the JRE.
tomcat-webserver-3.2.jar httpserver ide10
xerces-2.8.0.jar xerces-j2-2.7.1
TODO 2.7.1 was applicable for 6.1, but it should be tested for 6.5


Ant patches

Installation image of the NB 6.5 contains:

  • ./java2/ant/patches/72080.jar
  • ./java2/ant/patches/ant-42275.diff
  • ./java2/ant/patches/ant-42275.jar
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo