FaqSelectDocumentInView

How do I quickly find the current file in Projects/Files/Favorites view?

Say you're editing a file in editor and you need to quickly find the respective node in the Projects, Files or Favorites view. Obviously, you can select the view and start expanding packages or folders and try to locate an object that may be nested several levels deep. This can be very annoying.

Fortunately, there is a quicker way:

NetBeans 7.0 and later

Use the editor popup menu Select In Projects to locate the current file in the Projects view. Or use main menu Navigate > Select in Projects, Navigate > Select in Files or Navigate > Select in Favorites to locate the file in Projects, Files and Favorites views, respectively. Or, even quicker, press Ctrl-Shift-1 for Projects, Ctrl-Shift-2 for Files, Ctrl-Shift-3 Favorites.

You can also try the main menu View > Synchronize Editor with Views.

NetBeans 6.9 and earlier

In addition to the main Navigate menu and the shortcuts described above, the editor's popup menu contains Select in submenu. Choose Projects, Files or Favorites to locate the file in the corresponding view.

The main menu option View > Synchronize Editor with Views is in NetBeans 6.7 and later.

NetBeans 4.x

NetBeans 4.1 use the main menu Window > Select Document in and select the view (Projects, Files, Favorites) that you want to locate the file in.



Applies to: NetBeans 4.1, 5.x, 6.x, 7.x

Platforms: All

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo