FaqRunningRubyIdeOnJre

Since NetBeans 6.5 the IDE does not require a JDK but only a JRE.. There are however some features in the NetBeans Ruby IDE that do require a JDK:

  • Creating .war files out of Rails applications. The jar command, which is needed for creating .war files, is not part of the JRE. More specifically, it is needed by Warbler which the IDE uses for this task. Typically users wanting to create .war files likely need a JDK anyway, since .war file are meant for deployment to Java application servers that usually require a JDK.
Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo