FaqInstallCantInstallAppServerOnMacJa

AppServer のインストーラが MacOS 10.4 の JDK 1.5.x で失敗しました。どうすればよいでしょうか?

sjsas_pe-8_1_01_2005Q1-nb-4_1-macosx.jar のバイナリは AppServer と NB4.1 を同時にインストールします。インストール時に Java 1.5.0_03 を選びました。NetBeans 4.1 はインストールに成功しましたが AppServer はインストールされませんでした。

MacOS では AppServer のインストールは 1.4.x 上で行う必要があります。

MacOS では AppServer のインストールは JDK 1.5 では動作しません。回避策: まずインストーラでは JDK 1.4.2 を選択してください。JDK 1.5 の開発は IDE が 1.4.2 を使っていても可能です。ツール|プラットフォームマネージャー で 1.5 の JDK プラットフォームを追加してください。インストールした後にも IDE の使う JDK を変更 したり、その 設定を永続化することができます。

NetBeans 5.0 と SJS AS 8.2 のバンドルは JDK 1.4.2 と JDK 1.5.0 両方をサポートしています。つまり JDK 1.4.2 か JDK 1.5.0 を選択できます。



  バージョン: NetBeans 4.1
  プラットフォーム: MacOS

Not logged in. Log in, Register

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo